nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   startx hangs my computer (http://www.nvnews.net/vbulletin/showthread.php?t=87464)

zebdits 03-03-07 12:06 PM

startx hangs my computer
2 Attachment(s)
I recently purchased a GeForce 8800 GTS OC. I can get it sort-of working with the vesa driver (widescreen resolutions don't work, but other than that it's OK), but with the nvidia driver 9746, startx just hangs my computer.

It gets as far as declaring (on the console window) that it is using /etc/xorg.conf. And then it just hangs. Doesn't go into graphical mode - or sometimes the screen flashes for an instant and then immediately back into console mode.

And it just hangs forever. I have to hard power down my computer. This leads to lots of "drive wasn't unmounted properly" errors when I restart it; I'm starting to get worried that I'm going to kill my hard drives just by trying to solve this problem.

/var/log/Xorg.0.log doesn't show anything. And I don't just mean "it doesn't show any errors", I mean that it shows output from the last time that I successfully started X with the vesa driver. As if the attempt to start X using the nvidia driver didn't update the log at all.

I've tried using xorg.conf exactly as created by nvidia-xconfig, and I've tried it with various tweaks. All give this same problem. I am attaching a couple xorg.confs (which will be described at the end of this post).

I am starting to get worried that the card is not supported by 9746: The "Release Highlights" of the driver version's <a href="http://www.nvidia.com/object/freebsd_1.0-9746.html">page</a> claims that support was added for "GeForce 8800 GTS" (I checked this before I bought the card), but the box actually says "GeForce 8800 GTS OC". Is that "OC" meaningful in this context?

So, a few questions:

(1) Uh, can anybody magically fix this? Please?

(2) If not, has anybody ever seen something like this? Have any ideas? Any suggestions? Any questions? Et cetera?

(3) Is, or is not, a GeForce 8800 GTS OC supposed to be supported by 9746?

Now, information about the xorg.conf files that I am attaching:

(1) xorg.conf.nv.txt: This is exactly as created by nvidia-xconfig, and causes the computer to hang.

(2) xorg.conf.vesa.txt: I had been using an ATI card, with the VESA driver. This is (almost) exactly the file I had been using to drive that card; it also works with my new NVIDIA card (except that I can't get widescreen to work, which is the whole point of this exercise). The one difference between this file and the one that I had been using to drive the ATI card is that I have changed the BusID from PCI:6:0:0 to PCI:5:0:0. This is because (while investigating the NVIDIA problem), I noticed a potential IRQ conflict between the NVIDIA board and an ethernet controller that I wasn't using. So, I disabled the ethernet controller in the BIOS, and after that, the VESA config (set up for PCI:6) started complaining that it couldn't find a device in xorg.conf for PCI:5. I switched to PCI:5, and the VESA xorg.conf started working again (with my NVIDIA board).

I have also tried manually modifying the VESA xorg.conf as described in the NVIDIA README - i.e. replacing driver "vesa" with "nvidia", getting rid of "dri" and "GLCore" (although the latter wasn't present in the first place), adding "glx". This results in the same problem - my computer hangs on startx, while still displaying the console, and must be hard powered off.

Thanks in advance for any help.

zebdits 03-03-07 12:09 PM

Re: startx hangs my computer
Forgot to mention - I also tried a xorg.conf created by "Xorg -configure". Same problem occurs.

zebdits 03-04-07 01:04 PM

Re: startx hangs my computer
A little further information:

FreeBSD 6.2 Release, SMP.

Output of dmesg shows nothing out of the ordinary.

zebdits 03-07-07 11:31 PM

Re: startx hangs my computer
Well, the new 9755 driver gets a little bit farther, but...

Instead of just hanging the computer while still in console mode, it clears the screen and then hangs the computer.

And instead of just not updating Xorg.0.log at all, it moves Xorg.0.log to Xorg.0.log.old, creates a new Xorg.0.log, and puts no information into it at all (i.e. the file is zero bytes long).

Any help, please?

adamk75 03-08-07 10:47 AM

Re: startx hangs my computer
Add the 'sync' option to your /var entry in /etc/fstab. That should, hopefully, get you actual information in /var/log/Xorg.0.log.


anonuser 03-08-07 01:09 PM

Re: startx hangs my computer
You might want to try an include a module path in your xorg.conf but i may have just not have seen it.

Also comment out the VertRefresh and HorztRefresh and let it use values from the card.

zebdits 03-10-07 06:30 PM

Re: startx hangs my computer
OK, thanks for the suggestions. I turned on syncing on /var, and did get some information in Xorg.0.log.

I tried it twice - once, I turned the computer off after about a minute of hanging; the other time, I let it go for several minutes. The "several minutes" case got far more information into Xorg.0.log than the "about a minute" case did. So it seems like maybe it is doing stuff, but very, very slowly?

I am attaching both copies of Xorg.0.log - the "about a minute" case is Xorg.0.log.1.txt, and the "several minutes" case is Xorg.0.log.2.txt.

I saw only one thing in there that struck me as odd - at the very end of the "several minutes" one, there is the following line:

(--) NVIDIA(0): No video decoder detected

I don't really know much about this stuff, so I'm not sure if that's actually a problem, but it looked suspicious, at least.

Any more ideas?

I will try doing this one more time, and letting it go overnight, to see if anything else eventually gets into Xorg.0.log.

Thanks again.

zebdits 03-10-07 06:37 PM

Re: startx hangs my computer
3 Attachment(s)
Whoops - didn't attach them. I will do so in this post (I hope).

Also, forgot to mention - regarding the other suggestion:

I have tried it without Vert/Horiz stuff, and also with a ModulePath. Still get the problem.

Also, I am attaching the latest xorg.conf that I used (with the results described in my post of a moment ago). This was created by nvidia-xconfig, and apparently is a merge of my old (working) vesa xorg.conf with whatever nvidia-xconfig decided was good.

jamie 04-12-07 09:50 PM

Re: startx hangs my computer
When it 'hangs', assuming the machine itself hasn't really crashed, you should be able to do:


to get back to console, then control-c to abort the startx - you should also see some messages on the screen which may help.

All times are GMT -5. The time now is 12:36 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.