nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Instal successful, reboot failiure (http://www.nvnews.net/vbulletin/showthread.php?t=87469)

nukoso 03-03-07 01:42 PM

Instal successful, reboot failiure
 
2 Attachment(s)
Hi, i have a HP DV6150la, full specs (actually are for 6150br, but everything is the same):

Code:

http://h10025.www1.hp.com/ewfrf/wc/document?docname=c00791596&lc=en&cc=us&dlc=en&product=3289609&lang=en
it has a NVIDIA GeForce Go 6150 chipset on it.

I'm running ubuntu 6.10 Edgy Eft. I have everything working on it but the video, I must use Vesa driver to run Gnome, but it has a 1024x768 res. and its quite slow...

I downloaded the NVIDIA-Linux-x86_64-1.0-9746-pkg2.run, killed gnome (sudo /etc/init.d/gdm stop) and installed:

. During installation, it searched for a kernel on the ftp server but it couldn't find one for me, so it compiled a new one, installed, and i started gnome with startx, it ran ok, after that i rebooted (sudo reboot) and it crashed.

on the xlog it says:

Quote:

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0): that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0): that the NVIDIA device files have been created properly.
(EE) NVIDIA(0): Please consult the NVIDIA README for details.
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "ramdac"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
on startup it said that kernel was 7184 and drivers were 9746.

I tried with 7184 legacy drivers (NVIDIA-Linux-x86_64-1.0-7184-pkg2.run) as well, but no luck either.

What sould I try in order to get it working, I don't know why if i start X (with startx) just after install without reboot it runs, but when i reboot it doesnt. I tried rebooting inmediatly after install, but the result was the same. any help would be greatly appreciated, I attach the Xorg.0.log and nvidia-bug-report.log

Can I use x86 drivers even if I'm on a turion64x2 with ubuntu x64??

thanks a lot!.

AaronP 03-03-07 04:31 PM

Re: Instal successful, reboot failiure
 
Have you followed the instructions in this sticky post? http://nvnews.net/vbulletin/showthread.php?t=72490

nukoso 03-04-07 03:20 AM

Re: Instal successful, reboot failiure
 
yeah i've already done that:
Quote:

development tools like make and gcc are installed: both are installed
* the linux-headers package matching the installed Linux kernel is installed linux-headers-2.6.17-11-generic installed on its last version
* the pkg-config and xserver-xorg-dev packages are installed Both installed and on its last version
* the nvidia-glx package has been uninstalled with the --purge option and the file /etc/init.d/nvidia-glx does not exist. I did: sudo dpkg --purge nvidia-glx and there's no /etc/init.d/nvidia-glx
Quote:

If you use Ubuntu, please also ensure that the linux-restricted-modules packages have been uninstalled. Alternatively, you can edit the /etc/default/linux-restricted-modules configuration file and disable the NVIDIA linux-restricted kernel modules (nvidia, nvidia_legacy) via:
DISABLED_MODULES="nv"
unistalled every linux-restricted-modules pakage and edited /etc/default/linux-restricted-modules adding:
Quote:

DISABLED_MODULES="nv"
then installed... but no luck!...
I've also updated BIOS with the same exact results.... :(

nukoso 03-04-07 01:05 PM

Re: Instal successful, reboot failiure
 
2 Attachment(s)
Re-verified everything, and them re-installed with:
Quote:

sh NVIDIA-Linux-x86_64-1.0-9746-pkg2.run --kernel-source-path /lib/modules/$(uname -r)/build
Failed again to start but the error messages were different, then used "nvidia-bug-report.sh" and "startx --verbose 6"

noticed on Xorg.0.log the following:

Quote:

(--) PCI:*(0:5:0) nVidia Corporation C51 PCI Express Bridge rev 162, Mem @ 0xb2000000/24, 0xc0000000/28, 0xb1000000/24
(--) PCI: (0:10:3) nVidia Corporation MCP51 PMU rev 163, Mem @ 0xb0040000/18
and somewhere in the middle:
Quote:

(WW) NVIDIA: No matching Device section for instance (BusID PCI:0:10:3) found
(--) Chipset NVIDIA GPU found
Any ideas?? is that the reason why it can't be started?
Thanks a Lot!

netllama 03-04-07 01:23 PM

Re: Instal successful, reboot failiure
 
The only thing that I see in the latest bug report is:
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***

However, there's no other information in the bug report as to why this failure occurred. Can you check dmesg output immediately after hitting this failure and see if there are any NVRM messages at the end?

Thanks,
Lonni


All times are GMT -5. The time now is 07:02 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.