nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA GeForce 7, 8, And 9 Series (http://www.nvnews.net/vbulletin/forumdisplay.php?f=5)
-   -   Works great the first time! (http://www.nvnews.net/vbulletin/showthread.php?t=880)

whoever 08-18-02 03:31 PM

Works great - 1 time!
Wierdness details: Win98SE, Asus P3V4X P3 1ghz, 256mb cas 2 ram, GF4-TI4200, all of the latest drivers, 3Dmark 2001SE = 6986. Will run test indefinitely. No overclocking cpu or gpu. So the problem is, it will run any game the first time for as long as I can stand to play, no funny stuff. Starting the game a second time results in a total system lockup after 15 seconds up to 2 minutes. I am talking a wide range of games from Carmageddon TDR2000, to GTA3, with No One Lives Forever in between as far as age/technology. Re-booting, changing settings, disabling everything in the system tray, nothing makes a difference. If I'm able to play a game for the first time for as long as I want, but can never play again regardless of settings, and I change nothing in the system in between, can anyone guess what is going on? It's as if the games write a config file on exit that borks the game after a re-load. This system is otherwise 100% stable, and all of the games ran fine (albeit with lower framerates) with my prior Voodoo3 3000. I ran the setup redetection programs for all games prior to running with the new card. In all cases the new card was properly detected and the game ran fine the first time. I've read all of the postings that seemed relevant here including a post of the P3V4X being to "old", but my point is, if it will run perfectly once, why won't it run again?

Uttar 08-18-02 03:50 PM

Hmm, first, that's a VERY low 3D Mark score in my opinion. With a non-overclocked GF4-Ti4200 and a Athlon XP 1700+, i get a little more than 9000! Sure, 1ghz CPU is low, but that score, says locking is not your only problem - there's more than that.

Okay... So...

1. In your BIOS, you *are* activating AGP and not PCI, right? And you ARE activating the highest AGP setting you can ( 2x or 4x, not sure what it is on your motherboards )

2. Are you enabling AGP fastwrite? If so, you could try to see if you still got the problem without it. If you didn't activate it, activating it shouldn't make the problem bigger. Also, if you aren't doing so, it might be a good idea to activate Side Band Adressing to increase performance.

3. You DID uninstall the Voodoo 3 3000 drivers correctly, right?

4. Did you install the latest Detonator drivers?

5. Also, "Graphic Win Size" or "Aperture Size", names depend on BIOS, is activated? If it isn't, activate it. If nothing else works, try disactivating it.

You might want to try flashing your BIOS, who knows... don't have a lot of ideas, it's a pretty odd problem.

If REALLY nothing works, your last chance might be formatting your HD and reinstalling windows. But before that, you better see if anyone else got ideas.


whoever 08-18-02 09:22 PM

Thanks for your reply. I'll try to answer your questions in order. As to the score of 6986, using Madonion's online browser, I have been able to determine that this is a normal score for this motherboard/chipset. If I had been able to get any stability, I was going to overclock - this processor/mobo/memory combo runs at a 150 fsb no problem (with the voodoo card).

1. Bios is set for 4x agp traffic with SBA enabled. The 4200's properties, 3dmark and Sandra all agree.

2. AGP fastwrite is enabled. I disabled and re-ran 3Dmark 2001, score went from 6986 to 7517! So much for fast write.

3. I removed the Voodoo card in device manager, and uninstalled the 3dfx tools program from add/remove.

4. The driver is listed as

5. Aperture size is set to 64meg

6. Bios is flashed to the last version available (1.005) as Asus no longer supports this board because it's (choke) 2 years old. (Thanks Asus!)

After the fast write increase I ran 3dmark in loop mode for 40 minutes at default settings (1024X768 32 bit) with no problems. I started up GTA3 and did nothing at the games' opening screen (on the bridge) and it locked up in 48 seconds. I got Aquanox bundled with this card, so I installed and played through the 1st part, taking my time and moving about in a non-linear fashion. After the 1st mission had completed, I exited the game, rebooted and restarted the game. It locked up in just under 2 minutes!

I could handle this nonsense if it always locked up. That would mean a power supply problem, or a heat problem, but it just blows me away that 3dmark runs forever, and all games run fine the first time. That proves that the system can handle it. I keep going back to what changes between the initial game play and subsequent reloads. Did I mention that the 4200 can't even do 640X480/16 on reloads, but runs initially at 1024X768/32?
At this point I agree that a complete windows re-install is the next logical move, but I think I would rather shoot myself than deal with 60 gigs. Or I could just re-install my V3-3K and play games at 800X600 16 bit until I can afford a whole new system that the 4200 can handle. Sort of like buying a whole new car because the battery won't hold a charge!

If you (or anyone else) has any further suggestions, please post. You might just be preventing a suicide. (Just kidding folks).

SavagePaladin 08-19-02 12:59 AM

people do underestimate the importance of the CPU I've noticed...
All I can honestly say is check for Windows patches and shiz.
maybe some 3dfx files and crap are still there. Lots of companies have had problems with drivers such

saturnotaku 08-19-02 08:59 AM

Try setting your AGP aperture to 128 as that's the setting that GF4 Ti cards seem to be the most comfortable.

whoever 08-19-02 01:52 PM

As part of the troubleshooting process, I backed off on my up-to-date Via 4-in-1 drivers v4.40 and re-installed v4.35 on advice from the via forums. Whenever a new video card is installed on this mobo, or the drivers change, it always installs in windows at AGP2X, regardless of the bios settings. There is a registry key supplied by Asus support that they claim is a "Windows AGP 4X turn-on key". This key is named "ViaAgp4x.reg". It's content is[HKEY_LOCAL_MACHINE\Software\NVIDIA Corporation\Global\System]"EnableVia4x"=dword:00000001. Indeed when this key is inserted, windows, card properties, and 3dmark all report 4X as being enabled. This is suspect however, because with 4X enabled in bios, my 3dmark 2001 reported a speed of 6875 before the key change and 6889 after, so it certainly makes hardly any difference speed wise. With this key in the registry however, the mysterious locking issue occurs on all game re-loads. If I change the key's last digit to 0, everything reports AGP2X and all games run perfectly. I tested GTA3 for several hours continuously with no problems at all. It appears that the "turn-on key" is not much more than "window dressing" and certainly borks the system. Whether or not this board actually runs at 4x is anyone's guess, but it certainly won't run anything but 3dmark with this registry key turned on. Now that it actually works, I'm off to tweak land to try and raise scores in 3dmark, but since that test is so easy to fool, maybe I'll just enjoy some of my games first! Thanks to all, and I hope this info may help someone else saddled with a Via chipset.

Wang 08-19-02 05:34 PM

SBA/FW problems?
Last week on a whim I activated SBA+FW on my GF3.
Holy Crap! Lock-up city in WinMe and Safe-Mode!

I couldn't deactivate the settings unless I re-installed WinMe.
It would freeze @ desktop and in Safe-Mode (no-reg boot)

Had to put my GF2 back in (it was stable w/SBA+FW) to
deactivate the settings in RivaTuner.

GF3 works great again! I don't know which setting borked
my card. I think it's SBA, or a combi of both?

Anyways, to me, it's not worth the system instability.

Soyo sv7a - P3 933 (Via 133a) 4in1-turbo 4x agp.

whoever 08-19-02 07:25 PM

Hey Wang,
As you can see from my sad tales of terror above, the problems between Via chipsets and Nvidia cards is an ongoing battle. Remembering all of the posts of problems in the past several years, I specifically held on to my trouble-free Voodoo card until it was just to far behind the curve. Hoping that Nvidia and Via had reached some level of cooperation by now, I took the plunge and was rewarded with hours and hours of troubleshooting. Basically the Nvidia/Via combination will always be volatile and a real minefield awaits those who are brave enough to change any performance settings beyond the default installation. More details on the continuing conflict can be found at ViaArena.com. The faq's, troubleshooting sections and the forums are full of hints and tips and tales of woe, and I think that you and I are lucky that we figured out the solution to our individual problems in less than a week. There has always been a trade-off between stability and performance, but with the deadly Via/Nvidia combo, anything other than default is russian-roulette. My best suggestion to anyone brave (foolish?) enough to try fooling with settings is get that old 2-6 gig drive out of the scrap heap, install the operating system, various test programs and games, unplug your current main drive, and make the old drive work again as your test subject. Worst case = swapping drives back. It's a lot of trouble to go to, but it beats the hell out of reformatting your main drive.
For those about to bork, I salute you!

SavagePaladin 08-19-02 09:19 PM

I got an nforce. Only troubleshooting involved is user stupidity :D

whoever 08-20-02 07:22 AM

Old News
It looks like nothing's changed. I waited years to buy a new video card because I was hoping this would be resolved by now, but nothing has changed in 2 years...


--D-- 08-21-02 03:19 PM

Is it possible that you are running out of RAM? Check your free physical ram when you open and close your games. It might be that you are low on RAM and when you close applications, they don't release the RAM they were using properly.

rocketmanx 08-21-02 03:57 PM

This may seem like stupid question but, what version of DX is installed? Also, check to make sure the 3DFX opengl (opengl32.dll?- replace it with the one from your windows disk) driver is gone. I remember having similar problems with win98/3dfx cards and then switching to Nvidia cards. The fact that it runs fine the first time makes believe that it's definitely software and not hardware. Sounds like somethings not getting unloaded when the game exits.

All times are GMT -5. The time now is 08:03 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.