nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   General USB problems - help! (http://www.nvnews.net/vbulletin/showthread.php?t=88070)

inthedark 03-13-07 05:35 PM

General USB problems - help!
 
I'm really having trouble with this - contrary to what I previously said, USB is not working well at all.

1. USB storage devices (external Seagate HDD, Disgo flash drive) are only detected if they are plugged in when Ubuntu starts - you can eject them, but can't get them back on after that.

2. My Epson scanner is recognised under the Device Manager but not by sane. Actually I think that sane is not recognising it because:

3. lsusb just hangs - comes up with no results and I have to close the terminal window to stop its process. Therefore I guess that sane is a red herring at this point. Basically USB ain't working.

Can anyone help me with this? I know it's not a graphic problem but the USB is part of the NVidia chipset according to the Device Manager. If I need to post a log file, can you tell me which one? I've got everything else on this chipset working fine (ethernet, audio, twinview, etc..). This is the last thing that's stopping me switching off my Windoze partition!

badagentx 03-26-07 02:13 PM

Re: General USB problems - help!
 
I had the same problem with the usb storage issue. When I pluged in my flash drive and had my scsi hard disk connected the scsi disk would be bumped to sdb instead of sda. Try this after you reconnect your usb storage device mount it as sdb instead of sda it should work. I don't really use a scanner in linux so I can't help you here. Also if you have udev installed uninstall it. lsusb dosn't work with it installed also your scanner might work if it is uninstalled.

loura1 04-29-07 04:30 AM

Re: General USB problems - help!
 
go through the link

http://linuxera.com/content/view/181/2/


john:)

inthedark 04-29-07 06:03 AM

Re: General USB problems - help!
 
Quote:

Originally Posted by loura1
go through the link

http://linuxera.com/content/view/181/2/


john:)

Thanks, I've gone through the page you linked to, but it isn't helping me much - I'm afraid I'm not a C programmer (at least not at this level!). Are there any higher level tools which I can use to find out what is going on? As I said, lsusb just hangs the terminal window, so that's no use to me. The devices are detected and show under the device manager, just won't work.

The USB subsystem works perfectly under Windows, so I can only assume that the Linux drivers are at fault here, or that there is a configuration problem with these drivers or some other module conflicting...

Georg Black 06-13-07 01:36 AM

Re: General USB problems - help!
 
2 inthedark: Did you solve your problem? I have MB nvidia k8n4 deluxe and ubuntu 704 distro and lsusb get no results. I am finding help but no succes.
Thanks for your info.
GB.

jmsjr 06-25-07 03:52 AM

Re: General USB problems - help!
 
Quote:

Originally Posted by inthedark
I'm really having trouble with this - contrary to what I previously said, USB is not working well at all.

1. USB storage devices (external Seagate HDD, Disgo flash drive) are only detected if they are plugged in when Ubuntu starts - you can eject them, but can't get them back on after that.

What kernel boot parameter(s) are you using ?
What nVidia chipset ?

I have a similar situation as yours ( See link below ). In my case, I have an nVidia MCP51 chipset on a Compaq Presario V6017AU notebook. The only way I could get usb working is with "pci=noacpi", but this breaks audio, and I can't get nVidia's proprietary driver working. See:

http://www.nvnews.net/vbulletin/showthread.php?t=93781


All times are GMT -5. The time now is 12:49 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.