nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Cannot Modprobe without SMP? (http://www.nvnews.net/vbulletin/showthread.php?t=88127)

Laptop765 03-14-07 04:47 PM

Cannot Modprobe without SMP?
 
Hello all, I've got a strange problem with my nvidia-driver on Gentoo Linux.

I am running Gentoo Linux 2.6.18-r6 and emerged nvidia-drivers-1.0.9755-r1.

Initially I tried running my computer with HT enabled and SMP compiled into the kernel. I tried it without HT enabled in the BIOS and it seemed to have a performance increase. Naturally I now wanted to remove it from the kernel so things (i.e. video drivers) would not be compiled against it. I recompiled my nvidia drivers after recompiling my kernel and now I cannot modprobe nvidia.

The dmesg output:
NVRM: Can't find an IRQ for your NVIDIA card!
NVRM: Please check your BIOS settings.
NVRM: [Plug & Play OS] should be set to NO
NVRM: [Assign IRQ to VGA] should be set to YES
nvidia: probe of 0000:01:00.0 failed with error -1
NVRM: The NVIDIA probe routine failed for 1 device(s).
NVRM: None of the NVIDIA graphics adapters were initialized!

I find this weird because
1) I do not have those BIOS options.
2) The drivers work FINE when SMP is compiled into my kernel and the drivers are compiled against it.

Does anybody have any information that could be of use?


All times are GMT -5. The time now is 01:35 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.