nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Signs that graphics hardware is physically damaged or failing? (http://www.nvnews.net/vbulletin/showthread.php?t=8841)

rbininger 03-17-03 04:47 PM

Signs that graphics hardware is physically damaged or failing?
About a month ago, I made a post concerning my efforts to get my GLX libraries working after they mysteriously broke overnight. ( See old post: http://www.nvnews.net/vbulletin/show...&threadid=7647 ).

Unfortunately, I was never able to get my problem resolved, even after trying clean kernel installs and giving RedHat Phoebe-3 a try. Since I was in the market for a new hard drive, I pulled all the drives from my system and figured I'd start off with a completely fresh install.

To this point, I've determined that vanilla installs of all five RedHat releases from 7.0 to 8.0 yield a non working display. Every time, I wind up with exactly the same symptoms described earlier. If I try to run glxgears under the nVidia libraries and kernel module, it hangs X, though I can always still get out of X by escapes [CTL-ALT-BKSP or CTL-ALT-F2 or even Telnet from another machine and running kill or reboot]. Running glxgears under the vesa drivers w/ DRI however doesn't cause any problem, other than of course that I only get a paltry ~250fps in a window with the vesa drivers.

I'm at my wits end: I've adjusted all the recommended configs, changed appropriate lines in XF86Config, tried XFree versions from 4.0 to 4.3, removed and toggled every AGP nVidia probe feature/driver, done clean installs to remove any conceivable conflicting libraries (OSS and others), recompiled nVidia's software from source with and without SBA & FW under both gcc 2.9x and 3.xx, tried nVidia RPMs which I know previously worked ... all for a month now with no progress. All of this is with a machine that was once running UT2K3, Q3A and RTCW beautifully.

Just to test myself that I have been doing my installs correctly and modifying the appropriate files, I even went so far as to throw RH8.0 on different, similarly configured machine hardware and was able to get nVidia's GLX running five minutes after the initial post-install reboot. I then mirrored the /usr and /etc directories of the two machines to backup, and ran [diff] on the entire directory structures and config contents, and even ran [strings] against both machines' libraries and diff'ed the output of that.

So, has anyone ever experienced any similar issue that might be caused by a video device (or maybe another device such a sound card, memory or NIC going bad) or possibly a specific BIOS feature that could be changed that causes a problem with nVidia's driver _only_ on 4x AGP boards?

It's especially perplexing that as I write this, I'm using the installed PNY Verto GF4 4200Ti, which gives me rock solid stablility using the vesa driver @ 1024x768x16. But if I load the nVidia driver and GLX libraries (any from 2xxx up to 4191) I can't run the machine for 5 minutes, and can guarantee a lock-up if I launch any GL app.

Just want to gather some info and suggestions before I strip two otherwise perfectly working machines apart and start swapping NICs, AGP cards and memory.

I'm leaning towards the idea that my video card has begun to fail due to the fact that games and apps run fine and report fantastic framerates if I pipe their output to other terminals and hide X via escape, and that occasionally, if I tolerate watching the 1 frame per 10 seconds under nVidia's driver set, I often get flashes of wire-frames that have no textures (as if I'm looking at a red/black CAD display). Maybe the texture memory of my video card has gone bad?

Does anyone know the differences of how nVidia's driver vs. the generic drivers utilize the graphics hardware's features?

- Rich B

rbininger 04-03-03 12:53 AM

*sigh* Problem fixed, and it was in fact a faulty board.

After working for a month with software with no success, I finally broke down and tore the machine apart and stripped/swapped parts with another machine. Threw in an old GF2 MX I had available, and everything immediately worked.

So, after very close inspection of my PNY Verto GF4-4200 Ti 64Mb, I found corrosion around the solder joints of two of the eight capacitors on the board ... they looked like old alkaline batteries that had exploded and leaked battery acid. As I indicated previously though, whatever hardware functions these capacitors supported was only present with nVidia's drivers, not the XFree default nv driver.

I was able to get a very courteous Best Buy tech to replace the board, despite that BB's policy is normally only 30 days, and the board was approx 6 months old. Notably though, PNY's RMA staff was especially NON-helpful.

What I want to point out for other owners of PNY's boards though, is that my original board had other capacitors that were abnormally bulged or deformed, which implies they might have been defective from manufacture. The replacement board I received (EXACT same listed model, documentation and box) was in fact substantially different - it was silk screened in aqua blue as opposed to purple, and the layout, manufacturer and voltage ratings of the capacitors were significantly different, despite that the board serial numbers were the same. The cooling fan on the GPU was also of different manufacture and is now made of aluminum instead of plastic, so it doubles as a heat sink across half the length of the board.

I've scoured the web and have not found any info as to whether the first-gen Ti's produced by PNY were formally recalled, but it would appear to me that PNY is aware that there was a problem with their original hardware (or at least their component supplier's hardware).

I've been very happy with all the hardware I've ever purchased from PNY over the past several years, it's always been cost competitive and very reliable, and I am not trying to propogate any conspiracy theories, but as they say ... buyer beware.

- Rich B

sidewinder 05-07-03 02:44 PM

This is probably what happened to the capacitors.


All times are GMT -5. The time now is 09:59 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.