nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Weird xinerama behavior using 3 sceens(on 2 Nvidia Cards) (http://www.nvnews.net/vbulletin/showthread.php?t=88426)

llavalle 03-19-07 07:08 PM

Weird xinerama behavior using 3 sceens(on 2 Nvidia Cards)
 
Ok, here's my setup :
GF7900GT(1) --> 20" samsung lcd (dvi)
GF7900GT(2) --> 17" LG lcd (vga)
GF7600GS(1) --> 17" LG lcd (vga).


When I use only the 7900GT in twinview mode, everything is fine. I know I must configure an extra screen for the second video card. I did it, and all 3 screens showed data. Mouse was going from one to the other OK... but one problem tho : xinerama would only report 2 screens instead of 3!

One on the 7600GS and one on the 7900GT (the 2 screens combined).
That's kind of frustating cause apps show their screens in the middle of the 2 rights monitor...

Is there a way to fix that?? (telling xinerama to distinguish between the 2 card and between the 2 screen on the 7900GT)

Here's my xorg.conf file :

Using drivers : 1.0-9755 and Xorg 1.1 on gentoo

Code:

Section "ServerLayout"
    Identifier    "Layout0"
    Screen      0  "Screen0" 1280 0
    Screen      1  "Screen1" LeftOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    RgbPath        "/usr/lib/X11/rgb"
EndSection

Section "Module"
    Load          "dbe"
    Load          "extmod"
    Load          "type1"
    Load          "freetype"
    Load          "glx"
EndSection

Section "ServerFlags"
    Option        "Xinerama" "0"
EndSection

Section "InputDevice"
    # generated from data in "/etc/conf.d/gpm"
    Identifier    "Mouse0"
    Driver        "mouse"
    Option        "Protocol"
    Option        "Device" "/dev/input/mice"
    Option        "Emulate3Buttons" "no"
    Option        "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier    "Keyboard0"
    Driver        "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier    "Monitor0"
    VendorName    "Unknown"
    ModelName      "LG L1720B"
    HorizSync      30.0 - 83.0
    VertRefresh    56.0 - 75.0
    Option        "DPMS"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier    "Monitor1"
    VendorName    "Unknown"
    ModelName      "LG L1720B"
    HorizSync      30.0 - 83.0
    VertRefresh    56.0 - 75.0
    Option        "DPMS"
EndSection

Section "Device"
    Identifier    "Videocard0"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
    BoardName      "GeForce 7900 GT/GTO"
    BusID          "PCI:6:0:0"
EndSection

Section "Device"
    Identifier    "Videocard1"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
    BoardName      "GeForce 7600 GS"
    BusID          "PCI:5:0:0"
EndSection

Section "Screen"
    Identifier    "Screen0"
    Device        "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option        "TwinView" "1"
    Option        "metamodes" "CRT: 1280x1024 +1600+0, DFP: 1600x1200 +0+0; CRT: 1024x768 +0+0, DFP: NULL; CRT: 800x600 +0+0, DFP: NULL; CRT: 640x480 +0+0, DFP: NULL"
    SubSection    "Display"
        Depth      24
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "Screen"
    Identifier    "Screen1"
    Device        "Videocard1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option        "metamodes" "nvidia-auto-select +0+0"
    SubSection    "Display"
        Depth      24
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection


netllama 03-19-07 07:10 PM

Re: Weird xinerama behavior using 3 sceens(on 2 Nvidia Cards)
 
I'm I'm following you correctly, then this is expected behavior. Twinview counts as a single X screen (not two).

JaXXoN 03-20-07 07:55 AM

Re: Weird xinerama behavior using 3 sceens(on 2 Nvidia Cards)
 
Hi!

I have created a patch for the Xserver to fix that:

http://www.nvnews.net/vbulletin/show...7&postcount=10

regards

Bernhard

llavalle 03-20-07 11:03 PM

Re: Weird xinerama behavior using 3 sceens(on 2 Nvidia Cards)
 
Quote:

Originally Posted by netllama
I'm I'm following you correctly, then this is expected behavior. Twinview counts as a single X screen (not two).

What I mean is that the applications think I have 2 screens instead of 3... (when using 3 monitor on 2 cards)

When using only one card (2 monitors on 1 card) it's fine.

netllama 03-20-07 11:11 PM

Re: Weird xinerama behavior using 3 sceens(on 2 Nvidia Cards)
 
http://www.nvnews.net/vbulletin/showthread.php?t=46678

llavalle 03-22-07 10:19 PM

Re: Weird xinerama behavior using 3 sceens(on 2 Nvidia Cards)
 
1 Attachment(s)
Heres the report

netllama 03-22-07 10:22 PM

Re: Weird xinerama behavior using 3 sceens(on 2 Nvidia Cards)
 
As I stated earlier, you do have two X screens. One with Twinview, and a 2nd using the 7600GS card. There's nothing wrong here.

JaXXoN 03-23-07 01:54 PM

Re: Weird xinerama behavior using 3 sceens(on 2 Nvidia Cards)
 
Quote:

Originally Posted by netllama
There's nothing wrong here.

The situation is that loosing the nvidia twinview xinerama extension
can be pretty annoying for a triple-head setup. For details, please check:

http://www.nvnews.net/vbulletin/show...95&postcount=1
http://www.nvnews.net/vbulletin/show...7&postcount=10

regards

Bernhard

llavalle 03-23-07 10:04 PM

Re: Weird xinerama behavior using 3 sceens(on 2 Nvidia Cards)
 
Quote:

Originally Posted by JaXXoN
The situation is that loosing the nvidia twinview xinerama extension
can be pretty annoying for a triple-head setup. For details, please check:
Bernhard

Exactly. As soon as I enable a 2nd screen, Xinerama on the first one is lost.


All times are GMT -5. The time now is 09:21 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.