nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   resolution and graphical issues (http://www.nvnews.net/vbulletin/showthread.php?t=88469)

dusdus 03-20-07 01:16 PM

resolution and graphical issues
 
1 Attachment(s)
greetings,

My laptop, a Toshiba Satellite pro 6100 is a second hand one and I love 'm
Finally I got the Nvidia GeForce2 420 Go up and running, using the Envy-script to install the correct driver. I'm using ubuntu 6.10, downloaded yesterday :)
After installing the nvidia driver I got sounds, the system up and running, though a black screen.
It seemed I needed to add something to my xorg.conf:
Option "UseDisplayDevice" "DFP"

and indeed, that did the trick.

Problem now is, I can't change the resolution and I have some frustrating black stripe to the right of my screen; which is about 1.5 inch wide.
Chosing System --> Preferences --> Screen Resolution I can only chose 800x600 and 640x480. The refresh rate can be 50 or 52.

Before installing the nvidia drivers the resolution was 1024x768, and if I remember correctly the refresh rate was 60.

So I tried and it seems a lot of people have this problem.
As I dont know the actual sync and refresh rates, I had to try some generic ones:
Code:


Section "Device"
        Identifier        "NVIDIA GeForce4 420 Go"
        Driver                "nvidia"
        BusID                "PCI:1:0:0"
        Option                "UseFBDev"                "true"
        Option                "UseDisplayDevice"        "DFP"
        Option "IgnoreEDID" "1"
        Option "UseEdidFreqs" "0"
EndSection

Section "Monitor"
        Identifier        "Generic Monitor"
        Option                "DPMS"
        HorizSync        33-75
        VertRefresh        55-70
# 1024x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 64.11 MHz
  Modeline "1024x768_60.00"  64.11  1024 1080 1184 1344  768 769 772 795  -HSync +Vsync
EndSection

As you can see I've been experimenting a little with the lines IgnoreEDID etc, trust me also without those lines it simply wont work.

Code:

Section "Screen"
        Identifier        "Default Screen"
        Device                "NVIDIA GeForce4 420 Go"
        Monitor                "Generic Monitor"
        DefaultDepth        16
        SubSection "Display"
                Depth                1
                Modes                "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth                4
                Modes                "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth                8
                Modes                "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth                15
                Modes                "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth                16
                Modes                "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth                24
                Modes                "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

I've read and done a lot of how-to's concerning this problem and I have this feeling I'm overlooking some simple thingy...


Ah and now I've just tested something new.

I've followed the instruction on this website:
http://doc.gwos.org/index.php/Latest...OBLEMS_SECTION

7) If you own a GeForce4 420/440 Go or a GeForce4 MX 440 you should follow these steps:

etc...

Now it looks like I have a better/ the correct resolution, though all fit in a smaller part of the screen.
So now the screen which I can see ubuntu in is surrounded with black bars/borders!
It looks sharper though :P

and still, the application: System -> Preferences -> Screen Resolution says: 800x600.

So anyone has some bright ideas?!

dusdus 03-21-07 07:39 AM

Re: resolution and graphical issues
 
I've tried it with and without Modelines btw, but still I'm looking at a small part of the screen wich looks quite the same as if it has a resolution of 1024x768, though compressed in a small window.
The black borders are about 1-3 inches wide, it's like a window in a window.

To be honest I've tried quite a lot of things and my guess is I've been overlooking something...but what?

dusdus 03-21-07 11:40 AM

Re: resolution and graphical issues
 
SOLVED!!!

It seems the NVIDIA driver is NOT reading my (hardware-)EDID correctly, kinda bogus I know...

So someone helped me pointing out there a simple small program, freeware:
"Phoenix EDID Designer" http://www.tucows.com/preview/329441
This program lets you create a EDID-file. The NVIDIA-drive is actually able to read that correctly!

1. Open the program with wine or in windows
2. Import/ read your EDID file
3. Export it to raw-format, which will create a 128k file
4. add these lines in your xorg.conf:

Option "UseDisplayDevice" "DFP-0"
Option "CustomEDID" "DFP-0:/path/to/your/custom/edid-file/nameofedidfile.raw"

5. Remove all the crap you probably already have added in your xorg.conf (with all respect to all the helpfull people)
6. logout, kill X, startx
7. change resolution tot the correct size :)
8. Request NVIDIA to fix their driver :P

elgarfi 03-21-07 12:27 PM

Re: resolution and graphical issues
 
Quote:

Originally Posted by dusdus
SOLVED!!!

It seems the NVIDIA driver is NOT reading my (hardware-)EDID correctly, kinda bogus I know...

So someone helped me pointing out there a simple small program, freeware:
"Phoenix EDID Designer" http://www.tucows.com/preview/329441
This program lets you create a EDID-file. The NVIDIA-drive is actually able to read that correctly!

1. Open the program with wine or in windows
2. Import/ read your EDID file
3. Export it to raw-format, which will create a 128k file
4. add these lines in your xorg.conf:

Option "UseDisplayDevice" "DFP-0"
Option "CustomEDID" "DFP-0:/path/to/your/custom/edid-file/nameofedidfile.raw"

5. Remove all the crap you probably already have added in your xorg.conf (with all respect to all the helpfull people)
6. logout, kill X, startx
7. change resolution tot the correct size :)
8. Request NVIDIA to fix their driver :P

Hi dusdus,

i'm also having the problem that the driver seems to read my EDID incorrectly. I downloaded the PhoenixEDID Designer, and launched it with Wine, but i have no idea what to put into all those fields... might you give me some information for this? (I want to drive my CRT with 1024x768@100Hz, but the "nvidia"-driver reports my modeline as "invalid")

greetings
garfield

dusdus 03-22-07 04:46 PM

Re: resolution and graphical issues
 
Dont forget this is about nvidia not able to read the EDID. If you're doing this, I suggest disabling your modeline.

You dont fill in anything in the program. Follow these steps

1. Tools -> Extract Registry EDID
2. Select your device (hmm it doesnt seem to work with wine here anymore, I hope you have windows somewhere, cause personally i cant select a device and in windows I could)
3. click Extract EDID
4. File -> Export
5. change file-type to .raw
6. give it a name, e.g. custom_EDID
7. put in on your linux drive, e.g. /etc/X11/custom_EDID.raw
8. edit your /etc/X11/xorg.conf and in the Device section add:
Option "UseDisplayDevice" "DFP-0"
Option "CustomEDID" "DFP-0:/etc/X11/custom_EDID.raw"

:D

edit: made myself a little more clear


All times are GMT -5. The time now is 03:25 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.