nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   680i + Linux (http://www.nvnews.net/vbulletin/showthread.php?t=88705)

jduv 03-25-07 04:19 PM

680i + Linux
 
I recently bought and configured an ASUS P532-E SLI. Installing windows was easy beezy. Installing SuSE Linux 10.2, also easy. Except when I go to connect to the internet.

Neither of my NForce Nics will take a DHCP address. I'm using the version of forcedeth that comes with 10.2 64 bit, and in addition to the DHCP problem, if I unplug my nic and plug it back in the entire system locks up. I have also tried setting a static IP to the card and pinging my gateway router (192.168.1.1). This results in nothing as well.

Is there a fix for this, or must I go and buy a Linux supported NIC so that I can actually get on my network?

jduv 03-25-07 05:02 PM

Re: 680i + Linux
 
Nevermind. Due to some deeper googling, turns out you can fix this problem pretty easily within YaST. Simply go to configure your nic, click on advanced, and in the options field for the forcedeth module, msi=0 msix=0.

Fixed my problem.

netllama 03-25-07 10:37 PM

Re: 680i + Linux
 
This is an old BIOS bug. If you're already using the latest BIOS, you should report this to Asus.

jduv 03-26-07 03:05 PM

Re: 680i + Linux
 
Thanks for your reply, because the problem is happening again. I'll double check my bios version and post my results.

jduv 03-26-07 03:52 PM

Re: 680i + Linux
 
I have updated to BIOS rev 0902 and now both nforce NIC's are dead in both windows AND Linux. I have tried the "pull the psu plug" trick, and it didn't work. Suggestions?

netllama 03-26-07 03:55 PM

Re: 680i + Linux
 
report this to Asus.

jduv 03-26-07 04:00 PM

Re: 680i + Linux
 
On the phone with them now =D.

Thx for your help!

By the way, it's broken in Windows and Linux now. Hopefully I won't have to RMA this board...

jduv 03-26-07 05:20 PM

Re: 680i + Linux
 
Asus told me to reinstall my OS's. How lame is that. I can't get the damn things to work in Linux or Windows, so I'm guessing that's my only option =/.

jduv 03-26-07 07:30 PM

Re: 680i + Linux
 
Okay, after reinstalling windows the Nics work fine, but they do not work in Linux. I installed the forcedeth drivers that came with the board and the entire machine locked up. Anyone have any suggestions? Asus is telling me it isn't their fault and their BIOS should fix any issues like this.

Maybe I should move to another linux distro? Try 32 bit linux instead of 64 (although I don't see how that would change anything)?

netllama 03-26-07 09:02 PM

Re: 680i + Linux
 
If disabling msi support in the driver allows the NIC to work, then this is a BIOS bug.

jduv 03-26-07 09:14 PM

Re: 680i + Linux
 
okay I told Asus that, but apparently they didn't believe me. The NIC kind of works if I set msi=0 and msix=0, but it still occasionally locks up.

I have reported this to Asus but the tech support guy told me that using msi=0 and msix=0 is required in order for forcedeth to work. I can provide screenshots that my BIOS is the newest revision.

What can I do now? I really really appreciate your help netllama.

netllama 03-26-07 09:25 PM

Re: 680i + Linux
 
Disabling MSI support is definitely not required for forcedeth to work. I'd suggest asking the Asus tech how they came to that conclusion, as NVIDIA did not recommend it.


All times are GMT -5. The time now is 05:42 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.