nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   NEED HELP GF7600GS on openSUSE 10.2 (http://www.nvnews.net/vbulletin/showthread.php?t=88767)

generaleskimo 03-26-07 08:38 PM

NEED HELP GF7600GS on openSUSE 10.2
 
Ok, I need Help with GF7600GS on openSUSE 10.2. I am a fairly new linux user, and this is the first time I have tried openSUSE. I installed openSUSE 10.2 on a machine. At the end of the install (to my surprise), it told me that my graphics card, which it correctly identified as a GeForce 7600GS, was not in its list of supported cards (even though they list it as supported online).

On this page was the resolution/monitor configuration. No matter what resolution I set it to (even if it was the same resolution as the one displaying on the screen), when I told it to "test settings", the screen would go black. On the CRT I used originally, the monitor said something about the frequency being out of range. I tried it on 3 different CRT's, and they all said either this, or just went completely black (sleeping). When I tried it on a Dell LCD monitor, it also just went black. I was able to skip this page, as no resolution worked, and continued to the desktop. When trying to configure the resolution correctly through the GNOME interface, I had the same results with all monitors I tried on. I then tried to install the drivers. I successfully obtained the drivers, as the NVIDIA guide said to do, and they seemed to be installed on my system. I rebooted to allow them to take effect, but when I opened it up again, nothing seemed to have changed. YasT lists both packages as installed, but when I configure my graphics card, it still says that it is not on the supported list and that it does not have a driver. I tried to configure XGL, but it had an error every time. Then, when I went to configure the graphics card/monitor again, most of the resolution choices yielded the same error message as before, saying that SaX2 had run successfully, but no response from Xgl. I continued trying different resolutions until one (I don't remember which) caused my screen to go completely back again. I didn't remember the ctrl+alt+backspace command, and I didn't want to wait for it to default to my old resolution (1024x768, which doesn't work even if I try using it). So, I hit "enter". My screen returned instantly telling me that my settings had been saved!!!

Later, when I was trying to re-install the NVIDIA drivers again, I went into runlevel 3. However, I had forgotten that my new settings had been "saved". Upon reaching runlevel 3, my screen went black. Now, whenever I boot the computer in openSUSE, THE SCREEN GOES BLACK AS SOON AS I REACH SHELL. I have no problem with re-installing SUSE, but I need help installing these drivers.

Please help me.

netllama 03-26-07 09:25 PM

Re: NEED HELP GF7600GS on openSUSE 10.2
 
http://www.nvnews.net/vbulletin/showthread.php?t=46678

generaleskimo 03-27-07 02:53 PM

Re: NEED HELP GF7600GS on openSUSE 10.2
 
Quote:

Originally Posted by netllama

Ok, that is completely useless. I have already read that. Did you read my post? I have searched for a thread with the same problem: no such thread exists. So, I gave you a detailed description of the problem.

I have done everything it says, to the point that it is possible. I believe I gave a very detailed description of the issue. I would give you bug reports and installer logs, but I CAN NO LONGER REACH SHELL IN SUSE!!!

Can someone please help.

mbnik 03-29-07 05:58 AM

Re: NEED HELP GF7600GS on openSUSE 10.2
 
Hi generaleskimo,

i have got the same problems with my suse10.2 and and GF7600GS Card, but i could solve any things.

If i try to run my system with the glx module, it runs 10 secons in grapic mode and then it is froozen.

However my card is running in 1280x1024 on a Sony Flat screen, without the glx support.

What i did:

first: i loadet down from nvidia the booth driver rpmīs for the 7600GS
x11-video-nvidia-1.0.9631-0.1.i586.rpm, x11-video-nvidia-1.0.9631-0.1.i586.rpm
and installed he with yast.

second: i loadet down from nvidia the driver: NVIDIA-Linux-x86-1.0-9755-pkg1.run.
As root in runlevel 3, i start the nvidia pkg and it compiles the module and installed it.

After init 5 my system was froozen.
(NVIDIA-Linux-x86-1.0-9631-pkg1.run does run with the same problems)

third: i start the suse10.2 with init 3, then i edit the file
/etc/X11/xorg.conf, i disabled the line glx.... with #glx... and stored it back.

Section "Module"
Load "extmod"
Load "dbe"
Load "v4l"
Load "type1"
Load "freetype"
#Load "glx"
EndSection

fourth: i initialized runlevel 5 with init 5 and yast could handle the reolutions and my graphic was runnig.

But my problem with the unused 3d glx is not dissoved yet.

greetings
mbnik

hedele 03-29-07 06:41 AM

Re: NEED HELP GF7600GS on openSUSE 10.2
 
For me the rpms didn't have any effects.

So I have compiled the kernel, which is not really extremely difficult with the NVIDIA-Script NVIDIA-Linux-x86-1.0-9631-pkg1.run and can be done in 8 steps I discribed in
http://www.nvnews.net/vbulletin/showthread.php?t=88898

The most important thing - never mentioned by nVidia - seems to be, that kernel and driver must fit together. On the German site
http://www.chip.de/c1_forum/thread.h...readid=1031674
nearly everybody struggled over this problem. NVidia itself doesn't give any list of compatibility and seems to hide older versions without a reachable table of contents. I had to use Google to find the shell
NVIDIA-Linux-x86-1.0-9631-pkg1.run
on the us.download.nvidia.com-site.

There is also some good information in
http://en.opensuse.org/NVIDIA

hedele 03-29-07 07:04 AM

Re: NEED HELP GF7600GS on openSUSE 10.2
 
Quote:

Originally Posted by generaleskimo
I CAN NO LONGER REACH SHELL IN SUSE!!!

Problem:The monitor remains black after the SaX2 start. Solution: Too high frequencies have been assigned to the monitor so it switches to the stand-by mode.

Try (blind) <CTRL>+<ALT>+<F1> to set X into the background
then type in "root" and press <RETURN>
type in your password and press <RETURN>
then type in "sax2 -l" and press <RETURN>
In this way, SaX2 starts in a 640x480 mode with disabled DDC Probing (automatic monitor detection) and a 60Hz refresh rate.
To get back to X press <CTRL>+<ALT>+<F7>

Good luck!


All times are GMT -5. The time now is 07:36 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Đ1998 - 2014, nV News.