nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   eVga 8800GTS and Kubuntu Feisty (http://www.nvnews.net/vbulletin/showthread.php?t=89098)

aaroncampbell 04-01-07 09:39 AM

eVga 8800GTS and Kubuntu Feisty
 
1 Attachment(s)
Well, I've posted here before, and the fix worked! For a little while at least. Then one time when I rebooted, it stopped, and I got the same black screen. I tried removing everything, and going back to the instructions in the other thread, but it didn't work. Here is the issue:
I'm on Kubuntu 7.04. I have an eVga 8800GTS and I'm trying to use 2 Dell 2007WFP monitors. I used adept to add nvidia-glx (version 1.0.9755...see below), and then I ran nvidia-xconfig --twinview (also tried without the twinview), and restarted. However, I only get a black screen. If I press alt+f1, I get a text login (that you can't see...however, if I type my username and press enter, I can see the password prompt). I had to log in, and set the driver back to vesa.
Code:

aaroncampbell@aaron-linux:~$ aptitude show nvidia-glx | grep -i version
Version: 1.0.9755+2.6.20.4-13.12

Here is my current xorg.conf:
Code:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Mon Feb 26 23:38:46 PST 2007

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#  sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
EndSection

Section "Files"
        # path to defoma fonts
    FontPath        "/usr/share/fonts/X11/misc"
    FontPath        "/usr/share/fonts/X11/cyrillic"
    FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/Type1"
    FontPath        "/usr/share/fonts/X11/100dpi"
    FontPath        "/usr/share/fonts/X11/75dpi"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load          "i2c"
    Load          "bitmap"
    Load          "ddc"
    Load          "extmod"
    Load          "freetype"
    Load          "glx"
    Load          "int10"
    Load          "vbe"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules" "xorg"
    Option        "XkbModel" "pc105"
    Option        "XkbLayout" "us"
    Option        "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device" "/dev/input/mice"
    Option        "Protocol" "ImPS/2"
    Option        "ZAxisMapping" "4 5"
    Option        "Emulate3Buttons" "true"
EndSection

Section "Monitor"
    Identifier    "Generic Monitor"
    HorizSync      28.0 - 84.0
    VertRefresh    43.0 - 60.0
    Option        "DPMS"
EndSection

Section "Device"
    Identifier    "Generic Video Card"
    Driver        "vesa"
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "Generic Video Card"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    Option        "TwinView" "True"
    Option        "MetaModes" "nvidia-auto-select, nvidia-auto-select"
    Option        "AddARGBGLXVisuals" "True"
    SubSection    "Display"
        Depth      24
        Modes      "1680x1050" "1280x1024"
    EndSubSection
EndSection

I'm attaching the output of nvidia-bug-report.sh after attempting "startx -- -logverbose 6"

Let me know if anything else might help. I'm currently using the drivers from the kubuntu feisty repos, but I tried downloading and installing from nvidia...but it made no difference.

netllama 04-01-07 11:56 AM

Re: eVga 8800GTS and Kubuntu Feisty
 
In your bug report I see:
(EE) NVIDIA(0): Need libwfb but wfbScreenInit not found

Does this problem persist if you install the official NVIDIA driver package?

aaroncampbell 04-01-07 01:20 PM

Re: eVga 8800GTS and Kubuntu Feisty
 
Yes, it seems to. I'm trying to figure out WHERE libwfb is supposed to come from. Near as I can tell, it's supposed to come from the xorg server...which I have installed. However, sudo locate libwfb returns nothing, as does sudo modprobe -l | grep -i wfb

zander 04-01-07 01:44 PM

Re: eVga 8800GTS and Kubuntu Feisty
 
libnvidia-wfb is shipped with the official NVIDIA Linux graphics driver, but may be missing from your distributor's NVIDIA driver packages.

aaroncampbell 04-01-07 02:16 PM

Re: eVga 8800GTS and Kubuntu Feisty
 
Is there any way to get just that file that I need?

zander 04-01-07 02:38 PM

Re: eVga 8800GTS and Kubuntu Feisty
 
You can download the appropriate official .run package and extract it with the -x command line option.


All times are GMT -5. The time now is 07:33 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.