nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nforce4 + 7800gtx sli + smp = lockups (http://www.nvnews.net/vbulletin/showthread.php?t=89179)

ooPo 04-02-07 10:19 PM

nforce4 + 7800gtx sli + smp = lockups
 
1 Attachment(s)
I have the following:

Asus A8N32-SLI Deluxe
AMD Athlon X2 4800+ (s939)
Evga 7800GTX (256MB) x 2

This same hardware works fine under XP, Vista and Ubuntu Edgy.

I've installed the following:

Ubuntu Feisty Beta 1 (fresh install, then dist-upgraded today)
Nvidia restricted driver using the new Restricted Driver Manager

It seems to works fine, I can enable desktop effects, run Beryl perfectly or even run WoW through wine - until I enable SLI support in xorg.conf. If I turn off desktop effects it comes up long enough for me to run things like glxgears.

When I run glxgears, four different things can happen:

1) It runs fine.
2) It seems to be running fine, but I get a black square.
3) It hangs, and I get a black square.
4) It hangs, and I get a grey square.

Luckily, I can still ssh in and run the bug report tool.

Any hints?

ooPo 04-04-07 01:18 AM

Re: nforce4 + 7800gtx sli + smp = lockups
 
Just to brute force the general 'try this' responses, I've tried the following kernel parameters:

pci=routeirq
pci=nommconf
pci=conf1
idle=poll
noapic
pci=noacpi
pci=biosirq
acpi=off
maxcpus=1

Nothing changes. So I dug deeper. I've noticed that when I run glxgears with SLI that my cpu usage spikes up to 100% immediately. When I quit the cpu usage takes more than a few seconds to come back down to normal. If I wait before running glxgears again it generally, like 80% of the time, runs like normal.

Other times, it runs really slowly like something is using up all the cpu time.

So I ran it with strace and noticed that when it isn't working properly it is calling sched_yield() a lot, over and over again. I wonder if those 'fixes' where sched_yield was replaced with 'return 0;' is causing a problem where not only is it essentially polling, but with the added overhead of a function call making a bad problem worse. Even a 'usleep(1);' would have been better than that.

Is also could mean there's a deeper problem of which the hanging/cpu starvation is only a symptom. Perhaps a syncronization issue between the two cards? Something that happens early on, probably during initialization before rendering even occurs. Or maybe whatever shutdown code is used isn't properly releasing the second card causing each run afterwards to not work properly.

Sometimes using SMP or Cool'n'Quiet can cause subtle timing issues to appear but 'maxcpus=1' and 'acpi=off' would have eliminated those possibilities.

BTW, is this even the right place to be asking about this? I'm doubting I'll even get a response here beyond 'wait for the next release', if any response at all. I'm letting a second card go idle while I'm attempting to fix it myself here and without the source I can really only do so much...

netllama 04-04-07 11:06 AM

Re: nforce4 + 7800gtx sli + smp = lockups
 
Have you verified that you're using the latest motherboard BIOS?

ooPo 04-04-07 10:48 PM

Re: nforce4 + 7800gtx sli + smp = lockups
 
Yes. I've upgraded to the latest bios from Asus, and even tried their beta bios. Neither had any effect.

ooPo 04-09-07 03:49 PM

Re: nforce4 + 7800gtx sli + smp = lockups
 
Well, thanks for the help. You've really dropped the ball here.

Nvidia is damn lucky ATI is providing practically worthless Linux support because at this point I'd be willing to jump to ANYTHING else. This is absolutely pathetic and it'll be a long time before I even think of buying anything with Nvidia's name on it if I can help it.

Bring it on, Intel.


All times are GMT -5. The time now is 02:39 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.