nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   API Mis-Match When Trying to Launch X (http://www.nvnews.net/vbulletin/showthread.php?t=89550)

kc5hwb 04-10-07 10:49 PM

API Mis-Match When Trying to Launch X
 
I just installed this driver...
http://www.nvidia.com/object/linux_d..._1.0-9755.html

It worked fine for about 10-15 min and then the screen just froze. So I had to do a hard reboot and now when it tried to launch X I get a API mismatch error. Here is the complete message:

Quote:

ERROR: API mismatch: the NVIDIA kernal module has the version 1.0-7184 but the X module has the version 1.0-9755. Please make sure that the kernal module and all NVIDIA driver components have the same version.
NVIDIA 0: Failed to initialize the NVIDIA kernel module! Please ensure that there is a supported NVIDIA GPU in this system and that the NVIDIA device file have been created.

zander 04-10-07 10:52 PM

Re: API Mis-Match When Trying to Launch X
 
For the first problem, please see: http://www.nvnews.net/vbulletin/showthread.php?t=46678; for the second, please see: http://www.nvnews.net/vbulletin/showthread.php?t=72490.

kc5hwb 04-11-07 05:27 PM

Re: API Mis-Match When Trying to Launch X
 
1 Attachment(s)
ok, here is my installer log.

I read the 2nd post and went into the /etc/default/linux-restricted-modules-common with NANO and placed DISABLED_MODULES="nv" in the bottom line, then rebooted and now it seems to be working again. I am almost scared to reboot again....

That thread is saying that I should uninstall the nvidia-glx package? That is the exact OPPOSITE of what people on the linuxquestions.org and ubuntuforums.org boards are saying.

netllama 04-11-07 05:42 PM

Re: API Mis-Match When Trying to Launch X
 
I'm not clear which problem we're supposed to be looking for in the installer log?

kc5hwb 04-11-07 05:57 PM

Re: API Mis-Match When Trying to Launch X
 
The error I got is listed in my first post, which seems to be gone now, but only after I changed the DISABLED_MODULES="nv" line in the /etc/default/linux-restricted-modules-common file.

I guess now what I need to know is if I should go ahead and uninstall the nvidia-glx package as it says to do in that 2nd link that zander posted.

netllama 04-11-07 05:59 PM

Re: API Mis-Match When Trying to Launch X
 
If you're requesting assistance here, then you should follow the instructions in the sticky posts.

kc5hwb 04-11-07 06:08 PM

Re: API Mis-Match When Trying to Launch X
 
You mean like this one?
http://www.nvnews.net/vbulletin/showthread.php?t=46678

Thats why I posted that log file and a description of the problem


All times are GMT -5. The time now is 09:30 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.