nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   "Can't open NVIDIA-Linux-x86-1.0-9755-pkg1.run" (http://www.nvnews.net/vbulletin/showthread.php?t=89636)

Zildjian 04-12-07 02:17 PM

"Can't open NVIDIA-Linux-x86-1.0-9755-pkg1.run"
 
Hi all.

I am new to Linux (Ubuntu 6.10) and I am trying to install the graphics driver for my Nvidia 7900GS.
I have gone onto the nvidia site and downloaded the linux driver. I downloaded it to desktop, went to terminal and typed: "sh NVIDIA-Linux-x86-1.0-9755-pkg1.run" and I got this error; "sh: Can't open NVIDIA-Linux-x86-1.0-9755-pkg1.run".

Can someone tell me how to install this driver with Ubuntu 6.10 please???

rerushg 04-12-07 06:09 PM

Re: "Can't open NVIDIA-Linux-x86-1.0-9755-pkg1.run"
 
I've got a 7900GS too. Good card.
It's been over 3 hours since you posted. Did you get help or figure it out?

Cambo 04-12-07 06:25 PM

Re: "Can't open NVIDIA-Linux-x86-1.0-9755-pkg1.run"
 
You might want to try using "sh ./NVIDIA-Linux-x86-1.0-9755-pkg1.run" - the "./" at the start tells the "sh" command that the file is in the current directory.

You may need to check the file permissions, too, as it may not be executable - "chmod +x NVIDIA-Linux-x86-1.0-9755-pkg1.run" will sort that for you.



Cambo

Zildjian 04-13-07 06:53 AM

Re: "Can't open NVIDIA-Linux-x86-1.0-9755-pkg1.run"
 
Thanks for the help.

I still haven't been able to fix this...

I tried the commands posted above and here is what it said in console:

myuser@INSPIRON:~$ sh ./NVIDIA-Linux-x86-1.0-9755-pkg1.run
sh: Can't open ./NVIDIA-Linux-x86-1.0-9755-pkg1.run
myuser@INSPIRON:~$ chmod +x NVIDIA-Linux-x86-1.0-9755-pkg1.run
chmod: cannot access `NVIDIA-Linux-x86-1.0-9755-pkg1.run': No such file or directory
myuser@INSPIRON:~$ sh ./NVIDIA-Linux-x86-1.0-9755-pkg1.run
sh: Can't open ./NVIDIA-Linux-x86-1.0-9755-pkg1.run

I have no idea why... It's just on my desktop, I have redownloaded it incase it was a corrupt file or something, still no luck. :( :(

adamk75 04-13-07 07:00 AM

Re: "Can't open NVIDIA-Linux-x86-1.0-9755-pkg1.run"
 
Do an 'ls -l' in the terminal and post the output here.

Adam

Zildjian 04-13-07 07:28 AM

Re: "Can't open NVIDIA-Linux-x86-1.0-9755-pkg1.run"
 
It's OK, I have done it now. I done it all through terminal and didn't use the file, no idea why it wouldn't work.
Anyway, it seems to be working now and Beryl is working too :)

Thanks for the help.

ryokukitsune 04-22-07 03:54 PM

Re: "Can't open NVIDIA-Linux-x86-1.0-9755-pkg1.run"
 
if you still feel like helping someone with a similar problem here's mine

(after fallowing previously mentioned steps and "ls -l" Konsole command)

Code:

ryoku@ASPCII:~$ ls -l
total 120
drwxr-xr-x 2 ryoku ryoku  4096 2007-04-22 16:02 Desktop
lrwxrwxrwx 1 ryoku ryoku    26 2007-04-20 09:51 Examples -> /usr/share/example-content
-rw-r--r-- 1 root  root  114454 2007-04-22 16:03 nvidia-bug-report.log


zabbadahun 05-12-07 09:28 AM

Re: "Can't open NVIDIA-Linux-x86-1.0-9755-pkg1.run"
 
I am also having some issues. I have the file and I can open it but when I open it is gives me the error I will list below. I will not be able to be contacted however as this site does not allow hotmail accounts it seems and that is what my primary email account is. If you want to send me an email it is ohnojihadjoe@hotmail.com. Otherwise I will be back on sometime to check for reponses. Have to go shoot some turkeys. Anyway this is the error.

ERROR: You appear to be running an X server; please exit X before installing.

Ok this may seem pretty straight forward to someone but this is my first time using any distribution of Linux. I am normally on windows but I decided to learn something new and my hate for Vista just kind of led me here. I mean to my understanding X is kind of necessary for me to be using my operating system how do I go about operating without it.

JThrawn2000 05-12-07 10:32 AM

Re: "Can't open NVIDIA-Linux-x86-1.0-9755-pkg1.run"
 
You have to kill X-Server... ctrl+alt+backsapce

Then use the cli...

You can reboot in to singleuser mode also... some cards cant handle killing X with the vesa driver or budled nvidia package.

zabbadahun 05-12-07 11:21 AM

Re: "Can't open NVIDIA-Linux-x86-1.0-9755-pkg1.run"
 
Thank you

zabbadahun 05-12-07 12:33 PM

Re: "Can't open NVIDIA-Linux-x86-1.0-9755-pkg1.run"
 
ok I did that but it gives me an error.

ERROR: Unable to find development tool 'make' in your path; please make sure you have package 'make' installed.

So after that I tried to load back into x using startx, however now X will not launch. reading from where the screen starts.

X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.15.7 i686
Current Operating System: Linux quizacortezlinux 2.6.15-23-386 #1 PREEMPT Tue May 23 13:49:40 UTC 2006 i686
Build Date: 16 March 2006
Module Loader present
Markers: (only these 2 appear) (==) default settings (EE) error
(==)Log file: "/var/log/Xorg.0.log", Time: Sat May 12 13:00:45 2007
(==)Using config file: "/etc/X11/xorg.conf"

(EE)Failed to load module "nvidia" (module does not exist, 0)
(EE)No drivers available

Fatal server error:
no screens found
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0" after 0 requests (0 known processed) with 0 events remaining.

I think this is due to some modifications I made at 4am last night. I was attempting to get my 3d rendering to work according to what the book said. It said to modify xorg.conf and replace a driver value with "nvidia".

OH NOES! I was modifying the file and my system crashed. I went back to it and my xorg.conf file is completely empty. I think I may just have to reinstall now.

zabbadahun 05-14-07 02:46 PM

Re: "Can't open NVIDIA-Linux-x86-1.0-9755-pkg1.run"
 
Alright so now I am back to where I started the only thing is that I know I need that developer tool. Any ideas?


All times are GMT -5. The time now is 12:06 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.