nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   No direct rendering after Ubuntu upgrade (http://www.nvnews.net/vbulletin/showthread.php?t=90186)

StevenX 04-21-07 03:44 PM

No direct rendering after Ubuntu upgrade
 
I just upgraded to Ubuntu 7.04/Feisty Fawn a couple of days ago and ever since haven't been able to get Beryl working again. I found out the cause of this is that I don't have direct rendering (using glxinfo | grep direct, I get return "direct rendering: no").

I've tried loads of things to try to bring it back but so far have made no progress at all apart from causing Xorg to completely break and not load up again... In which case, I've had to reinstall the Nvidia drivers from the command line again before rebooting into Gnome.

My current xorg.conf is as follows.

Code:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Mon Feb 26 23:38:46 PST 2007

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#  sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "stylus" "SendCoreEvents"
    InputDevice    "cursor" "SendCoreEvents"
    InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Files"

        # path to defoma fonts
    FontPath        "/usr/share/fonts/X11/misc"
    FontPath        "/usr/share/fonts/X11/cyrillic"
    FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/Type1"
    FontPath        "/usr/share/fonts/X11/100dpi"
    FontPath        "/usr/share/fonts/X11/75dpi"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load          "bitmap"
    Load          "ddc"
    Load          "extmod"
    Load          "freetype"
    Load          "glx"
    Load          "int10"
    Load          "vbe"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules" "xorg"
    Option        "XkbModel" "pc105"
    Option        "XkbLayout" "gb"
    Option        "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device" "/dev/input/mice"
    Option        "Protocol" "ImPS/2"
    Option        "ZAxisMapping" "4 5"
    Option        "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
    Identifier    "stylus"
    Driver        "wacom"
    Option        "Device" "/dev/input/wacom"
    Option        "Type" "stylus"
    Option        "ForceDevice" "ISDV4"                # Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier    "eraser"
    Driver        "wacom"
    Option        "Device" "/dev/input/wacom"
    Option        "Type" "eraser"
    Option        "ForceDevice" "ISDV4"                # Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier    "cursor"
    Driver        "wacom"
    Option        "Device" "/dev/input/wacom"
    Option        "Type" "cursor"
    Option        "ForceDevice" "ISDV4"                # Tablet PC ONLY
EndSection

Section "Monitor"
    Identifier    "Generic Monitor"
    HorizSync      28.0 - 51.0
    VertRefresh    43.0 - 60.0
    Option        "DPMS"
EndSection

Section "Device"
    Identifier    "Generic Video Card"
    Driver        "nvidia"
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "Generic Video Card"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    SubSection    "Display"
        Depth      1
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      4
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      8
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      15
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      16
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      24
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Can anyone help me get my direct rendering working again? This is driving me mad! Feel like I'm back in the stone age without my fancy window effects! ;)

Tanker Bob 04-21-07 04:06 PM

Re: No direct rendering after Ubuntu upgrade
 
Your xorg.conf file is missing some lines that I have in mine under feisty. In the Screen section there's a GLX option line:

Code:

Section "Screen"
    Identifier    "Default Screen"
    Device        "Generic Video Card"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    Option        "AddARGBGLXVisuals" "True"
    ...
EndSection

And at the end of the file I enable Composite:

Code:

Section "Extensions"
    Option        "Composite" "Enable"
EndSection

Also, in the NVIDIA configuration utility, ensure that in the OpenGL Settings section, the Image Settings are set to "High Quality."

Hopefully that will get you up and running. I've made other changes to my xorg.conf file, but none related to Beryl.

StevenX 04-21-07 04:53 PM

Re: No direct rendering after Ubuntu upgrade
 
Put those lines in, and I've reinstalled the Nvidia drivers after performing all of the steps in the thread http://www.nvnews.net/vbulletin/showthread.php?t=72490

Still no direct rendering though :(

ls -al /usr/lib/libGL* gives me:

Code:

lrwxrwxrwx 1 root root      21 2007-04-21 22:23 /usr/lib/libGLcore.so.1 -> libGLcore.so.1.0.9755
-rw-r--r-- 1 root root 9918780 2007-04-21 22:21 /usr/lib/libGLcore.so.1.0.9755
lrwxrwxrwx 1 root root      16 2007-04-19 21:58 /usr/lib/libGLEW.so.1.3 -> libGLEW.so.1.3.4
-rw-r--r-- 1 root root  199848 2007-03-05 05:16 /usr/lib/libGLEW.so.1.3.4
-rw-r--r-- 1 root root    653 2007-04-21 22:18 /usr/lib/libGL.la
lrwxrwxrwx 1 root root      17 2007-04-21 22:23 /usr/lib/libGL.so.1 -> libGL.so.1.0.9755
-rw-r--r-- 1 root root  601720 2007-04-21 22:21 /usr/lib/libGL.so.1.0.9755
lrwxrwxrwx 1 root root      20 2007-04-21 21:59 /usr/lib/libGLU.so.1 -> libGLU.so.1.3.060502
-rw-r--r-- 1 root root  521000 2007-03-31 00:07 /usr/lib/libGLU.so.1.3.060502


AaronP 04-21-07 05:42 PM

Re: No direct rendering after Ubuntu upgrade
 
Please post a bug report and the output of glxinfo.

StevenX 04-21-07 05:54 PM

Re: No direct rendering after Ubuntu upgrade
 
1 Attachment(s)
Bug report attached.
Output of glxinfo:

Code:

name of display: :0.0
display: :0  screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
    GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig
client glx vendor string: NVIDIA Corporation
client glx version string: 1.4
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_visual_info,
    GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_SGI_video_sync,
    GLX_NV_swap_group, GLX_NV_video_out, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGI_swap_control, GLX_NV_float_buffer, GLX_ARB_fbconfig_float,
    GLX_EXT_fbconfig_packed_float, GLX_EXT_texture_from_pixmap,
    GLX_EXT_framebuffer_sRGB
GLX version: 1.2
GLX extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_SGIX_fbconfig,
    GLX_ARB_get_proc_address
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce FX 5700VE/AGP/SSE/3DNOW!
OpenGL version string: 1.2 (2.1.0 NVIDIA 97.55)
OpenGL extensions:
    GL_ARB_depth_texture, GL_ARB_imaging, GL_ARB_multitexture,
    GL_ARB_point_parameters, GL_ARB_point_sprite, GL_ARB_shadow,
    GL_ARB_texture_border_clamp, GL_ARB_texture_cube_map,
    GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
    GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
    GL_ARB_window_pos, GL_ARB_vertex_program, GL_ARB_fragment_program,
    GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color, GL_EXT_blend_func_separate,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_draw_range_elements,
    GL_EXT_fog_coord, GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels,
    GL_EXT_rescale_normal, GL_EXT_secondary_color,
    GL_EXT_separate_specular_color, GL_EXT_shadow_funcs, GL_EXT_stencil_wrap,
    GL_EXT_texture3D, GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add,
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3, GL_EXT_texture_lod,
    GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_vertex_array,
    GL_IBM_texture_mirrored_repeat, GL_NV_blend_square,
    GL_NV_texgen_reflection, GL_NV_texture_rectangle,
    GL_NV_texture_env_combine4, GL_SGIS_generate_mipmap, GL_SGIS_texture_lod,
    GL_SGIX_depth_texture, GL_SGIX_shadow

  visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x2c 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x2d 24 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
0x2e 32 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 Ncon
0x2f 32 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 Ncon

Sorry for not attaching them to begin with - it's taken me a while to work out how to get the bug report!

Edit.. Just in case you need it.. My new xorg.conf as well:

Code:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Mon Feb 26 23:38:46 PST 2007

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#  sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "stylus" "SendCoreEvents"
    InputDevice    "cursor" "SendCoreEvents"
    InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Files"

        # path to defoma fonts
    FontPath        "/usr/share/fonts/X11/misc"
    FontPath        "/usr/share/fonts/X11/cyrillic"
    FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/Type1"
    FontPath        "/usr/share/fonts/X11/100dpi"
    FontPath        "/usr/share/fonts/X11/75dpi"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load          "bitmap"
    Load          "ddc"
    Load          "extmod"
    Load          "freetype"
    Load          "glx"
    Load          "int10"
    Load          "vbe"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules" "xorg"
    Option        "XkbModel" "pc105"
    Option        "XkbLayout" "gb"
    Option        "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device" "/dev/input/mice"
    Option        "Protocol" "ImPS/2"
    Option        "ZAxisMapping" "4 5"
    Option        "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
    Identifier    "stylus"
    Driver        "wacom"
    Option        "Device" "/dev/input/wacom"
    Option        "Type" "stylus"
    Option        "ForceDevice" "ISDV4"                # Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier    "eraser"
    Driver        "wacom"
    Option        "Device" "/dev/input/wacom"
    Option        "Type" "eraser"
    Option        "ForceDevice" "ISDV4"                # Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier    "cursor"
    Driver        "wacom"
    Option        "Device" "/dev/input/wacom"
    Option        "Type" "cursor"
    Option        "ForceDevice" "ISDV4"                # Tablet PC ONLY
EndSection

Section "Monitor"
    Identifier    "Generic Monitor"
    HorizSync      28.0 - 51.0
    VertRefresh    43.0 - 60.0
    Option        "DPMS"
    Option        "AddARGBGLXVisuals" "True"
EndSection

Section "Device"
    Identifier    "Generic Video Card"
    Driver        "nvidia"
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "Generic Video Card"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    SubSection    "Display"
        Depth      1
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      4
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      8
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      15
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      16
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      24
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "Extensions"
    Option        "Composite" "Enable"
EndSection


StevenX 04-21-07 06:31 PM

Re: No direct rendering after Ubuntu upgrade
 
Also, in my Xorg.0.log file, I have the errors:

Code:

(EE) Unable to locate/open config file: "/root/xorg.config.new"
(EE) open /dev/fb0: No such file or directory
(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

The config file should be located at "/etc/X11/xorg.conf" though? Why would it be trying to look for a file in /root/? I don't know if this is significant, but thought it's worth a mention..

AaronP 04-21-07 08:15 PM

Re: No direct rendering after Ubuntu upgrade
 
The fact that it can't find its configuration file at /root/xorg.config.new is the heart of the problem: It's falling back to the nv driver because it thinks there's no config file. With the X server running this way, try running "ps aux | grep X" in a terminal to see if the -config option is being passed into the server by whatever is starting it.

StevenX 04-22-07 05:38 AM

Re: No direct rendering after Ubuntu upgrade
 
This is what I'm getting returned..

Code:

root      4892  1.9 10.1  61348 52388 ?        SL  08:27  2:10 /usr/bin/Xgl :0 :0 -fullscreen -ac -accel glx:pbuffer -accel xv:fbo -auth /var/lib/gdm/:0.Xauth -nolisten tcp vt7
root      4895  0.0  3.5  23000 18292 tty7    SLs+ 08:27  0:01 /usr/bin/Xorg vt7 -auth /tmp/.Xgl-auth-Zu8IPR -nolisten tcp :93 -terminate
steven  10154  0.0  0.1  2892  764 pts/0    R+  10:18  0:00 grep X


AaronP 04-22-07 02:33 PM

Re: No direct rendering after Ubuntu upgrade
 
Oh, you're running Xgl... In that case, the log file you posted was not the one from the actually running X server. You want Xorg.93.log instead of Xorg.0.log.

Not having direct rendering in Xgl is expected behavior.

xernos 04-22-07 03:52 PM

Re: No direct rendering after Ubuntu upgrade
 
2 Attachment(s)
I have the same problem - after upgrade from Edgu to Fiesty i lost hardware 3D support. I tray install with some strange flags (i found on this forum workaround ) :
NVIDIA-Linux-*.run --x-module-path=`X -showDefaultModulePath 2>&1 | cut -d, -f1` --x-library-path=`X -showDefaultLibPath 2>&1`
But didn't work for me :/ .
I use may own configuration kernel - always the same but this time didn't work I put may config and nvidia-bug_report for diagnose.
Software version :
Xorg 7.2
kernel 2.6.20.7
gcc version 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
GNU Make 3.81

May Hardware:
GF 6200N -> Asus
K7NF2-RAID ASrock
Chieftec 450 V
2 optical drivers
1 HUB - 4 ports USB 1.1
2 hard drives

Bay.

StevenX 04-22-07 04:47 PM

Re: No direct rendering after Ubuntu upgrade
 
OK, I've given up and reinstalled Feisty as a clean install.. Everything works straight away.. Sorry to waste anyone's time!


All times are GMT -5. The time now is 02:10 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.