nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Have to rebuild 9631 after every boot (http://www.nvnews.net/vbulletin/showthread.php?t=90378)

imrazor 04-25-07 03:49 AM

Have to rebuild 9631 after every boot
 
1 Attachment(s)
I previously had 7184 installed. I ran the 9631 installer, started X, got beryl and all the associated eye-candy working. After reboot, however, the X server fails to load. When I try to load it manually, I get this error:

API Mismatch: The Nvidia kernel module has the version 1.0-7184, but this X module has the version 1.0-9631.

If I rebuild the 9631 modules, I can then start X. However, when I reboot I'm back to square one. Apparently there's a 7184 kernel module hiding somewhere on my system, and I've been unable to root it out.

Some details:
GPU: Nvidia Geforce 2 MX/MX400 (64 MB RAM)
CPU: Athlon XP 1700+
RAM: 768MB PC2100
OS: Ubuntu 7.04 i386 (Feisty Fawn)
uname -a:
Linux dragon 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux

I've also attached the Nvidia installer log.

AaronP 04-25-07 04:27 AM

Re: Have to rebuild 9631 after every boot
 
See http://nvnews.net/vbulletin/showthread.php?t=72490

imrazor 04-25-07 10:43 PM

Re: Have to rebuild 9631 after every boot
 
Tried all that. When I ran "apt-get remove --purge nvidia-glx-legacy" and "apt-get remove --purge nvidia-glx" I got a message to the effect that no packages were installed. Just to be thorough, I then ran "apt-get install nvidia-glx-legacy" then immediately ran "apt-get install remove --purge nvidia-glx-legacy" to make absolutely sure every last trace of it was removed. I got the same API mismatch. I then manually tracked down /lib/modules/2.6.20-15-generic/kernel/drivers/nvidia.ko, deleted it and watched the installer rebuild it. Same problem. Then I noticed that nvidia kernel modules were being rebuilt spontaneously every reboot in /lib/modules/2.6.20-15-generic/volatile. I deleted those, rebooted, same problem. Those modules had magically reappeared in the same place.

That gave me a brilliant (or lame, depending on how you look at it) idea and I added these lines to /etc/rc.local:

/sbin/rmmod nvidia
/sbin/insmod /lib/modules/2.6.20-15-generic/kernel/drivers/video/nvidia.ko.

This removed the bogus 7184 module that seems to magically regenerate at every boot and loaded the good 9631 module from the correct place. Now I get an X login at every boot.

This is a rather lame kludge, and I'd like to do this properly. Does anyone know why the modules in /volatile/ are reappearing at every boot?

imrazor 04-26-07 12:10 AM

Re: Have to rebuild 9631 after every boot
 
There's a slight mistake in the above instructions that threw me off

If you use Ubuntu, please also ensure that the linux-restricted-modules packages have been uninstalled.

It's not linux-restricted-modules that needs to be uninstalled, it's linux-restricted-modules-common. Instead of taking that route, I just disabled the Ubuntu nvidia kernel module in /etc/default. Now everything is working just peachy!


All times are GMT -5. The time now is 01:29 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.