nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   Trouble with Linux emulation [97.46] (http://www.nvnews.net/vbulletin/showthread.php?t=90684)

gigiilmaco 05-01-07 10:28 AM

Trouble with Linux emulation [97.46]
 
Hi,
I've got a problem with the Linux emulation with update driver.
The installation goes perfect, but i cannot run any OpenGL Linux application.

In /usr/compat/linux environment, glxinfo gives me just this line:

NVIDIA: failed to execute '/sbin/modprobe': no such file or directory

and freeze.
The trouble seems to be related with libGL.so. If the link point to original DRI libGL.so.1.2 it run, but with just a partially accelerated rendering (glx server -> Nvidia, glx client -> SGI). If the link point to the right libGL.so.1.0.9746, nothing works.
By the way, native FreeBSD application works perfectly
Any help?
Thanks

gigiilmaco 05-18-07 06:05 PM

Re: Trouble with Linux emulation [97.46]
 
update: i tried a fresh BSD installation and all drivers available, 9755, legacy and beta.
Nothing works. Native applications are perfect, but Linux emulation is broken
Anyone can use it?
:(

zander 05-18-07 06:44 PM

Re: Trouble with Linux emulation [97.46]
 
You'll only run into this problem if you run Linux applications as root. You can work around it by linking /compat/linux/sbin/modprobe to /bin/true.


All times are GMT -5. The time now is 07:57 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.