nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   Xorg will not start with nVidia glx module (http://www.nvnews.net/vbulletin/showthread.php?t=90945)

mdelorme 05-05-07 02:55 PM

Xorg will not start with nVidia glx module
 
2 Attachment(s)
Hello,
I've just switched from Gentoo Linux to FreeBSD 6.2, and am having trouble making use of the nvidia-driver port. I've installed the port and configured my xorg.conf file appropriately. My problem is that xorg crashes while starting if I load the glx module.

Interestingly enough, it appears that this is a problem with my mouse in combination with the glx module. When I startx, the nVidia splash screen appears for a few seconds, then Xorg crashes before loading the mouse on screen. However, if I move the mouse WHILE the nVidia splash screen is up, Xorg crashes the second the mouse is touched. Inspecting my Xorg.0.log file somewhat confirms this since X seems to crash when adding my mouse to the server layout. Again, this is only a problem when glx is loaded. I am using a EVGA 6200 TourboCache, Xorg 6.9, and a USB mouse that gets "automagically" mapped to /dev/sysmouse at boot time (my PS/2 port is out of commission, so I've no alternative as far as a mouse is concerned). I've attached my xorg.conf and Xorg.0.log file. Any help would be greatly appreciated. Thanks.

Attachment 25462

Attachment 25463

Arabian 05-05-07 04:44 PM

Re: Xorg will not start with nVidia glx module
 
I wish you problem would be solved when Xorg-server 7.2 hit the ports tree by this week.

mdelorme 05-05-07 08:13 PM

Re: Xorg will not start with nVidia glx module
 
EDIT: the following does not actually "solve" my problem... i've found that it merely installs the MESA glx module over the nVidia one. The module loads, but direct rendering is unavailable with this module. Reinstalling nvidia-driver still causes the same error as mentioned above.
-------------------------------------------------------------------

My apologies. I seem to have solved my own problem. I had added
Code:

WITH_NVIDIA_GL
to my /etc/make.conf file after I had built xorg. I then ran
Code:

portmanager -l -u -p
under the false understanding that it might rebuild all packages that were altered by this new flag. Running
Code:

portmanager x11/xorg -l -f -p
rebuilt all of xorg and it's dependencies, which solved my problem.

I suppose this brings up a new question with regards to FreeBSD. In Gentoo, if I add a USE flag to my /etc/make.conf file, I can have portage check my entire system and rebuild any packages are altered by the addition of this flag with
Code:

emerge --update --deep --newuse world
and then use
Code:

revdep-rebuild
to rebuild all packages that might have been broken by this upgrade. Is there anything similar in FreeBSD for managing ports? I seem to find myself struggling with managing the configure options for packages since FreeBSD does not have a fixed set of USE flags that I can easily track.


All times are GMT -5. The time now is 02:34 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.