nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Solaris (http://www.nvnews.net/vbulletin/forumdisplay.php?f=45)
-   -   Screen stays black: MX-400 problem? (http://www.nvnews.net/vbulletin/showthread.php?t=91726)

hvn 05-18-07 01:31 PM

Screen stays black: MX-400 problem?

I have a video problem and I can't find the cause, hence this post.
My hardware: Asus A7V8X/AthlonXP 2400+ and nVidia MX-400 videocard.
My problem: Up from Solaris 8 (or earlier even) till 10 1/06, Solaris works fine. However, from 10 6/06 on, Solaris refuses to boot properly. What happens is that, on boot, I see the monitor getting off sleep (led turns green), but I don't see anything on screen. No matter how long I wait, nothing happens.
I asked Asus, but apart from a BIOS upgrade, they say they don't support Solaris anymore. End of story, while I bought this systemboard upon their recommendation for Solaris in the first place.
So now I ask anyone here: is this problem anyhow familiar and how can I solve it? Is this indeed a problem related to the MX-400?

Thanks for any help.

paulgress 05-18-07 03:41 PM

Re: Screen stays black: MX-400 problem?
Doesn't really seem to be a NVIDIA question because it appears your not even booting at all. Is your hard drive light flashing durring boot? Anyway, assuming your not booting try below.

One of the differences from old Solaris to todays new Solaris is they default to ACPI turned on and DMA turned on. So I suggest to try one of the following or both:


where the acpi is now turned off
and dma is off

please refer to the link for detail information on acpi:


Both items can be set using


or manually be editing the text file


hvn 05-19-07 02:16 PM

Re: Screen stays black: MX-400 problem?
Thanks for your response. Indeed, my harddisk doesn't flash. Some questions though:
1) could you explain what influence changing /boot/solaris/bootenv.rc will have on booting from cdrom?
2) acpi-user-options is unknown to eeprom: “data not available”. Should I set it to 0x8 anyway?

paulgress 05-21-07 12:37 AM

Re: Screen stays black: MX-400 problem?
The reasons I stated acpi option can be found in "man eeprom"

"x86 Only

A configuration variable that controls the use of
Advanced Configuration and Power Interface (ACPI), a
power management specification. The acceptable values
for this variable depend on the release of the Solaris
operating system you are using.

For all releases of Solaris 10 and Solaris 11, a value
of of 0x0 means that there will be an attempt to use
ACPI if it is available on the system. A value of 0x2
disables the use of ACPI.

For the Solaris 10 1/06 release, a value of 0x8 means
that there will be an attempt to use ACPI in a mode com-
patible with previous releases of Solaris 10 if it is
available on the system. The default for Solaris 10 1/06
is 0x8.

For releases of Solaris 10 after the 1/06 release and
for Solaris 11, the default is 0x0.

Most users can safely accept the default value, which
enables ACPI if available. If issues related to the use
of ACPI are suspected on releases of Solaris after
Solaris 1/06, it is suggested to first try a value of
0x8 and then, if you do not obtain satisfactory results,

The way to disable it booting from the cdrom is:

boot cdrom -B acpi-user-options=2

There is also an option to turn dma off for the cdrom drive:


The reason is sometimes these setting give problems upon booting and you stated early Solaris worked fine, this is one difference that affects booting.

Did you successfully install Solaris 10, or are you failing at the install process.

hvn 05-26-07 10:51 AM

Re: Screen stays black: MX-400 problem?
Thank you for your answer. I tried "boot cdrom -B acpi-user-options=8", but that doesn't solve the problem. Worse, I can't get past the bootprompt anymore, with or without cdrom.
I have Solaris 10 1/06 installed and working fine. The problem starts from 10 6/06, like "man eeprom" indicates.
Update: watching the led's closely, I see the harddisk flash sometimes, and the cdrom working. Even a short check for the floppydrive. I just don't see anything on screen so I have no clue what's happening.
Update 2: it seem to be working. After a VERY long time waiting I actually have the install screen. How long should it take anyway to get something on screen?
Update 3: 11/06 is installed and running fine. Thank you for your help.

All times are GMT -5. The time now is 03:57 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.