nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Ubuntu 7.04, XFX GeForce 6800LE - no drivers work (http://www.nvnews.net/vbulletin/showthread.php?t=92011)

Nizzle 05-23-07 10:10 AM

Ubuntu 7.04, XFX GeForce 6800LE - no drivers work
 
3 Attachment(s)
I've installed drivers on every way I thought possible.. totally destroyed my system a couple of times and yet still I've got nothing working..

I used to have it all working even had Beryl running and played some games but now I can't get anything to work :(

here's the story..
at first I just installed the drivers through the new Ubuntu feature for installing closed source drivers.. all went fine (or so I thought) but after reboot X crashed on boot.. I had no clue what could be wrong.. did the "sudo dpkg-reconfigure -phigh xserver-xorg" and got it back working

all happy again didn't really bother with the drivers again because I didn't need them but now I do want them for Beryl and games.. so went bothering with it again

in the Ubuntu packages there's nvidia-glx, nvidia-glx-legacy and nvidia-glx-new.. I read on some site that my GeForce 6800LE would work best with the nvidia-glx-new so I installed those and set nvidia as my driver for vid card in the xorg.conf (this is when hell started)
did a reboot again and well.. X didn't crash.. boot worked.. logged in and I noticed colored stripes all over the screen.. becomming more and more stripes.. and eventually all my pc crashed..
so did another reconfigure and searched the internet again
eventually I tried all the drivers.. with nvidia-glx and nvidia-glx-legacy the whole X thing doesn't even start because of diffrent kernel module than X module

after alot of problems I figured that my current xorg.conf file works.. with driver set to "nv" and if I change "nv" to "nvidia" it will boot with them colored stripes all over the screen and crashing eventually.. but it has best results in comparison to other configs that I had

I shall attach the error log from Xorg and nvidia error log and the xorg.conf file
the xorg error log is from when I have the nvidia-glx installed instead of the nvidia-glx-new
I did ask about the problem over at the Dutch Ubuntu forums but nobody had a clue of what's wrong
please help :(

evilghost 05-23-07 10:16 AM

Re: Ubuntu 7.04, XFX GeForce 6800LE - no drivers work
 
What happens when you try a more recent driver as 1.0.7184 is quite old? Try 1.0.9755, http://www.nvidia.com/object/linux_d..._1.0-9755.html

Code:

(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.7184


Nizzle 05-23-07 10:23 AM

Re: Ubuntu 7.04, XFX GeForce 6800LE - no drivers work
 
nvidia-glx-new = 1.0.9755

got that installed now again and I get the pretty stripes all over my screen :(

evilghost 05-23-07 10:33 AM

Re: Ubuntu 7.04, XFX GeForce 6800LE - no drivers work
 
Can you submit a bug report with 1.0.9755? Hit another terminal (CTRL-ALT-F2) while you're in "pretty stripe" mode?

Nizzle 05-23-07 11:49 AM

Re: Ubuntu 7.04, XFX GeForce 6800LE - no drivers work
 
1 Attachment(s)
I think that would be this one..

evilghost 05-23-07 01:02 PM

Re: Ubuntu 7.04, XFX GeForce 6800LE - no drivers work
 
I looked but didn't immediately see a solution. I'm going to let the Nvidia folks comment.

Nizzle 05-23-07 01:04 PM

Re: Ubuntu 7.04, XFX GeForce 6800LE - no drivers work
 
well thanks for trying :)

netllama 05-23-07 04:24 PM

Re: Ubuntu 7.04, XFX GeForce 6800LE - no drivers work
 
I have a few questions:
0) Does this problem persist with the 100.14.06 beta drivers?
1) Does this problem persist if you remove 'quiet splash' from your GRUB configuration (and reboot)?
2) Does this problem persist if you remove the Coolbits, TripleBuffer and Composite extension options from your X configuration ?
3) Have you verified that you're using the latest motherboard BIOS?
4) Does this problem persist if you set NvAGP to 0 in xorg.conf ?

Thanks,
Lonni

Nizzle 05-24-07 04:27 PM

Re: Ubuntu 7.04, XFX GeForce 6800LE - no drivers work
 
Quote:

Originally Posted by netllama
I have a few questions:
0) Does this problem persist with the 100.14.06 beta drivers?
1) Does this problem persist if you remove 'quiet splash' from your GRUB configuration (and reboot)?
2) Does this problem persist if you remove the Coolbits, TripleBuffer and Composite extension options from your X configuration ?
3) Have you verified that you're using the latest motherboard BIOS?
4) Does this problem persist if you set NvAGP to 0 in xorg.conf ?

Thanks,
Lonni

0) didn't try those yet
1) never did touch anything from the GRUB.. don't have a clue how to either
2) Yes
3) most probably not.. no clue how to update those either.. drivers did use to work though
4) no clue.. how can I try that?

another piece of information.. just got updates for the nvidia-glx-new and for linux-restricted-modules and still nothing improves

netllama 05-25-07 12:23 AM

Re: Ubuntu 7.04, XFX GeForce 6800LE - no drivers work
 
The driver README covers how to set the NvAGP option. You'll need to consult with the Ubuntu folks for assistance with anything else.

borgzilla 05-25-07 04:02 AM

Re: Ubuntu 7.04, XFX GeForce 6800LE - no drivers work
 
Quote:

Originally Posted by Nizzle
with nvidia-glx and nvidia-glx-legacy the whole X thing doesn't even start because of diffrent kernel module than X module

And you thought there isn't distro that's worse than sabayon huh? Well you're right but Ubuntu is almost there. Anyway, this is how I solved my problem with nvidia under ubuntu.

Open synaptic and type nvidia in search field.
Remove everything installed including their dependencies (don't be afraid to remove depending kernel images) and just leave "restricted manager" and "xserver-xorg-video-nv".

Make sure xorg.conf is set to vesa driver.

sudo apt-get install build-essential
also install kernel headers if you haven't already.
Download latest nvidia beta drivers from http://www.nzone.com/object/nzone_do...etadriver.html

NOW this is a MUST. There's a hidden nvidia file in /lib/linux-restricted-modules/
DELETE IT. It almost caused me a hearth attack. It supposed to be deleted when you remove ubuntu nvidia-glx-new package but for some reason it still remains there. I think it's the main reason our cards don't work. I'll never forget ubuntu for that.
Reboot.

ctrl+alt+f2
login

sudo killall gdm
do it again just in case

chmod +x NVIDIA*.run
now install nvidia drivers and let installer configure xorg.conf for you and then reboot.

Hope this works for you. If not, debian's going to work I guaranty.

mikejac69 05-25-07 02:07 PM

Re: Ubuntu 7.04, XFX GeForce 6800LE - no drivers work
 
Hi there, I had some issues with my 6600 card, I found that using automatix 2 to install the drivers worked excellently, and was done in a couple of clicks!

Hope u get it sorted!


All times are GMT -5. The time now is 09:03 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.