nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   Cannot start X (http://www.nvnews.net/vbulletin/showthread.php?t=92194)

ntamp 05-26-07 12:49 PM

Cannot start X
 
Hello,
I use FreeBSD 6.2 and Xorg 7.2 (card` s chipset is Nvidia 440MX)
I installed latest nvidia drivers from ports, but i cannot start X.
An error appeared:

(II) Module kbd: vendor="X.Org Foundation"
compiled for 7.2.0, module version = 1.1.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.7
(II) NVIDIA dlloader X Driver 1.0-9746 Tue Dec 19 13:23:45 PST 2006
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(WW) NVIDIA(0): The NVIDIA GeForce4 MX 440 GPU installed in this system is
(WW) NVIDIA(0): supported through the NVIDIA 1.0-96xx Legacy drivers.
(WW) NVIDIA(0): Please visit http://www.nvidia.com/object/unix.html for
(WW) NVIDIA(0): more information. The 1.0-9746 NVIDIA driver will ignore
(WW) NVIDIA(0): this GPU. Continuing probe...
(EE) No devices detected.

Fatal server error:
no screens found


Then i installed nvidia-driver-9631 and then nvidia-driver-7184 and the result is:

(II) XINPUT: Adding extended input device "Mouse1" (type: MOUSE)
(II) XINPUT: Adding extended input device "NVIDIA Damage Notification Manager" (type: Other)
(II) XINPUT: Adding extended input device "NVIDIA Kernel RC Handler" (type: Other)
(II) XINPUT: Adding extended input device "NVIDIA Event Handler" (type: Other)
(II) Mouse1: SetupAuto: hw.iftype is 4, hw.model is 0
(II) Mouse1: SetupAuto: protocol is SysMouse

Caught signal 10. Server aborting

Thank you

Xorg:
Code:

Section "ServerLayout"
    Identifier    "Simple Layout"
    Screen        "Screen 1" 0 0
    InputDevice    "Mouse1" "CorePointer"
    InputDevice    "Keyboard1" "CoreKeyboard"
EndSection

Section "Files"
    FontPath        "/usr/local/lib/X11/fonts/misc/"
    FontPath        "/usr/local/lib/X11/fonts/TTF/"
    FontPath        "/usr/local/lib/X11/fonts/OTF"
    FontPath        "/usr/local/lib/X11/fonts/Type1/"
    FontPath        "/usr/local/lib/X11/fonts/100dpi/"
    FontPath        "/usr/local/lib/X11/fonts/75dpi/"
    FontPath        "/usr/local/lib/X11/fonts/local/"
    FontPath        "/usr/local/lib/X11/fonts/TrueType/"
EndSection

Section "Module"
    Load          "dbe"        # Double buffer extension
    SubSection    "extmod"
        Option        "omit xfree86-dga"  # don't initialise the DGA extension
    EndSubSection
    Load          "freetype"
    Load          "glx"
EndSection

Section "InputDevice"
    Identifier    "Keyboard1"
    Driver        "kbd"
    Option        "AutoRepeat" "500 30"
    Option        "XkbRules" "xorg"
    Option        "XkbModel" "pc101"
    Option        "XkbLayout" "us,el"
    Option        "XkbOptions" "grp:alt_shift_toggle"
EndSection

Section "InputDevice"
    Identifier    "Mouse1"
    Driver        "mouse"
    Option        "Protocol" "Auto"    # Auto detect
    Option        "Device" "/dev/sysmouse"
    Option        "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier    "philips"
    HorizSync      30.0 - 83.0
    VertRefresh    56.0 - 76.0
EndSection

Section "Device"

    #VideoRam    65536
    Identifier    "gforce"
    Driver        "nvidia"
EndSection

Section "Screen"
    Identifier    "Screen 1"
    Device        "gforce"
    Monitor        "philips"
    DefaultDepth    24
    SubSection    "Display"
        Depth      24
        Modes      "1280x1024"
    EndSubSection
EndSection


ntamp 05-26-07 01:09 PM

Re: Cannot start X
 
Then i installed 9631 and that error appears that time:

(==) Using config file: "/etc/X11/xorg.conf"
dlopen: Cannot open "/usr/local/lib/xorg/modules/extensions//libglx.so"
(EE) Failed to load /usr/local/lib/xorg/modules/extensions//libglx.so
(EE) Failed to load module "glx" (loader failed, 7)
(EE) Failed to load module "nvidia" (module does not exist, 0)
(EE) No drivers available.

Code:

[root@jeremes /usr/local/lib/xorg/modules/extensions]# ls
XXX-libGLcore.la.%%.orig-20070526      libextmod.la
XXX-libGLcore.so.%%.orig-20070526      libextmod.so
XXX-libglx.la.%%.orig-20070526          libglx.so
XXX-libglx.so.%%.orig-20070526          librecord.la
libdbe.la                              librecord.so
libdbe.so                              libxtrap.la
libdri.la                              libxtrap.so
libdri.so
[root@jeremes /usr/local/lib/xorg/modules/extensions]#


zander 05-26-07 01:33 PM

Re: Cannot start X
 
This looks like an installation problem; did you install using the official driver package or via ports/?

ntamp 05-26-07 01:36 PM

Re: Cannot start X
 
Only 9631 drivers, downloaded from http://www.nvidia.com/object/freebsd_1.0-9631.html

All the other have been installed from ports.

zander 05-27-07 12:44 PM

Re: Cannot start X
 
My guess is that X11BASE isn't set and that the NVIDIA driver files were installed in the wrong place. Judging from your initial post, the nvidia-driver-9631 package didn't have this problem. Does X start with the nv driver or do you get the signal with that driver also?

ntamp 05-27-07 01:25 PM

Re: Cannot start X
 
zander,
Thank you very much for your answears.
Finally i solve the problem, reinstalling Xorg 7.2 (ports) and nvidia-drivers-9631 (ports)
Now, everything works fine!

zander 05-27-07 01:34 PM

Re: Cannot start X
 
That's good to hear, thanks for the update.


All times are GMT -5. The time now is 05:39 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.