nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   Strange behaviour by Enemy Territory (http://www.nvnews.net/vbulletin/showthread.php?t=92444)

nullpt 05-31-07 07:57 AM

Strange behaviour by Enemy Territory
 
2 Attachment(s)
Hello all,

I'm having trouble launching Enemy Territory on FreeBSD 6.2-STABLE with a Nvidia 8800GTS 320MB DDR + latest BETA nvidia driver (the only one that seems to work). I have an Acer AL1916WS 19" Widescreen LCD Monitor and I'm using 1440x900 resolution. Everything works OK with Xorg, I have KDE running and all.

I'm trying to get enemy territory to run but I have a strange behaviour when I launch the game. The screen goes black and the monitor starts to show "Auto config in progress" and then it returns to the shell where I launch the game. The game doesn't spit any error, the output is all good. The game stops when the system sends a SIGTERM to the process.

I've also configured the game for my exact resolution. No go.

I've attached my xorg.conf and glxinfo output.

Any help is greatly apreciated.

Regards

zander 05-31-07 12:08 PM

Re: Strange behaviour by Enemy Territory
 
Can you start `glxgears` more than once without restarting X? If not, then I believe what you are seeing is likely related to known problems with 100.14.06 and 8800 series GPUs on FreeBSD. These problems should be resolved in the next 100.14.xx NVIDIA FreeBSD graphics driver release.

nullpt 05-31-07 03:39 PM

Re: Strange behaviour by Enemy Territory
 
Zander, thanks for the quick answer.

I was just about to post some new findings.. there isn't any opengl application that will run more than one time without start core dumping :|

Glxgears report 11400 frames. If i start it again it won't work. I have to reload the nvidia driver.

Is there any workaround for this? Also, is there a possibility to view a todo list or know problem database for this driver?

I'd like to aid testing the driver if possible. All other graphical stuff work ok, the only thing is I can't run 3d stuff (oh well, games are bad for u anyway heh) :)

Thanks

zander 05-31-07 04:42 PM

Re: Strange behaviour by Enemy Territory
 
Unfortunately, there's no feasible workaround for this problem, nor is there a public TODO/bug list. We hope to release updated FreeBSD graphics drivers with improved G80/G8x support in the near future, though.

nullpt 06-09-07 09:06 PM

Re: Strange behaviour by Enemy Territory
 
Just FYI, latest driver is working great now :)

zander 06-09-07 09:09 PM

Re: Strange behaviour by Enemy Territory
 
That's good to hear, thanks for the update.


All times are GMT -5. The time now is 05:18 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.