nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Problems with my external projector (http://www.nvnews.net/vbulletin/showthread.php?t=92454)

everolth 05-31-07 10:35 AM

Problems with my external projector
 
Hi,

I have a Geforce Go 7900 GS in my laptop and I used to watch movies and stuff in my EPSON projector. The projector supports wide screen resolutions. I was using nvidia-settings in order to set everything up. I would plug the projector, click on detect displays and a display called EPSON would be detected and I could set its resolution to a wide range of choices including both 4:3 resolutions and 16:9 resolutions. However I performed some upgrades in my linux distribution (I use Gentoo) using its package system, and some changes in my xorg.cong file. When I tried to use my projector again, nvidia-settings would detect the projector as CRT-0 in stead of EPSON and I can no longer choose wide screen resolutions. I have tried to go back to an old xorg.conf file but it does not work. Does anybody else have the same problem?

I use the 64 bit version of the 1.0-9755 driver. This is my xorg.conf file:

Section "ServerLayout"
Identifier "X.Org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "PS/2 Mouse" "AlwaysCore"
# Serial Mouse not detected
InputDevice "USB Mouse" "AlwaysCore"
InputDevice "Synaptics" "AlwaysCore"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "true"

EndSection

Section "Files"
FontPath "/usr/share/fonts/util"
FontPath "/usr/share/fonts/encodings"
FontPath "/usr/share/fonts/misc"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/terminus"
FontPath "/usr/share/fonts/corefonts"
FontPath "/usr/local/share/fonts"
FontPath "/usr/share/fonts/default"
FontPath "/usr/share/fonts/TTF"
FontPath "/usr/share/fonts/type1"
FontPath "/usr/share/fonts/100dpi"
FontPath "/usr/share/fonts/75dpi"
FontPath "/usr/share/fonts/arphicfonts"
FontPath "/usr/share/fonts/jisx0213"
FontPath "/usr/share/fonts/shinonome"
FontPath "/usr/share/fonts/baekmuk-fonts"
FontPath "/usr/share/fonts/kacst-fonts"
FontPath "/usr/share/fonts/sgi-fonts"
FontPath "/usr/share/fonts/unfonts"
FontPath "/usr/share/fonts/default/ghostscript"
FontPath "/usr/share/fonts/xfonts-cronyx-100dpi:unscaled"
FontPath "/usr/share/fonts/xfonts-cronyx-75dpi:unscaled"
FontPath "/usr/share/fonts/xfonts-cronyx-misc:unscaled"
FontPath "/usr/share/fonts/xfonts-cronyx-100dpi"
FontPath "/usr/share/fonts/xfonts-cronyx-75dpi"
FontPath "/usr/share/fonts/xfonts-cronyx-misc"
FontPath "/usr/share/fonts/xfonts-cronyx-cp1251-100dpi:unscaled"
FontPath "/usr/share/fonts/xfonts-cronyx-cp1251-75dpi:unscaled"
FontPath "/usr/share/fonts/xfonts-cronyx-cp1251-misc:unscaled"
FontPath "/usr/share/fonts/xfonts-cronyx-cp1251-100dpi"
FontPath "/usr/share/fonts/xfonts-cronyx-cp1251-75dpi"
FontPath "/usr/share/fonts/xfonts-cronyx-cp1251-misc"
FontPath "/usr/share/fonts/xfonts-cronyx-isocyr-100dpi:unscaled"
FontPath "/usr/share/fonts/xfonts-cronyx-isocyr-75dpi:unscaled"
FontPath "/usr/share/fonts/xfonts-cronyx-isocyr-misc:unscaled"
FontPath "/usr/share/fonts/xfonts-cronyx-isocyr-100dpi"
FontPath "/usr/share/fonts/xfonts-cronyx-isocyr-75dpi"
FontPath "/usr/share/fonts/xfonts-cronyx-isocyr-misc"
FontPath "/usr/share/fonts/xfonts-cronyx-koi8r-100dpi:unscaled"
FontPath "/usr/share/fonts/xfonts-cronyx-koi8r-75dpi:unscaled"
FontPath "/usr/share/fonts/xfonts-cronyx-koi8r-misc:unscaled"
FontPath "/usr/share/fonts/xfonts-cronyx-koi8r-100dpi"
FontPath "/usr/share/fonts/xfonts-cronyx-koi8r-75dpi"
FontPath "/usr/share/fonts/xfonts-cronyx-koi8r-misc"
FontPath "/usr/share/fonts/xfonts-cronyx-koi8u-100dpi:unscaled"
FontPath "/usr/share/fonts/xfonts-cronyx-koi8u-75dpi:unscaled"
FontPath "/usr/share/fonts/xfonts-cronyx-koi8u-misc:unscaled"
FontPath "/usr/share/fonts/xfonts-cronyx-koi8u-100dpi"
FontPath "/usr/share/fonts/xfonts-cronyx-koi8u-75dpi"
FontPath "/usr/share/fonts/xfonts-cronyx-koi8u-misc"
EndSection

Section "Module"
Load "ddc"
Load "vbe"
# Load "GLcore"
Load "dbe"
# Load "dri"
# Load "extmod"
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection
Load "glx"
Load "bitmap"
Load "type1"
Load "freetype"
Load "record"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "inspiron"
Option "XkbLayout" "es"
# Option "XkbOptions" "grp:toggle,grp_led:scroll"
# Option "XkbVariant" ",winkeys"
EndSection

Section "InputDevice"
Identifier "Serial Mouse"
Driver "mouse"
Option "Protocol" "Microsoft"
Option "Device" "/dev/ttyS0"
Option "Emulate3Buttons" "true"
Option "Emulate3Timeout" "70"
Option "SendCoreEvents" "true"
EndSection

Section "InputDevice"
Identifier "PS/2 Mouse"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/misc/psaux"
Option "Emulate3Buttons" "true"
Option "Emulate3Timeout" "70"
Option "SendCoreEvents" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "USB Mouse"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "SendCoreEvents" "true"
Option "Protocol" "IMPS/2"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"
EndSection

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Protocol" "event"
Option "Device" "/dev/input/by-path/platform-i8042-serio-1-event-mouse"
Option "LeftEdge" "1900"
Option "RightEdge" "5400"
Option "TopEdge" "1900"
Option "BottomEdge" "4000"
Option "FingerLow" "25"
Option "FingerHigh" "30"
Option "MaxTapTime" "180"
Option "MaxTapMove" "220"
Option "VertScrollDelta" "100"
Option "MinSpeed" "0.02"
Option "MaxSpeed" "0.10"
Option "AccelFactor" "0.0010"
Option "SHMConfig" "true"
EndSection

# Auto-generated by mkxf86config

Section "Monitor"
Identifier "Monitor0"
HorizSync 28.0 - 96.0
VertRefresh 50.0 - 75.0
EndSection

Section "Device"
Identifier "nvidia0"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "GeForce Go 7900 GS"
VideoRam 262144
# Option "NvAGP" "0"
Option "RenderAccel" "true"
Option "TripleBuffer" "true"
Option "NoFlip" "True"
Option "AllowGLXWithComposite" "true"
Option "Coolbits" "1" #### this enables you to use nvidia-settings AA & FSAA
Option "BackingStore" "true"
Option "AddARGBGLXVisuals" "true"
Option "DamageEvents" "True"
Option "UseEvents" "False"
#BusID "PCI:1:0:0"
EndSection

Section "Extensions"
Option "Composite" "enable"
Option "RENDER" "Enable"
Option "DAMAGE" "Enable"
EndSection


Section "Screen"
Identifier "Screen0"
Device "nvidia0"
Monitor "Monitor0"
# Option "TwinView" "1"
# Option "metamodes" "CRT: 1280x720 +0+0, DFP: 1280x720 +0+0"
DefaultColorDepth 24
SubSection "Display"
Depth 1
Modes "1920x1200" "1920x1080" "1680x1050" "1600x1200" "1440x900" "1280x1024" "1280x800" "1280x720" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 4
Modes "1920x1200" "1920x1080" "1680x1050" "1600x1200" "1440x900" "1280x1024" "1280x800" "1280x720" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 8
Modes "1920x1200" "1920x1080" "1680x1050" "1600x1200" "1440x900" "1280x1024" "1280x800" "1280x720" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 15
Modes "1920x1200" "1920x1080" "1680x1050" "1600x1200" "1440x900" "1280x1024" "1280x800" "1280x720" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 16
Modes "1920x1200" "1920x1080" "1680x1050" "1600x1200" "1440x900" "1280x1024" "1280x800" "1280x720" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 24
Modes "1920x1200" "1920x1080" "1680x1050" "1600x1200" "1440x900" "1280x1024" "1280x800" "1280x720" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 32
Modes "1920x1200" "1920x1080" "1680x1050" "1600x1200" "1440x900" "1280x1024" "1280x800" "1280x720" "1024x768" "800x600"
EndSubSection
EndSection


#Section "DRI"
# Mode 0666
#EndSection

netllama 05-31-07 10:37 AM

Re: Problems with my external projector
 
You'll need to generate and attach an nvidia-bug-report.log.

everolth 05-31-07 11:02 AM

Re: Problems with my external projector
 
1 Attachment(s)
I am attaching my nvidia-bug-report.log in this reply

netllama 05-31-07 11:16 AM

Re: Problems with my external projector
 
I don't see any indication that the Epson projector was connected when this bug report was generated. Was the problem present when the bug report was generated?

everolth 05-31-07 11:36 AM

Re: Problems with my external projector
 
1 Attachment(s)
Ups, sorry, this time I made sure that my X server was started with the projector connected so everything should be there.

netllama 05-31-07 02:20 PM

Re: Problems with my external projector
 
Looks like your projector isn't providing an EDID:
(WW) NVIDIA(GPU-0): Unable to read EDID for display device CRT-0

Is the projector directly attached to the graphics card, without any intermediary devices? What kind of cable are you using to attach it?

everolth 05-31-07 07:52 PM

Re: Problems with my external projector
 
I am connecting the projector using the VGA input of the projector and the VGA output of the laptop, which I assume comes directly from the graphics card and I am using a male-male VGA cable. The funny thing is that this used to work perfectly a few days ago and it even detected the projector as "EPSON(seiko)" or something like this.
I tested the projector with windows vista and I managed to set the resolution to e.g. 1280x720 successfully, I suppose that the projector and the cable are still working.
Thank you for your quick replies and your help :) !

netllama 05-31-07 08:30 PM

Re: Problems with my external projector
 
If this worked a few days ago and no longer works, then I'd suggest undoing whatever has changed.

All that I can tell you from your bug report is that the EDID from your projector is not being detected, which suggests a hardware problem.

everolth 06-08-07 12:51 PM

Re: Problems with my external projector
 
Hi again,

I have been trying a lot of stuff like replacing the VGA cable with a new one, which did not work or installing a new linux (Debian) from scratch in an external hard drive, which produced the same results. As Netllama said, this has to be a hardware problem, hopefully in the projector and not my laptop. So the question now is: is it possible to "force" a resolution for the projector? In other words: When my laptop could read the EDID I found that the best resolution was 1280x720. However now I cannot choose this resolution. Is there any way I can choose this resolution now?
Another possibility would be to use other input of the projector. It has 3 more inputs apart from the VGA: S-Video, which I think does not have enough quality, Composite (RCA), which is worse than S-Video I think and finally there is this Component input which consists of 3 RCA inputs for red green and blue. If I use a DVI to RCA cable for example, will I be able to get 1280x720 resolution? (for example, this one http://www.amazon.co.uk/Professional...1325097&sr=8-2)

Thank you

rerushg 06-08-07 05:04 PM

Re: Problems with my external projector
 
Got kind of a bad feeling about this but I'll dive in...:)

Since your projector has all those inputs it surely can be driven with an analog signal and your NV card can do that. But first....
Can you confirm projector is working from another source (cable box maybe?), preferably via VGA cable?
Your laptop has only VGA output, right?
Have you looked at the Nvidia "read me" stuff on their site? Especially the TV-out stuff?
Since you've changed everything can you send a new bug report with projector attached to VGA?
(And the stupid questions, of course..) Is the projector set up properly? Is input mode selectable? Kids been goofing with the remote maybe? :)


All times are GMT -5. The time now is 10:27 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.