nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Problem with compiling driver under kernel-2.6.22 (http://www.nvnews.net/vbulletin/showthread.php?t=92863)

Delirium 06-07-07 10:14 AM

Problem with compiling driver under kernel-2.6.22
With the newest version of kernel 2.6.22-rc4-33 under OpenSuse 10.2 I have problem with compiling drivers. I'v tried with all version of drivers I have: 9629, 9755 and 100.14.06.

Here is listing from nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Thu Jun 7 16:54:07 2007

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
precompiled interfaces : true
no ncurses color : false
query latest version : false
OpenGL header files : true
no questions : false
silent : false
no recursion : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
no kernel module : false
force SELinux : default
no X server check : false
force tls : (not specified)
X install prefix : (not specified)
X library install path : (not specified)
X module install path : (not specified)
OpenGL install prefix : (not specified)
OpenGL install libdir : (not specified)
utility install prefix : (not specified)
utility install libdir : (not specified)
doc install prefix : (not specified)
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> There appears to already be a driver installed on your system (version: 1.0-
9629). As part of installing this driver (version: 1.0-9629), the existing
driver will be uninstalled. Are you sure you want to continue? ('no' will a
bort installation) (Answer: Yes)
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: No)
-> No precompiled kernel interface was found to match your kernel; this means
that the installer will need to compile a new kernel interface.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
-> Kernel source path: '/lib/modules/2.6.22-rc4-33-default/source'
-> Kernel output path: '/lib/modules/2.6.22-rc4-33-default/build'
-> Performing rivafb check.
-> Performing nvidiafb check.
-> Cleaning kernel module build directory.
executing: 'cd ./usr/src/nv; make clean'...
rm -f -f nv.o nv-vm.o os-agp.o os-interface.o os-registry.o nv-i2c.o nv.o nv
-vm.o os-agp.o os-interface.o os-registry.o nv-i2c.o nvidia.mod.o
rm -f -f build-in.o nv-linux.o *.d .*.{cmd,flags}
rm -f -f nvidia.{o,ko,mod.{o,c}} nv_compiler.h *~
rm -f -f stprof stprof.o symtab.h Modules.symvers
rm -f -rf .tmp_versions
-> Building kernel module:
executing: 'cd ./usr/src/nv; make module SYSSRC=/lib/modules/2.6.22-rc4-33-d
efault/source SYSOUT=/lib/modules/2.6.22-rc4-33-default/build'...

NVIDIA: calling KBUILD...
make CC=cc KBUILD_OUTPUT=/lib/modules/2.6.22-rc4-33-default/build KBUILD_VER
BOSE=1 -C /lib/modules/2.6.22-rc4-33-default/source SUBDIRS=/tmp/selfgz9766/
NVIDIA-Linux-x86-1.0-9629-pkg1/usr/src/nv modules
make -C /lib/modules/2.6.22-rc4-33-default/build \
KBUILD_SRC=/usr/src/linux-2.6.22-rc4-33 \
KBUILD_EXTMOD="/tmp/selfgz9766/NVIDIA-Linux-x86-1.0-9629-pkg1/usr/src/nv" -
f /usr/src/linux-2.6.22-rc4-33/Makefile modules
test -e include/linux/autoconf.h -a -e include/config/auto.conf || ( \
echo; \
echo " ERROR: Kernel configuration is invalid."; \
echo " include/linux/autoconf.h or include/config/auto.conf are mis
sing."; \
echo " Run 'make oldconfig && make prepare' on kernel src to fix it
."; \
echo; \
mkdir -p /tmp/selfgz9766/NVIDIA-Linux-x86-1.0-9629-pkg1/usr/src/nv/.tmp_vers
rm -f /tmp/selfgz9766/NVIDIA-Linux-x86-1.0-9629-pkg1/usr/src/nv/.tmp_version
make -f /usr/src/linux-2.6.22-rc4-33/scripts/Makefile.build obj=/tmp/selfgz9
echo \#define NV_COMPILER \"`cc -v 2>&1 | tail -n 1`\" > /tmp/selfgz9766/NVI
cc -Wp,-MD,/tmp/selfgz9766/NVIDIA-Linux-x86-1.0-9629-pkg1/usr/src/nv/.nv.o
.d -nostdinc -isystem /usr/lib/gcc/i586-suse-linux/4.1.2/include -D__KERNEL
__ -Iinclude -Iinclude2 -I/usr/src/linux-2.6.22-rc4-33/include -include incl
ude/linux/autoconf.h -I/tmp/selfgz9766/NVIDIA-Linux-x86-1.0-9629-pkg1/usr/
src/nv -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -Werror-implicit-fun
ction-declaration -fno-strict-aliasing -fno-common -Os -pipe -msoft-float -m
regparm=3 -freg-struct-return -mpreferred-stack-boundary=2 -march=i586 -mtun
e=generic -ffreestanding -maccumulate-outgoing-args -DCONFIG_AS_CFI=1 -DCONF
IG_AS_CFI_SIGNAL_FRAME=1 -I/usr/src/linux-2.6.22-rc4-33/include/asm-i386/mac
h-generic -Iinclude/asm-i386/mach-generic -I/usr/src/linux-2.6.22-rc4-33/inc
lude/asm-i386/mach-default -Iinclude/asm-i386/mach-default -fomit-frame-poin
ter -fno-stac
k-protector -Wdeclaration-after-statement -Wno-pointer-sign -I/tmp/selfgz97
66/NVIDIA-Linux-x86-1.0-9629-pkg1/usr/src/nv -Wall -Wimplicit -Wreturn-type
-Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpointer-arith -Wno-multi
char -Werror -O -fno-common -msoft-float -MD -Wsign-compare -Wno-cast-qual -
a)" -c -o /tmp/selfgz9766/NVIDIA-Linux-x86-1.0-9629-pkg1/usr/src/nv/.tmp_nv.
o /tmp/selfgz9766/NVIDIA-Linux-x86-1
In file included from /usr/src/linux-2.6.22-rc4-33/include/linux/list.h:8,
from /usr/src/linux-2.6.22-rc4-33/include/linux/wait.h:22,
from include2/asm/semaphore.h:41,
from /usr/src/linux-2.6.22-rc4-33/include/linux/sched.h:59,
from /usr/src/linux-2.6.22-rc4-33/include/linux/utsname.h:3
from /tmp/selfgz9766/NVIDIA-Linux-x86-1.0-9629-pkg1/usr/src
from /tmp/selfgz9766/NVIDIA-Linux-x86-1.0-9629-pkg1/usr/src
/usr/src/linux-2.6.22-rc4-33/include/linux/prefetch.h: In function ‘prefet
/usr/src/linux-2.6.22-rc4-33/include/linux/prefetch.h:62: warning: pointer o
f type ‘void *’ used in arithmetic
In file included from include2/asm/irq.h:15,
from /usr/src/linux-2.6.22-rc4-33/include/linux/irq.h:23,
from include2/asm/hardirq.h:5,
from /usr/src/linux-2.6.22-rc4-33/include/linux/hardirq.h:7
from /usr/src/linux-2.6.22-rc4-33/include/linux/interrupt.h
from /tmp/selfgz9766/NVIDIA-Linux-x86-1.0-9629-pkg1/usr/src
from /tmp/selfgz9766/NVIDIA-Linux-x86-1.0-9629-pkg1/usr/src
42: warning: "/*" within comment
:1: error: unterminated comment
:23: warning: no newline at end of file
1: error: unterminated #ifndef
1: error: unterminated #ifndef
In file included from include2/asm/hardirq.h:5,
from /usr/src/linux-2.6.22-rc4-33/include/linux/hardirq.h:7
from /usr/src/linux-2.6.22-rc4-33/include/linux/interrupt.h
from /tmp/selfgz9766/NVIDIA-Linux-x86-1.0-9629-pkg1/usr/src
from /tmp/selfgz9766/NVIDIA-Linux-x86-1.0-9629-pkg1/usr/src
/usr/src/linux-2.6.22-rc4-33/include/linux/irq.h: At top level:
/usr/src/linux-2.6.22-rc4-33/include/linux/irq.h:178: error: ‘NR_IRQS’ u
ndeclared here (not in a function)
In file included from /usr/src/linux-2.6.22-rc4-33/include/linux/interrupt.h
from /tmp/selfgz9766/NVIDIA-Linux-x86-1.0-9629-pkg1/usr/src
from /tmp/selfgz9766/NVIDIA-Linux-x86-1.0-9629-pkg1/usr/src
/usr/src/linux-2.6.22-rc4-33/include/linux/hardirq.h:40:27: warning: "NR_IRQ
S" is not defined
/tmp/selfgz9766/NVIDIA-Linux-x86-1.0-9629-pkg1/usr/src/nv/nv.c:110: warning:
‘kmem_cache_t’ is deprecated
/tmp/selfgz9766/NVIDIA-Linux-x86-1.0-9629-pkg1/usr/src/nv/nv.c: In function
/tmp/selfgz9766/NVIDIA-Linux-x86-1.0-9629-pkg1/usr/src/nv/nv.c:1848: warning
: ‘deprecated_irq_flag’ is deprecated (declared at /usr/src/linux-2.6.22
/tmp/selfgz9766/NVIDIA-Linux-x86-1.0-9629-pkg1/usr/src/nv/nv.c:1848: warning
: ‘deprecated_irq_flag’ is deprecated (declared at /usr/src/linux-2.6.22
/tmp/selfgz9766/NVIDIA-Linux-x86-1.0-9629-pkg1/usr/src/nv/nv.c:1849: warning
: passing argument 2 of ‘request_irq’ from incompatible pointer type
make[4]: *** [/tmp/selfgz9766/NVIDIA-Linux-x86-1.0-9629-pkg1/usr/src/nv/nv.o
] Error 1
make[3]: *** [_module_/tmp/selfgz9766/NVIDIA-Linux-x86-1.0-9629-pkg1/usr/src
/nv] Error 2
make[2]: *** [modules] Error 2
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.

The same problem I had in previous kernel version (2.6.22-rc3-git2-47.1) but there was no problem with 9629 drivers. All other drivers were giving the same error. Is there any solution for this?

netllama 06-07-07 10:37 AM

Re: Problem with compiling driver under kernel-2.6.22
1.0-9629 is no longer supported. Please use 1.0-9755, 100.14.06 or 1.0-9639 depending on your GPU.

ViN86 06-07-07 01:11 PM

Re: Problem with compiling driver under kernel-2.6.22
if you have the same problem after trying the next version, make sure your kernel source is maintained and all configs are placed in the correct locations and can be seen by the nvidia installer.

Delirium 06-08-07 02:49 AM

Re: Problem with compiling driver under kernel-2.6.22
netllama - as I wrote, under 2.6.22-rc3-git2-47.1 there was no problem only with 9629. All other versions (9755 and 100.14.06) give errors during compiling.

Under 2.6.22-rc4-33 no one of these a/m drivers is working.
Only downgrading kernel to 2.6.22-rc3-git2-29 gives oportunity to make 100.14.06 working well.

ViN86 - I checked if there is everything ok with kernel sources. It seems there is no problem - installation program is passing initial checks but shows errors in compiling procedure.

netllama 06-08-07 10:18 AM

Re: Problem with compiling driver under kernel-2.6.22
Please attach the installer log against a supported driver version.

Delirium 06-10-07 10:12 AM

Re: Problem with compiling driver under kernel-2.6.22
1 Attachment(s)
Finally I found reason why newest drivers won't to compile. It seems to be OpenSuse problem.

After upgrading kernel and kernel-sources rpms Nvidia driver installer see kernel sources and try to compile but it gives errors like in attachment.

After a few tries I found that forcing kernel-sources to install (by rpm -ihv --force) gives opportunity to compile drivers in right way (but only to next reboot). I don't know what is the reason but I think it is not directly conected with drivers functionality.

zander 06-10-07 01:25 PM

Re: Problem with compiling driver under kernel-2.6.22
Yes, the errors in the nvidia-installer.log file suggest the kernel development files the module was being built against were in a bad state.

All times are GMT -5. The time now is 10:04 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.