nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   100.14.09 with 8600GT - random lockups (http://www.nvnews.net/vbulletin/showthread.php?t=93082)

...Max... 06-11-07 11:58 AM

100.14.09 with 8600GT - random lockups
 
Ubuntu 7.04, 2.6.20-16, XFX 8600GT; 100.14.09.

X Server locks up intermittently, often along with keyboard. Mouse cursor is sometimes responsive, sometimes not.

Observed causes:

- Screen saver activation
- Attempting to resize the window while application is active; Synaptic PM does it very well.
- No particular cause at all

I've tried suggestions in the stickies; no luck so far. Filed the bug report with nVidia too. Was just wondering what else can I try to better diagnose the problem.

I've spent quite a bit of time fighting the installation and am by now reasonably sure the RIGHT modules are being loaded... for what good it does me.

The whole thing is rather disappointing for someone used to (mostly) flawless performance of nVidia drivers under Windows for years now :-P

...Max...

netllama 06-11-07 12:00 PM

Re: 100.14.09 with 8600GT - random lockups
 
The sticky posts instruct you to attach an nvidia-bug-report.log which you've not done. Also, you stated that you tried all the suggestions in the stickies. Please detail what you've tried.

...Max... 06-11-07 12:46 PM

Re: 100.14.09 with 8600GT - random lockups
 
1 Attachment(s)
I had attached the nvidia-bug-report.log to my bug report; here it comes now. Note that it has not been produced during/after the actual lockup occurrence as my only remedy for those so far was hardware reset. If it is paramount to gain access to the box after a crash (assuming daemons still respond), I can try that.

Going by http://www.nvnews.net/vbulletin/showthread.php?t=58498

- scanned logs for NVRM messages: nothing suspicious
- scanned /var/log/dmesg for "PCI: Using MMCONFIG": not there
- kernel is 2.6.20-16, so concerns for earlier versions should not apply
- no obvious firmware updates available

I _did_not_ try "idle=poll" as I am not yet sure about its [primarily performance] implications on a system intended to run multiple active VMs.

Thanks in advance for any suggestions. My alternative is to go back to generic open-source drivers as 3D is not my primary concern right now, but I'd rather get the nVidia driver to work in a stable manner.

...Max...

netllama 06-11-07 12:50 PM

Re: 100.14.09 with 8600GT - random lockups
 
If you can ssh into the system while X is hung, that would be most useful in getting a bug report.

Have you verified that you're using the latest motherboard BIOS?

...Max... 06-11-07 01:45 PM

Re: 100.14.09 with 8600GT - random lockups
 
I tried connecting to the locked system... no luck. The TCP stack is, I think, alive -- pings are returned. But no response on ssh or any other ports I could think of.

Updating m/b BIOS to R02 brought no improvement.

...Max...

netllama 06-11-07 01:51 PM

Re: 100.14.09 with 8600GT - random lockups
 
Have you tried disabling the Composite extension in xorg.conf and/or setting RenderAccel to false?

...Max... 06-11-07 02:37 PM

Re: 100.14.09 with 8600GT - random lockups
 
1 Attachment(s)
Nope, neither did the trick (I am attaching a new "bug report log" so you can see that these options have indeed been changed). I do see some new variations of the lockup, to wit:

- The test case to reproduce the crash is that I run Synaptic PM, type in a nonsense search string and while it is searching I grab the window corner and drag it around.

- Prior to disabling the options it would lock up almost immediately.

- Now I've been seeing it lock up and then unfreeze after a few seconds; also saw the X server spontaneously restart (I got the login screen). Repeating the exercise still leads to an unrecoverable crash.

Weird, eh...

...Max...

...Max... 06-11-07 10:34 PM

Re: 100.14.09 with 8600GT - random lockups
 
Just saw the same thing happen with a simple mouse movement. And I think both mouse and keyboard lock up together... and they are both USB...

Is there such a thing as a conflict between USB and graphics card? IRQ levels, or something... Sadly, I have no idea how hardware interrupts are dispatched in Linux kernel :(

...Max...

...Max... 06-12-07 11:50 AM

Re: 100.14.09 with 8600GT - random lockups
 
Hate to be so insistent.... but perhaps the resident nVidia people will advise me. Is it any good to wait for the resolution of this issue, or should I just switch back to the open source driver?

gulrich 06-14-07 12:19 PM

Re: 100.14.09 with 8600GT - random lockups
 
Max, I am having similar issues and think I am experiencing the same bug. I upgraded from FC6 to F7 and with the upgrade came a change from nvidia 97xx series drivers from livna to the newer 100.14.09 drivers also from livna. I am running a 5500FX card (older but good enough). Like you, everything is fine with the 100.14.09 until the screen is reset, for example compiz is running then starting beryl it does a redraw and X freezes immediately. No more keyboard but mouse still moves around over frozen screen. This isn't just loading beryl because if I stick with compiz, it runs OK for a while until something else invokes a redraw of the screen. Then the same freeze happens. So I loaded the old 9762 nvidia driver still available from livna for F7 and now everything is rock solid. So I will be staying with the old 9762 driver I guess until this gets fixed in the 100.x.x series.

All this to say that even with a different distro, different card etc., I am seeing what seems to be the same problem. I would suggest to find the old 9762 nvidia driver. If you do, please let me know if it fixes everything as it did for me.

Mr. NVIDIA developer, I am willing to go quite a distance to help you get this fixed if you want to work with me. Please fix this... :-)

...Max... 06-14-07 02:15 PM

Re: 100.14.09 with 8600GT - random lockups
 
I am not sure if I can find an older driver that would work with my card (8600GT is quite new). In any case I got the open source driver (nv) to work and for the moment that should be enough.

Of course one could say that I was asking for trouble myself: running a late-model GPU on a late-model m/b under 64-bit OS ;-) Oh well, at least my job does not depend on this exercise!

rjpa123 06-14-07 05:48 PM

Re: 100.14.09 with 8600GT - random lockups
 
My thread...http://www.nvnews.net/vbulletin/showthread.php?t=93273

Same problem.....random X restarts.

Try 1.0-9755....everything works for my 8800 GTX.


All times are GMT -5. The time now is 12:06 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.