nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   s3 resume failures (http://www.nvnews.net/vbulletin/showthread.php?t=93090)

sgoodall 06-11-07 01:27 PM

s3 resume failures
 
My laptop fails to resume every now and then (usually in the least appropriate time). The /sys/power/pm_trace stuff has now shown the problem device is my nvidia card. On attempting to resume, the screen will stay off/blank and caps lock etc lights do not change when the appropriate button is pressed. SysRq functions usually work, usually with a little delay, indicating perhaps something is using a lot of cpu? Rebooting sometimes leaves the machine with the display turned off requiring a power cycle to turn it back on. This perhaps indicates some more persistent state is being corrupted?

My other nvidia issues can be worked around (e.g. using the nv driver first to allow the nvidia driver the suspend more than once -- something that is not required with the legacy 7xxx drivers) but this bug is more serious as it unpredictable as to when it will occur leading to potential data loss if some applications have unsaved state. Sometimes it will fail to resume after the first try, or it can be after many tries.

I am running Fedora 7 on a Dell Inspiron 8500 with a nvidia go 4200 card. I am running the livna kmod-nvidia-96xx (version 9631) drivers. This problem has occurred on all previous driver versions (livna and nvidia packages) and on the various fedora/redhat versions I have tried. Its only the pm_trace that has pin-pointed the exact cause.

I really would like this particular issue solved and I do not mind doing some hacking to get it fixed.

sgoodall 06-11-07 01:30 PM

Re: s3 resume failures
 
1 Attachment(s)
See attached for the bug report. It's been taken straight from boot up as I am unable to take one after my problem occurs.

netllama 06-11-07 01:33 PM

Re: s3 resume failures
 
1.0-9631 is no longer supported, so I'd suggest retesting with 1.0-9639.

You should also verify that you're using the latest BIOS.

sgoodall 06-11-07 02:45 PM

Re: s3 resume failures
 
My problem still occurs with the 9639 drivers. I am using the latest machine and video bios' from the dell site.

seeker010 06-11-07 06:55 PM

Re: s3 resume failures
 
I was told to try this for 100 series; see if it works for you. I didn't get a chance to try it before switching to x86_64, where going into S3 causes hangs.
Quote:

Please try adding the following line to the /etc/modules.conf or
/etc/modprobe.conf file and restart the computer.

options nvidia NVreg_SaveVBios=1

sgoodall 06-12-07 03:34 PM

Re: s3 resume failures
 
No, unfortunately that did not work for me.


All times are GMT -5. The time now is 01:31 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.