nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Random freezes on Fedora 7 (http://www.nvnews.net/vbulletin/showthread.php?t=93110)

Hapless Hero 06-11-07 06:41 PM

Random freezes on Fedora 7
 
I have been attempting to use the proprietary nVidia drivers since I put together this laptop. First, the hardware specs:

ASUS ASMobile Z62Jm
14.1" 1280x800 screen
Intel Core 2 Duo T7200 2.0 GHz 4MB L2 Cache
nVidia GeForce Go 7300 128MB dedicated/256MB total shared VRAM
120GB Western Digital SATA hdd
2 GB (1GB x 2) 533MHz OCZ Value Series DDR2 RAM
Intel 3945abg Pro Wireless PCIE card

Software:
Fedora 7 x86_64
Windows XP Pro

Windows works absolutely fine graphics wise...

Fedora 7, on the other hand, has problems...
Whether I use either the nVidia installer or the Livna packages, I get the same problem: random freezes for no apparently reason while attempting to do something. This "something" can be anything from booting Fedora to opening menus in GNOME (although it usually boots)--I once even got the 3D game Scorched3D to run fine for a while and Beryl to work. But just about every time, everything will freeze--except the mouse. Screen shows no other activity, Ctrl-Alt-Backspace does nothing, and neither does Ctrl-Alt-F6 or F7.

Sometimes, it comes out of the freeze and shows one of the processor cores having run at 100% (50% total CPU load) load for a while, and when it unfreezes load goes back down to normal. Other times, I will wait a few minutes and if nothing happens, I will simply press the power button.

I have tried the following fixes:
1. idle=poll kernel argument - no effect
2. Downgrading and upgrading kernel and driver version, Fedora 6 and 7, Livna or nVidia.com drivers - no effect
3. acpi=off noapic kernel argument - no effect
4. Using "nv" driver - works perfectly except no 3D rendering

Does anyone have any other suggestions I can try before I (sadly) give up?

seeker010 06-11-07 06:52 PM

Re: Random freezes on Fedora 7
 
hmm your problems seem similar to mine. have you tried noapic?

Hapless Hero 06-11-07 06:56 PM

Re: Random freezes on Fedora 7
 
Just as you were posting, I was. No effect. But thanks for the quick reply!

Hapless Hero 06-13-07 02:47 PM

Re: Random freezes on Fedora 7
 
No progress yet--are there any specific fixes anyone else can suggest?

netllama 06-13-07 02:54 PM

Re: Random freezes on Fedora 7
 
All 'specific fixes' and default recommendations are already included in the forum sticky posts.

Hapless Hero 06-13-07 03:35 PM

Re: Random freezes on Fedora 7
 
Thanks, saw those already and listed the ones I've tried.

As of now, I have also tried going between the 96xx (legacy) driver and version 100.14.09.

Did I miss a fix? I feel like I've tried them all.

netllama 06-13-07 03:39 PM

Re: Random freezes on Fedora 7
 
You've not provided a bug report.

Hapless Hero 06-13-07 03:54 PM

Re: Random freezes on Fedora 7
 
1 Attachment(s)
Here is the generated bug report file.

Oops, wrong one, see later post below.

netllama 06-13-07 05:59 PM

Re: Random freezes on Fedora 7
 
That bug report is against the 'nv' X driver.

Hapless Hero 06-13-07 07:58 PM

Re: Random freezes on Fedora 7
 
1 Attachment(s)
Ooh, I forgot I switched to nv...

Here we go.

Hm actually this bug report doesn't reflect my problem, the problem here would be that it won't start, but I think that is mostly a product of my having fiddled around too much with stuff.

I'll go and try to freshen my install before I post another bug report.

netllama 06-13-07 09:25 PM

Re: Random freezes on Fedora 7
 
Plus you're still using the 'nv' driver.

kyleki 06-28-07 06:06 PM

Re: Random freezes on Fedora 7
 
1 Attachment(s)
I'm experiencing something very similar except that my mouse also freezes. I also haven't ever felt things would come back, so I've never seen the 100% CPU symptom you've mentioned. Reverting back to 100.14.09 fixes the problem for me.

I've attached my bug report when running with 100.14.11 on my Fedora 7, x86_64 box.

At first I thought this had something to do with the Livna rpms (Bug 1562), but I removed them and installed using the official Nvidia installer and experienced the same problem.

A good way I found to reproduce the problem was by running ppracer and playing through a few levels. Sometimes it froze right away, other times it took up to 3 levels.

If any additional information is needed to help fix this problem, I'd be more than happy to supply it.


All times are GMT -5. The time now is 11:55 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.