nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Setting up the computer to work with a splitter (http://www.nvnews.net/vbulletin/showthread.php?t=93660)

Chuck Law 06-22-07 07:53 AM

Setting up the computer to work with a splitter
 
Hey everyone,
I have another problem that I've run into. I have 2 X-servers running 2 separate displays, which come out of a nvidia quadro FX4500. These are going to a video network (a splitter and I think some type of video switching matrix).

I have the splitter (here) for playing around with before connecting to the video network and i've run into a problem. The output only works on the monitor that the is connected when the computer starts up (or maybe when X starts up, now that I think about it). I think there's some sort of back and forth communication between the video card and the display. Is there any option that I can set in the xorg.conf file in order to get the video card to transmit a generic signal all the time?
Thanks

netllama 06-22-07 10:43 AM

Re: Setting up the computer to work with a splitter
 
See the driver README's discussion of the ConnectedMonitor option. However there is no assurance of whether this will work with the product you've referenced.

Chuck Law 06-22-07 07:53 PM

Re: Setting up the computer to work with a splitter
 
I've done a lot of debugging (haven't tried the connected monitor option yet)

I've figured out that the splitter sends back the information from a large ldc (i think 1920 by 1440 or so) instead of the projector (1600x1200). Here's what I've learned:
1) The lcd says that it's displaying a 1920x1440 resolution image despite the fact that the xorg.conf file is configered to use 1600x1200 and shows a 1600x1200 size desktop (it says 1920x1440 as the native and backend resolution in the nvidia gui).
2) I noticed if X started with the projector directly connected to the computer, and then the high res screen was plugged in, lcd it would use 1600x1200 instead of it's native resolution, and the splitter would work. (in other words, edid info from the projector works for the lcd)
3) I tried starting X using only the projector. I then ran gtf 1600 1200 60, and put that in the xorg.conf file in the modeline section and then referenced that mode as the default mode. It didn't fix the resolution that was being sent to the lcd though. I also added Option "ModeValidation" "NoEdidModes". I stupidly forgot to try Option "UseEDID" "false" though.

So here's what I am still wondering:
1) Did I get the modeline process correct and use the right information?
2) If the lcd information is always given to the video card through the splitter, is what i tried in 3 plus the NoEdidModes option what I'm looking for?
3) If I use the NoEdidModes option, do I have to add any more information to the xorg file? (I have all the default settings from running the xconfig utility, and the added modeline and mode info.)

netllama 06-22-07 09:27 PM

Re: Setting up the computer to work with a splitter
 
You'll need to generate and attach an nvidia-bug-report.log if you'd like answers to those questions.


All times are GMT -5. The time now is 09:05 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.