nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   FX 5200 + Debian Etch won't work for me. (http://www.nvnews.net/vbulletin/showthread.php?t=93666)

Ponder 06-22-07 09:31 AM

FX 5200 + Debian Etch won't work for me.
1 Attachment(s)
I've read through the log I created and that will tell you everything about my system but please ignore the XFree86 sections because I'm now using Xorg.

I had a GeForce4 440MX installed initially under Debian Sarge, which worked well. I upgraded to Etch and used Hakix 1.0 to reinstall the drivers and Beryl and once again all was well, but I was finding Bery was too slow for regular use with that card so bought a slightly better FX 5200 and then my problems started.

First thing I noticed was that the initial boot kernel parameter VGA=775 (for my 1280x1024 TFT monitor) wasn't recognised. This is an annoyance, albeit minor.

First thing I tried on booting was startx, assuming the same drivers would work. I was wrong so I reinstalled using Hakix 1.0 again. This failed.

Then I tried with the nVidia proprietary drivers. The installer ran flawlessly but when I tried to startx (into KDE) it'd get as far as "Loading the Desktop" then everything would slow to a crawl as Xorg started eating CPU time. I could ssh in to stop the desktop manager most of the time but occasionally it'd be so bad that Xorg just wouldn't stop and a reboot would be required.

I've tried many changes to Xorg.conf and checked for conflicting libraries, and followed advice from elsewhere. The current log is with GLcore and dri Modules commented out, and this just wouldn't load the X Server at all.

I've tried Gnome, which loads, but as soon as I try any GL application it goes into crawl mode (Beryl has the habit of causing the total lockout).

My bug log is attached, can anyone help please?

netllama 06-22-07 10:50 AM

Re: FX 5200 + Debian Etch won't work for me.
I have a few questions:
0) Does this problem persist if you set NvAGP to 0 in xorg.conf ?
1) Does this problem persist if you disable the Composite extension in xorg.conf ?
2) Have you verified that you're using the latest motherboard BIOS?
3) Does the problem persist if you upgrade to a more recent kernel.org kernel?


Ponder 06-22-07 11:22 AM

Re: FX 5200 + Debian Etch won't work for me.
I have to apologise but impatience got the better of me so I tried the latest Ubuntu Live CD on my Media PC (normally Windows) and installed Beryl and it worked beautifully. That has an ATI X600 installed. This was with out of the box drivers.

Tried the same on this machine and it looked bad to start when glxgears showed a 250fps rate but looked very jerky. Loading Beryl turned the screen white and I could no longer do anything useful.

I've now got the hint and reinstalled the 440MX.

I'm going to need some very good evidence that what you'll suggest will have a chance of working before I try again.

To answer your questions specifically:

0) Unable to try at present. What does this actually do?

1) Won't this break Beryl? As you might have read this was my primary reason for upgrading.

2) Yes.

3) I'm not willing to go messing about with custom kernel builds and risking damaging the rest of the system which is working perfectly. If it won't work from the stock Etch kernel then as far as I'm concerned it's dead in the water.

FWIW the 440MX is working perfectly, it's just too slow to run Beryl as a primary desktop manager, and I do appreciate the help.

netllama 06-22-07 11:31 AM

Re: FX 5200 + Debian Etch won't work for me.
0) Setting NvAGP to 0 disables AGP transfer rates, and falls back to PCI rates. This would detemine whether the problem is an AGP driver, BIOS or hardware issue, or a problem elsewhere.
1) Yes, you need Composite to use Beryl. However, if the problem isn't present without Composite (and/or Beryl), then it could suggest a bug in X, or Beryl. Or it could still be a driver bug. Regardless, its a useful isolation test.
3) I wasn't advocating removing the current kernel, just adding another kernel for testing purposes.

You'll need to perform all of the tests I've requested to better isolate the cause of the problem. Its quite possible that they won't all be needed if the problem is eliminated after only performing some of them.

Ponder 06-22-07 11:46 AM

Re: FX 5200 + Debian Etch won't work for me.
Ok, 0) and 1) will be tested when I get a spare hour or two, possibly tomorrow night, 3) is perlexing me though, why would an old card require the very latest kernel?

I'm using 2.6.18-4 and the latest stable is 2.6.21-5. The Ubuntu kernel was 2.6.20-x. The machine is also used in a hobby-server environment so test kernels are not a task to be undertaken lightly.

One other thing I've noticed, all drivers (Etch and Ubuntu) have shown a 1 pixel wide vertical line down the screen which I thought was the monitor, but is no longer present with the old card back in. I'm beginning to wonder if it's the card itself at fault.

netllama 06-22-07 11:53 AM

Re: FX 5200 + Debian Etch won't work for me.
If this is an AGP or kernel bug, then a newer kernel might have it fixed. Clearly something has changed on the system. All of these tests are required to better isolate where the problem may be.

Ponder 06-22-07 01:46 PM

Re: FX 5200 + Debian Etch won't work for me.
Well I've solved one problem, I borrowed an older Fx 5200 (this time with 256MB RAM) from my neighbour and I get no lockouts, no crawling, etc. so I'm even more convinced it's a faulty card...


glxgears runs very flickery for about 5s then quits with the message "Aborted". Beryl starts up but freezes fairly soon after but Xorg doesn't eat the CPU and it's easily quit by logging in remotely and killing startkde.

I've tried disabling composite and setting NvAGP to 0 (and 1 and 3) but there's no difference.

Progress but not there yet. Any ideas on this one please?

netllama 06-22-07 01:52 PM

Re: FX 5200 + Debian Etch won't work for me.
I'd need to see a new bug report, however it doesn't appear that you've tried a newer kernel yet. Also, have you verified that the rest of your hardware isn't faulty?

Ponder 06-22-07 02:44 PM

Re: FX 5200 + Debian Etch won't work for me.
1 Attachment(s)
I'm sorry, you say "try a newer kernel" as though it's a trivial affair. The last time I compiled a kernel it took half a day's worth of configuring before I even got as far as a build.

However, I have attached another bug report.

The rest of the system runs flawlessly with uptimes only interrupted by power failures. It's on 24/7 running news, mail, web, irc, ftp, etc. server software and is completely up to date as per the Etch Stable repositories.

netllama 06-22-07 02:55 PM

Re: FX 5200 + Debian Etch won't work for me.
You should be able to use the same kernel configuration as was used for the kernel you're currently running. Building a kernel shouldn't require more than an hour on any hardware from the past 3-4 years.

Ponder 06-22-07 03:43 PM

Re: FX 5200 + Debian Etch won't work for me.
Looking at the newer HOWTO you may be right, but the last time I built a kernel was for 2.2.x. These days, the supplied kernels seem to do everything needed out of the box.

I'm really not convinced it's the kernel at fault here though or many others would be having the same problems. If it's going to be so much bother I'll revert back to the 440MX until I can pick up a cheap equivalent ATI card.

All times are GMT -5. The time now is 06:36 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.