nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   SuSE 10 100.14.11 installation problem (http://www.nvnews.net/vbulletin/showthread.php?t=93689)

rtcwp 06-22-07 05:06 PM

SuSE 10 100.14.11 installation problem
 
1 Attachment(s)
Yesterday I installed SuSE 10 on my computer. Installing the Nvidia driver through YaST didn't work, so I had to use the other way recompiling myself.

After following the steps - downloading gcc, make and kernel-source through YaST and attempting to install it it recompiled and told me the kernel header /lib/modules/2.6.13-15.15-smp/build/inclued/linux/kernel.h was not existing, so that I had to copy it from /usr/inclue/linux/etc.

The next attempt it gives me the error "Error: Unable to build the Nvidia kernel module", the rest is in the attached logs.

The graphic card I use is Nvidia 6200.

It's my first time I work with linux, so I'd be pleased if someone could help me.

netllama 06-22-07 05:18 PM

Re: SuSE 10 100.14.11 installation problem
 
The problem is here:
/bin/sh: scripts/basic/fixdep: No such file or directory

fixdep should be part of the kernel sources that SUSE provides.

rtcwp 06-23-07 09:05 AM

Re: SuSE 10 100.14.11 installation problem
 
I searched for the file and I do have it 6 times in

/usr/src/linux-2.6.13-15-obj/i386/bigsmp/scripts/basic
/usr/src/linux-2.6.13-15-obj/i386/debug/scripts/basic
/usr/src/linux-2.6.13-15-obj/i386/default/scripts/basic
/usr/src/linux-2.6.13-15-obj/i386/smp/scripts/basic
/usr/src/linux-2.6.13-15-obj/i386/um/scripts/basic
/usr/src/linux-2.6.13-15-obj/i386/xen/scripts/basic

I suppose it installed the file to a wrong directory like it already did with the kernel.h.

Where is the file supposed to be for it to find?

pe1chl 06-23-07 10:17 AM

Re: SuSE 10 100.14.11 installation problem
 
try this:
cd /usr/src/linux
make cloneconfig
make
(once it has compiled a few things you can just interrupt it with ctrl-c)
then try to install again.

rtcwp 06-23-07 11:09 AM

Re: SuSE 10 100.14.11 installation problem
 
Thank you very much, it's working


All times are GMT -5. The time now is 04:07 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.