nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Compiz performance under load (http://www.nvnews.net/vbulletin/showthread.php?t=93756)

kriko 06-24-07 11:58 AM

Compiz performance under load
 
When using compiz I get bad performance under load. To be precise - mouse is jerky when a program demands more cpu power (not only mouse, moving windows, resizing get also jerky). As I remember this never happened before on same hardware configuration, but 32-bit kernel (now I have 64-bit).
The problem is always visible, e.g. when launching koqueror, when using smart (installing new programs). Mouse gets really jerky.
When moving windows around (slowly) or slowly rotating cube, I can see CPU usage going to high levels (90% +), process causing this was Xorg.

Normally in 2d mode none of this problem is seen. Curently I'm launching compiz with:
Code:

#export __GL_YIELD="NOTHING"; compiz --replace --loose-binding --indirect-rendering ccp &
I read many performance optimization tweaks, did xorg.conf tweaks... don't know what else to do anymore.
Can you please help me to kill this problem. I started to think switching back to 32 bit, where compiz was really smooth under heavy load.... but better solution is to pinpoint the real problem, so I'm asking you - graphics experts.

EDIT: here I found someone describing my problem too:
http://lists.freedesktop.org/archive...ch/001686.html

user5124 07-19-07 06:52 AM

Re: Compiz performance under load
 
The gl yield nothing option improved it for me, but definitely didn't completely solve it. Thanks for the tip.

I'm running a Athlon 64 X2 4600 and a geforce 8800gtx. I guess I need to upgrade for smooth gui effects :P


All times are GMT -5. The time now is 08:07 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.