nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   mcp51 chipset: usb not working with "noapic" ... system freezes without "noapic" (http://www.nvnews.net/vbulletin/showthread.php?t=93781)

jmsjr 06-24-07 10:18 PM

mcp51 chipset: usb not working with "noapic" ... system freezes without "noapic"
 
Hi,

I filed a bug with redhat / fedora7 or my Compaq Presario V6017AU, which has an nVidia MCP51 chipset:

https://bugzilla.redhat.com/bugzilla....cgi?id=244563

Maybe I should check here as well if anyone knows the answer. Basically:


1) If I don't specify any boot parameters, I get system lockup.

2) If I specify "noapic", I don't have USB working. Particularly, any usb device attached after startup will not be recognised, even if it was the same device that you just disconnected and tried to attach again under the same "boot session" [ for lack of a better phrase / word ]. USB 2.0 high speed devices that are attached even before startup / power on are also __not__ recognised.

3) If I specify "pci=noacpi" or "acpi=noirq", USB works including usb 2.0 high speed ... but any sound played is stopped every half a second, unless I move my usb mouse which allows the sound to play continuously. If I stop moving the mouse, the sound being played is stopped again. Also, with this kernel parameter, nVidia's proprietary driver does not work.


So basically, I am stuck with the following choices:

1) "noapic" .. USB 2.0 devices are not recognised
2) "pci=noacpi" .. bad sound and no 3D / OpenGL

Any ideas ?

jmsjr 06-24-07 10:27 PM

Re: mcp51 chipset: usb not working with "noapic" ... system freezes without "noapic"
 
Furthermore ... Is HPET ( high-precision event timer ) also part of this chipset, or is it external to the chipset and part of the motherboard of my notebook ? At the moment, the hidden HPET ( no option via BIOS ) is not enabled.

jmsjr 07-03-07 02:06 AM

Re: mcp51 chipset: usb not working with "noapic" ... system freezes without "noapic"
 
Note that I seem to have found the correct combination of kernel parameters to get things stable for the Compaq Presario V6017AU that have this nVidia mcp51 chipset. It is simply "pci=msi,mmconf". No need for "noapic".

The bugzilla entry that I mentioned in the OP have also been updated.

marcus.kall 07-24-07 10:52 AM

Re: mcp51 chipset: usb not working with "noapic" ... system freezes without "noapic"
 
Hi, I have the same problem with my Hp Pavilion HP Pavilion dv9398eu with mcp51 chipset. But, I can't make it work with "pci=msi,mmconf".


All times are GMT -5. The time now is 05:42 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.