nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nVidia don't start after upgrade in Linux (http://www.nvnews.net/vbulletin/showthread.php?t=93790)

gastverh 06-25-07 03:24 AM

nVidia don't start after upgrade in Linux
 
Hello,
nVidia doesn't start after upgrade in Linux.

I'm working with linux FC6.
Since a long time I had installed with yum kmod-nvidia and associated with it xorg-x11-drv-nvidia.
Most of all when I receive a kernel-update, then there is also a nvidia-driver-update.

On this moment I have:
Code:

[root@pandora1 gastonv]# yum list installed | grep kernel
kernel.i686                              2.6.20-1.2952.fc6      installed

And my /etc/X11/xorg.conf shows:
Code:

Section "Device"

#      Option      "TVOutFormat" "SVIDEO"
        Identifier  "Videocard0"
        Driver      "nvidia"
        VendorName  "Videocard vendor"
        BoardName  "NVIDIA GeForce FX (generic)"
        Option      "NvAGP" "1"
        Option      "RenderAccel" "1"

This morning I received an upgrade for:
Code:

kmod-nvidia            i686      100.14.11-1.2.6.20_1.2952.fc6  livna            2.4 M
 xorg-x11-drv-nvidia    i386      100.14.11-1.lvn6.1  livna            4.9 M

Because of the kernel version is ok, I did make the upgrade and a reboot.
But then the X-Windows didn't start and the folowing error message appears:
Code:

Could not open the device file /dev/nvidiactl (no such file or directory)
Please, what can be the reason of this error?

Fortunately I can start Linux with a few changes:
1. in /etc/X11/xorg.conf I have to change the Driver to nv.
2. yum remove kmod-nvidia and xorg-x11-drv-nvidia.

But, for some applications, I like to have the nvidia drivers like before.
A possible solution is to wait for a new kernel update together with a new install of the corresponding nvidia-drivers. By installing them, the /etc/X11/xorg.conf will be automatically set to the Driver nvidia.
Booting correctly gives then the nVidia-Logo before the Fedora login screen.

Please, once again, what can be the reason of the above error?
Many thanks in advance,
Greetings
Gaston Verhulst.

gastverh 06-25-07 04:18 AM

nVidia doesn't start after upgrade in Linux
 
Hello,

I'm working with linux FC6.
Since a long time I had installed with yum kmod-nvidia and associated with it xorg-x11-drv-nvidia.
Most of all when I receive a kernel-update, then there is also a nvidia-driver-update.

On this moment I have:
Code:

[root@pandora1 gastonv]# yum list installed | grep kernel
kernel.i686                              2.6.20-1.2952.fc6      installed

And my /etc/X11/xorg.conf shows:
Code:

Section "Device"

#      Option      "TVOutFormat" "SVIDEO"
        Identifier  "Videocard0"
        Driver      "nvidia"
        VendorName  "Videocard vendor"
        BoardName  "NVIDIA GeForce FX (generic)"
        Option      "NvAGP" "1"
        Option      "RenderAccel" "1"

This morning I received an upgrade for:
Code:

kmod-nvidia            i686      100.14.11-1.2.6.20_1.2952.fc6  livna            2.4 M
 xorg-x11-drv-nvidia    i386      100.14.11-1.lvn6.1  livna            4.9 M

Because of the kernel version is ok, I did make the upgrade and a reboot.
But then the X-Windows didn't start and the folowing error message appears:
Code:

Could not open the device file /dev/nvidiactl (no such file or directory)
Please, what can be the reason of this error?

Fortunately I can start Linux with a few changes:
1. in /etc/X11/xorg.conf I have to change the Driver to nv.
2. yum remove kmod-nvidia and xorg-x11-drv-nvidia.

But, for some applications, I like to have the nvidia drivers like before.
A possible solution is to wait for a new kernel update together with a new install of the corresponding nvidia-drivers. By installing them, the /etc/X11/xorg.conf will be automatically set to the Driver nvidia.
Booting correctly gives then the nVidia-Logo before the Fedora login screen.

Please, once again, what can be the reason of the above error?
Many thanks in advance,
Greetings
Gaston Verhulst.

kwizart 06-25-07 07:30 AM

Re: nVidia don't start after upgrade in Linux
 
This is a known problem switching to the new udev scheme
The fix is already avaible throught yum update with this one:
[root@Kwizatz X11]# rpm -q xorg-x11-drv-nvidia
xorg-x11-drv-nvidia-100.14.11-1.lvn6.2

Sorry for this broken update...

gastverh 06-25-07 08:53 AM

Re: nVidia doesn't start after upgrade in Linux
 
Hello,
I have to thank you for your fast reply.
So, I have installed again:
Code:

[root@pandora1 gastonv]# yum --enablerepo=livna install kmod-nvidia
That installs:
Code:

[root@pandora1 gastonv]# rpm -qa | grep nvidia
kmod-nvidia-100.14.11-1.2.6.20_1.2952.fc6
xorg-x11-drv-nvidia-100.14.11-1.lvn6.2

And after rebooting nVidea is starting faultless.
Greetings and again many thanks for helping,
Gaston Verhulst.


All times are GMT -5. The time now is 09:00 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.