nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   [Suggestion] NVreg_ReqAGPRate "Enabled" in os-registry.c (http://www.nvnews.net/vbulletin/showthread.php?t=93821)

Cimi 06-25-07 06:57 PM

[Suggestion] NVreg_ReqAGPRate "Enabled" in os-registry.c
 
Could I suggest to enable NVreg_RegAGPRate into os-registry.c by default?
In that way I can set the AGP rate by adding the correct value under modprobe.conf.
Now it is disabled so the optional parameter is ignored at the modprobing and I have always agp 8x.

In my case I'm obliged to patch every version of the drivers, as there's a bug in the driver (http://www.nvnews.net/vbulletin/show...&postcount=329) that causes Xid crashes with AGP 8x (it's not a videocard problem as the same card runs well on Windows and it is not a Motherborad problem as on the same pc an ATI card worked in the past (before i got switched to Nvidia) )

Changing that value will help me and generally everyone will have the opportunity to adjust its AGP rate
Quote:

nv_parm_t nv_parms[] = {
{ "NVreg", "VideoMemoryTypeOverride", &NVreg_VideoMemoryTypeOverride, 0 },
{ "NVreg", "EnableVia4x", &NVreg_EnableVia4x, 1 },
{ "NVreg", "EnableALiAGP", &NVreg_EnableALiAGP, 1 },
{ "NVreg", "NvAGP", &NVreg_NvAGP, 1 },
{ "NVreg", "ReqAGPRate", &NVreg_ReqAGPRate, 1 },
{ "NVreg", "EnableAGPSBA", &NVreg_EnableAGPSBA, 1 },
{ "NVreg", "EnableAGPFW", &NVreg_EnableAGPFW, 1 },
{ "NVreg", "SoftEDIDs", &NVreg_SoftEDIDs, 1 },
{ "NVreg", "Mobile", &NVreg_Mobile, 1 },
{ "NVreg", "ResmanDebugLevel", &NVreg_ResmanDebugLevel, 1 },
{ "NVreg", "FlatPanelMode", &NVreg_FlatPanelMode, 1 },
{ "NVreg", "DevicesConnected", &NVreg_DevicesConnected, 1 },
{ "NVreg", "RmLogonRC", &NVreg_RmLogonRC, 1 },
{ "NVreg", "VbiosFromROM", &NVreg_VbiosFromROM, 1 },
{ "NVreg", "ModifyDeviceFiles", &NVreg_ModifyDeviceFiles, 1 },
{ "NVreg", "DeviceFileUID", &NVreg_DeviceFileUID, 1 },
{ "NVreg", "DeviceFileGID", &NVreg_DeviceFileGID, 1 },
{ "NVreg", "DeviceFileMode", &NVreg_DeviceFileMode, 1 },
{ "NVreg", "RemapLimit", &NVreg_RemapLimit, 1 },
{ "NVreg", "UseCPA", &NVreg_UseCPA, 1 },
{ "NVreg", "DetectPrimaryVga", &NVreg_DetectPrimaryVga, 1 },
{ "NVreg", "SaveVBios", &NVreg_SaveVBios, 1 },
{ "NVreg", "EnableBrightnessControl", &NVreg_EnableBrightnessControl, 1 },
{ "NVreg", "PanelPWMFrequency", &NVreg_PanelPWMFrequency, 1 },
{ "NVreg", "PanelBrightnessLimits", &NVreg_PanelBrightnessLimits, 1 },
{ "NVreg", "UseVBios", &NVreg_UseVBios, 1 },
{ "NVreg", "RMEdgeIntrCheck", &NVreg_RMEdgeIntrCheck, 1 },
{ NULL, NULL, NULL, 0 }
};

Cimi 07-01-07 10:48 AM

Re: [Suggestion] NVreg_ReqAGPRate "Enabled" in os-registry.c
 
up :)
:jumping:


All times are GMT -5. The time now is 10:24 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.