nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   7400 GO blank screen! (http://www.nvnews.net/vbulletin/showthread.php?t=94370)

ian_man 07-05-07 05:42 PM

7400 GO blank screen!
 
3 Attachment(s)
Hello, I've been trying for the past few days to get the Nvidia linux drivers to work with the 7400 GO on my dv8000 notebook. I've tried installing the official Nvidia drivers manuallys per the instructions on this forum's sticky, I've tried using the restricted driver manager in Ubuntu Feisty, I've also tried using the livna drivers on Fedora 7, everything results in X starting with a black screen. I am unable to start a virtual console or otherwise recover, and must reboot. I have even tried using xorg.conf files which work for other people with the 7400 GO, but with not luck. The frustrating part is there are no errors in the Xorg.0.log. So here I am hoping one of you can make sense of all this. I reinstalled Ubuntu on my system, installed the drivers from the Nvidia website, and started X with the logverbose 6 flag. I have also generated an nvidia-bug-report.log. Along with these logs, you will find the xorg.conf file attached. The only thing I can think of is that video is being sent to the external monitor port, instead of the built in LCD. I will try to find a monitor to test this, in the meantime I hope you guys will have a chance to look over the attached files and give me some ideas.

Thanks in advance,
~Ian

Edit: I renamed the xorg.conf file to xorg.conf.txt because it would not let me upload it

netllama 07-05-07 05:48 PM

Re: 7400 GO blank screen!
 
1.0-7184 is no longer supported, and has no support for a GeForce Go 7400. Please retest with 100.14.11.

thanks,
Lonni

ian_man 07-05-07 05:56 PM

Re: 7400 GO blank screen!
 
Hmm, this is confusing because I installed the drivers using NVIDIA-Linux-x86-100.14.11-pkg1.run. Am I missing something here?

Thanks,
~Ian

netllama 07-05-07 05:59 PM

Re: 7400 GO blank screen!
 
You're probably hitting an Ubuntu bug where it auto-installs its own NVIDIA driver package each time your (re)boot. This is covered in the forum sticky posts.

ian_man 07-05-07 06:09 PM

Re: 7400 GO blank screen!
 
Are you referring to http://www.nvnews.net/vbulletin/showthread.php?t=72490? I did apt-get install make gcc pkg-config xserver-xorg-dev libc-dev and apt-get remove nvidia-glx --purge then added DISABLED_MODULES="nv nvidia_new" to /etc/default/linux-restricted-modules, then did rm -f /lib/linux-restricted-modules/.nvidia_new_installed. I'm sorry if I have have overlooked something. Thanks for your patience >.<.

netllama 07-05-07 06:14 PM

Re: 7400 GO blank screen!
 
Yes, that is what I was referring to. Does reinstalling 100.14.11 help?

ian_man 07-05-07 06:15 PM

Re: 7400 GO blank screen!
 
I just checked the restricted drivers manager and it is still listed. Does this mean disabling the nvidia module did not work? I can try removing the restricted drivers manager altogether, I was simply reluctant to do so because I was worried it would disable my wireless card which is listed as a restricted driver.

Edit: I will try this, and then reinstall and get back to you with the results.

ian_man 07-05-07 06:44 PM

Re: 7400 GO blank screen!
 
3 Attachment(s)
OK, I installed it again with the restricted-modules-common package uninstalled, with some different results. I did nvidia-installer --uninstall, then reinstalled the drivers. This time after starting X, the X server crashed with several errors, hopefully something we can work with. At least its not a blank screen with no errors! Attached are the new logs and configuration file.

On a side note, I forgot to mention that whenever I run the driver install program, it gives me a warning about running it in runlevel 1, when I booted in runlevel 3. I don't know if this is a problem.
Also, something that is odd, is that when I startx as a user, it says I don't have the required priveledges, but when I startx as a superuser it warns me as running X as a priveledged user. I'm a bit confused about this, but I don't think its a problem, as I've just been starting X as a super user for the purposes of these tests.
Edit: yet another problem is that uninstalling the restricted modules package did indeed disable my wireless card. Now that I have installed the correct version of the drivers, would it still be a problem to reinstall this package?

netllama 07-05-07 06:51 PM

Re: 7400 GO blank screen!
 
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!

What is the output from running "modprobe nvidia" as root (or via sudo)?

ian_man 07-05-07 06:56 PM

Re: 7400 GO blank screen!
 
sh: /sbin/lrm-video: not found
FATAL: Error running install command for nvidia

netllama 07-05-07 06:59 PM

Re: 7400 GO blank screen!
 
That's more of the same Ubuntu bug. I'd suggest searching this forum for lrm-video to find the workarounds, and reporting this back to Ubuntu.

ian_man 07-05-07 06:59 PM

Re: 7400 GO blank screen!
 
alright thanks, I'll give that a shot


All times are GMT -5. The time now is 07:28 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.