nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   A question about suspend2disk (swsuspend) (http://www.nvnews.net/vbulletin/showthread.php?t=94444)

meskalamdug 07-06-07 06:21 PM

A question about suspend2disk (swsuspend)
 
Hi.
I'm not talking about suspend2,but swsuspend(included in kernel)
this is my situation.
Suspend to disk WITHOUT nvidia driver=ok,works fine
Supend to dissk WITH nvidia driver=tell me..not enough space!
I have 500mb of swap,is not enough?

Suspend2(not included in kernel,must be patched)
with nvidia driver works fine.
I'm on Slackware 12,nvidia 9755,kernel 2.6.21.5

kraju 07-06-07 07:26 PM

Re: A question about suspend2disk (swsuspend)
 
swsuspend in kernel is generally broken (considering suspending to disk). It's not nvidia's fault. Use suspend2, what's the problem?

meskalamdug 07-07-07 03:24 PM

Re: A question about suspend2disk (swsuspend)
 
Quote:

Originally Posted by kraju
swsuspend in kernel is generally broken (considering suspending to disk). It's not nvidia's fault. Use suspend2, what's the problem?

No problem..i prefer suspend1 because is
in the kernel..i will wait for suspend2 integration
;)

jmsjr 07-08-07 05:46 AM

Re: A question about suspend2disk (swsuspend)
 
Fedora 7
Compaq Presario V6107AU
AMD Turion64 x2 ( dual-core )
nVidia GForce 6150 Go with the NVIDIA-Linux-x86_64-100.14.11 driver
nVidia MCP51 controller

$ uname -rmiv
2.6.21-1.3228.fc7 #1 SMP Tue Jun 12 14:56:37 EDT 2007 x86_64 x86_64


I just tried suspend to disk using kde's kpowersave from the system tray and the selecting "Suspend to Disk". It suspends successfully, although my notebook still has the power / LED lights on.

So I then press the power button for a few seconds to completely turn off the notebook, and then press again to turn on, it successfully loads from the image in swap, and restores my session but in screensaver mode ( I am using an opengl screensaver ). I then typein my password to unlock the screensaver, and everything is restored... except that my mouse does not work.

If I then hit Ctrl+Alt+Backspace ( because I could not end my current x.org session ) using my mouse, x.org then fails to restart. dmesg shows the following:

NVRM: RmInitAdapter failed! (0x31:0xffffffff:949)
NVRM: rm_init_adapter(0) failed
NVRM: RmInitAdapter failed! (0x31:0xffffffff:949)
NVRM: rm_init_adapter(0) failed
NVRM: RmInitAdapter failed! (0x31:0xffffffff:949)
NVRM: rm_init_adapter(0) failed

Any ideas ?


All times are GMT -5. The time now is 11:08 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.