nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   DVI Help - still pleading 4 drivers revs later (http://www.nvnews.net/vbulletin/showthread.php?t=9447)

decay 04-01-03 07:41 PM

DVI Help - still pleading 4 drivers revs later
 
1 Attachment(s)
My DVI problems appear to be improving a bit, but still not working. At least my machine does not crash anymore.

Hardware:

Dual PIII-933
Xtasy 6964
Philips 180P

Attached is my log file.

If I boot with just the DVI connector hooked up, the screen goes black, but it no longers locks the system. If I exit X (Ctrl-Alt-BKspace), I have full console control back. I can then plug in the VGA connector and X will use it when I restart (that is an improvement. It used to need a reboot with the VGA connector unhooked and then hooked up).

The lines I find interesting are:

II) NVIDIA(0): Connected display device(s):
(WW) NVIDIA(0): No connected display devices detected; assuming 1 CRT
(--) NVIDIA(0): Detected TV Encoder: Brooktree 868
(II) NVIDIA(0): Enabled display device(s): CRT-0
(II) NVIDIA(0): Mapping display device 0 (CRT-0) to CRTC 0


It thinks I have a CRT hooked up, and setting the Connected string to DFP will hard lock my system (that has not changed).

decay 04-03-03 05:07 PM

As an extra option I have tried adding the ignore option for CRT and that gets X to recognize the flat panel in the log file, but it can display anything.

Andy, can you throw me a line here?

Thanks.

Andy Mecham 04-03-03 05:20 PM

The fact that ignoring CRT causes X to detect your flatpanel is interesting. Can you attach a verbose X log showing that?

I'm tracking down hardware to match yours again, but I still need your vbios revision in order to make sure we're comparing apples to apples.

Thanks!

--andy

decay 04-04-03 06:20 PM

1 Attachment(s)
Andy,

Attached is the log file that has the IgnoreDisplayDevices "CRT" Option enabled.

It times out with a no screens found, but in the log file you can clearly see it notices the DFP.

Making "ConnectedMonitor" DFP will not work either.

Thanks.

Andy Mecham 04-09-03 07:32 PM

What vbios do you have? Have you attempted to update it from your vendor's webpage?

--andy

Andy Mecham 04-09-03 07:34 PM

Code:

(II) NVIDIA(0): Connected display device(s):
(WW) NVIDIA(0): No connected display devices detected; assuming 1 CRT
(--) NVIDIA(0): Detected TV Encoder: Brooktree 868
(II) NVIDIA(0): Enabled display device(s): CRT-0
(EE) NVIDIA(0): Failed to read mapping of display devices to CRTCs
(II) UnloadModule: "nvidia"

Your panel isn't actually being detected - the CRTC failure happens because it thinks your DFP is a CRT. I'd be very curious to find out what happens with a vbios update.

--andy

decay 04-09-03 10:36 PM

Quote:

Originally posted by Andy Mecham
Code:

(II) NVIDIA(0): Connected display device(s):
(WW) NVIDIA(0): No connected display devices detected; assuming 1 CRT
(--) NVIDIA(0): Detected TV Encoder: Brooktree 868
(II) NVIDIA(0): Enabled display device(s): CRT-0
(EE) NVIDIA(0): Failed to read mapping of display devices to CRTCs
(II) UnloadModule: "nvidia"

Your panel isn't actually being detected - the CRTC failure happens because it thinks your DFP is a CRT. I'd be very curious to find out what happens with a vbios update.

--andy

Thanks Andy,

There is no BIOS info in /proc. It is a Visiontek and it does not report BIOS on bootup, and there have never been any BIOS updates before they switched over to ATI

Any recommendations?

I will get you any info you need. Thanks.

Andy Mecham 04-15-03 06:22 PM

(sorry, I haven't forgotten about this)

I don't have any recommendations as of yet. I'm still not able to reproduce, but I have a few more pairs of eyes on this now.

--andy

decay 04-15-03 08:33 PM

Keeping in mind that my machine is SMP also. That might have gotten lost in the shuffle of that first post of the thread.

Thanks again.

decay 04-26-03 10:39 AM

DVI Help - still pleading *5* driver revs later
 
1 Attachment(s)
Andy,

Still no go on DVI.

Setting "ConnectedMonitor" will hard lock my system.

Attached is my XFree log file.

It sees the DFP as the bootup device but insists on forcing a CRT.

Thanks.

decay 04-27-03 12:32 PM

I tried the IgnoreDisplayDevices to no avail either.

Perhaps there is something I can force with the Philips 180P.

Others seem to have their DVI working.


All times are GMT -5. The time now is 06:44 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.