nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Problems with configuration of Quadro FX 4600 (http://www.nvnews.net/vbulletin/showthread.php?t=94563)

Schaf1010 07-09-07 09:48 AM

Problems with configuration of Quadro FX 4600
 
4 Attachment(s)
Hey!

I have problems with the installation and configuration of my Nvidia Quadro FX 4600. I downloaded the latest driver from the nvidia.com homepage and followed the instructions in the readme file and as far as I can tell the installation finished without errors. But when I run the "sax2 -r -m 0=nvidia" command the X-server hangs up and I have to restart my computer.
I'm quite new in the linux community and I don't know what to do to fix my problem. My OS is openSUSE 10.2. I attached some files which I thought to be useful. If anything is missing tell me. I can't read your answers the next 3 days but I hope to find some advice when I return.

Thanks!

netllama 07-09-07 09:52 AM

Re: Problems with configuration of Quadro FX 4600
 
According to your bug report, you're using the VESA X driver, and not the nvidia X driver. I'd guess that there's a problem with the version of the vesa X driver that ships in SUSE-10.2. Instead of running sax, just run "nvidia-xconfig" as root, and you should be able to start X.

Schaf1010 07-13-07 02:50 AM

Re: Problems with configuration of Quadro FX 4600
 
I tried this several times up to now. After that my X hung up everytime. Not even Ctrl+Alt+Del worked then anymore. So I changed the driver manually to "VESA" to be able to start X.

netllama 07-13-07 08:10 AM

Re: Problems with configuration of Quadro FX 4600
 
I can't comment on the problem with the nvidia X driver until you provide a bug report against that configuration.

Schaf1010 07-16-07 06:36 AM

Re: Problems with configuration of Quadro FX 4600
 
I’m totally confused by now what I tried so far and what I didn’t try. Because of that I will start again and describe every step.
I just ran the nvidia-installer command once again. The xorg.conf file was written and the driver was correct (nvidia in the driver line). But nothing in the display changed so I logged out and wanted to log in again. But after logging out I got nothing but a black screen. I ran the nvidia-bug-report.sh then from a remote login then. When I rebooted the system (from the remote login) everything was ok until the x server should be started normally. Linux tried two or three times to generate the graphical user login screen but failed. I now have a message in “text mode” on my screen that says:
“Failed to start the x server (your graphical interface). It is likely that it is not set up correctly. Would you like to view the x server output to diagnose the problem?”
I choose yes. I get some error diagnostics. The EE lines are:
“FATAL: Module nvidia not found.
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0): ***Aborting***
(EE) Screen(s) found, but none have a usable configuration.
Fatal server error:
no screens found”
How can I load the kernel module?
I let the nvidia-bug-report.sh run another time because I noticed that the one I generated when the screen was black had the vesa driver selected. I add both bug reports. I changed the names to distinguish them. The first one is named ***.log.blackscreen and the second one ***.log.withoutx. How can it be that the first bug report still has the vesa driver although I already had changed the driver?

Schaf1010 07-16-07 09:13 AM

Re: Problems with configuration of Quadro FX 4600
 
2 Attachment(s)
Sorry! I forgot the attachments.

netllama 07-16-07 10:18 AM

Re: Problems with configuration of Quadro FX 4600
 
This error is fairly explicit on where the problem lies:
FATAL: Module nvidia not found.

I don't see the NVIDIA driver installer log in your bug report, so its not clear how you installed the driver, but its seemingly not installed correctly (if at all). I'd suggest (re)installing the driver.

Schaf1010 07-17-07 04:29 AM

Re: Problems with configuration of Quadro FX 4600
 
3 Attachment(s)
I reinstalled the driver this morning, but the problem still persists. I followed the Suse Nvidia Installer HOWTO from the Nvidia driver homepage (http://www.nvidia.com/object/linux_d...00.14.11.html). I changed into runlevel 3 and ran rmmod nvidia. I got a message then that this module doesn't exist in /proc/modules (thats the mistake I guess). Then I typed run NVIDIA*.run -q und followed the instructions of the installer. As before the Installation concluded without any visible error. After the installation I ran the nvidia-xconfig command and again after reboot the graphical interface didn't start and hang up resp. I checked the log files for errors but they don't mention any as far as I can tell.

netllama 07-17-07 09:49 AM

Re: Problems with configuration of Quadro FX 4600
 
In the latest bug report, X appears to be hanging, which is a completely different problem than what you reported initially.

It appears that you're using a Tyan S3992 motherboard. According to Tyan's website, this motherboard does not support PCI-E graphics cards:
http://tyan.com/product_board_detail.aspx?pid=235

This is not an NVIDIA bug.

Schaf1010 07-18-07 02:37 AM

Re: Problems with configuration of Quadro FX 4600
 
Oh. I would have never thought of that.

But thank you very much for helping me!


All times are GMT -5. The time now is 07:37 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.