nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   RAID Failure - Please Help (mdadm) (http://www.nvnews.net/vbulletin/showthread.php?t=94901)

carlos 07-14-07 03:37 PM

RAID Failure - Please Help (mdadm)
 
Guys - I have a problem on my home PC. I am posting from it now however something is wrong with one of my two mirrors.

I have 2 Western Digital S-ATA drives on my PC. Exactly identical models.

I partitioned them so that

/dev/sda3 & /dev/sdb3 = /dev/md0

/dev/md0 is mounted on /

/dev/sda4 & /dev/sdb4 = /dev/md1

/dev/md1 is mounted on /home

However the problem is this...

Code:

tunafish:/home/cwilliams# cat /proc/mdstat
Personalities : [raid1]
md1 : active raid1 sda4[0]
      135275264 blocks [2/1] [U_]

md0 : active raid1 sdb4[2](S) sdb3[1] sda3[0]
      19534976 blocks [2/2] [UU]

unused devices: <none>

It appears I am running on 1/2 a mirror on /home and although I can still use my system perfectly, I would like to repair this problem. I know the disk is fully functional and works perfectly - I think I somehow just messed or mixed things up and I don't have any RAID experience to resolve this so I am asking for any help on resolving this.

carlos 07-15-07 09:15 AM

Re: RAID Failure - Please Help (mdadm)
 
Yeah - this was not a Ubuntu / Beryl question so I assumed not much help here.

Self Resolved

Code:

tunafish:/home/cwilliams# cat /proc/mdstat
Personalities : [raid1]
md0 : active raid1 sda3[0] sdb3[1]
      19534976 blocks [2/2] [UU]

md1 : active raid1 sdb4[2] sda4[0]
      135275264 blocks [2/1] [U_]
      [==============>......]  recovery = 70.5% (95456512/135275264) finish=17.7min speed=37391K/sec

unused devices: <none>
tunafish:/home/cwilliams# cat /proc/mdstat
Personalities : [raid1]
md0 : active raid1 sda3[0] sdb3[1]
      19534976 blocks [2/2] [UU]

md1 : active raid1 sdb4[1] sda4[0]
      135275264 blocks [2/2] [UU]


Bman212121 07-15-07 03:10 PM

Re: RAID Failure - Please Help (mdadm)
 
Could you post how you fixed it as it might help someone else out in the future?

evilghost 07-15-07 09:16 PM

Re: RAID Failure - Please Help (mdadm)
 
Just found this thread, I was going to chime in about the arrays not being uniform. You can make them uniform by doing a:

raidhotadd /dev/md1 /dev/sda4

carlos 07-16-07 07:31 AM

Re: RAID Failure - Please Help (mdadm)
 
Code:

tunafish:/home/cwilliams# mdadm --remove /dev/md0 /dev/sdb4
mdadm: hot removed /dev/sdb4
tunafish:/home/cwilliams# cat /proc/mdstat
Personalities : [raid1]
md0 : active raid1 sda3[0] sdb3[1]
      19534976 blocks [2/2] [UU]

md1 : active raid1 sda4[0]
      135275264 blocks [2/1] [U_]

unused devices: <none>
tunafish:/home/cwilliams# mdadm --re-add /dev/md1 /dev/sdb4
mdadm: added /dev/sdb4
tunafish:/home/cwilliams# cat /proc/mdstat
Personalities : [raid1]
md0 : active raid1 sda3[0] sdb3[1]
      19534976 blocks [2/2] [UU]

md1 : active raid1 sdb4[2] sda4[0]
      135275264 blocks [2/1] [U_]
      [>....................]  recovery =  0.1% (259200/135275264) finish=34.7min speed=64800K/sec



All times are GMT -5. The time now is 09:32 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.