nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   m2n-mx gigabit problem (http://www.nvnews.net/vbulletin/showthread.php?t=94997)

philippn 07-16-07 12:57 PM

m2n-mx gigabit problem

my setup is a
asus m2n-mx motherboard (bios rev. 0701 (not 100% sure); nforce 430)
2 sata seagate hdds
connected to a netgear gbit-switch (and previously d-link gbit-switch).

at first i tried ubuntu feisty (7.04, amd64, also one try with gentoo 2007.0 minimal x86) without installing windows. then the onboard gbit nic can't establish a connection to the gbit-switch. it also doesn't work if i call 'ethtool -s speed 100' for 100mbit or 10mbit. i also tried two different kernel-packages in ubuntu: 2.6.22 (form gutsy) and 2.6.20 (default).
result: no connection to a gbit-switch from linux (forcedeth driver, version 0.60 i think).
but if i connect it physically to a 100mbit router, then everything works fine (but without gbit of course).

yesterday i tried it with windows. there everything seems to work fine regarding gbit (tested with netio).
then i powered off (stupidly without disconnecting the power) and tried linux again and it worked!!!

later i took the computer and brought it to my friend with a smile on my face that everything works now. but as we connect everything it does not work again under linux.

now im very confused and don't know how to go on. it's also difficult to try many things, since he needs the computer to access his files on the hdd's (he has only a laptop).

thanks for any help,

schafdog 07-22-07 09:18 AM

Re: m2n-mx gigabit problem
I seem to have the same issue with gigabit.

Running Fedora 7 (kernel 2.6.21-1.3228.fc7 #1 SMP Tue Jun 12 14:56:37 EDT 2007 x86_64 x86_64 x86_64 GNU/Linux) on a Asus M2N-MX.

The switch is 3Com 5 port gigabit.

I can get the card to work in 100 Mbit/s, either forcing it into 100 Mbit/s with ethtool or the card "settling" on 100 Mbit after many attemps on getting into 1000 Mbit/s. I cannot force the card into 1000 Mbit/s.

I see the link go on and then off after some few seconds.

the LAN driver is forcedeth version 0.60.

The cabling has been tested with another gigabit card using the same switch. And even tried a cat. 6 cabling just to be sure.

I think the BIOS is old. could that be a solution?

Any one have a fix?


netllama 07-22-07 11:05 AM

Re: m2n-mx gigabit problem
Yes, you should ensure that you're using the latest motherboard BIOS.

Additionally, check /var/log/messages for errors when the failure occurs.

philippn 07-22-07 05:50 PM

Re: m2n-mx gigabit problem
now i updated the bios to 0804 and tried it again with windows xp sp2:
it loses the connection several times but after several attempts a usable connection is established.
with linux i can't get any connection, even "ethtool -s eth0 speed 100 autoneg off" does not work.

"ethtool -i eth0" says
driver: forcedeth
version: 0.60
bus-info: 0000:00:07.0

in /var/log/messages "eth0: link up." and "eth0: link down." is continuously listed.
no further errors for eth0 or forcedeth.

the lights of the router are even blinking if the computer is shutdown but powerconnected.

schafdog 07-23-07 05:07 AM

Re: m2n-mx gigabit problem
I am seeing the same here. link going up and down in the syslog, but nothing else is logged. Even when runing a kernel with debug The link light on the switch going on/off as well.

Can I run the forcedeth with some debug options to get more info?

I havent upgraded to last BIOS, but doing it later today.


schafdog 07-23-07 07:52 AM

Re: m2n-mx gigabit problem
Upgrading BIOS version 0804 to did not help...

Tried FreeBSD (pfSense Live CD), and the hardware (link lights on switch) looks the same, switching on and off.

Could it be a defect hardware, not being able to run in 1000 Mbit/s ?


philippn 07-23-07 09:41 AM

Re: m2n-mx gigabit problem
asus replied: if a pci lan card works then the onboard controller is damaged.

i also think that it is a hardware problem, because of the problems when the pc is shut down.

bobism 08-12-07 09:19 AM

Re: m2n-mx gigabit problem
I'll add a little here, I have the same problem. FC6 latest kernel, latest bios, multiple m2n-mx boards. Once the link goes "broken", I can get it to come back up if I do a;

rmmod forcedeth;modprobe forcedeth

so have used that as a workaround with a ping test in a cron job. ifdown/ifup has no affect, ifconfig acts like the eth0 is up.

Also, I have win2003 on an identical hardware setup with no errors/problems on the link. So it looks to me like a driver issue. I've been trying to compile 0.62 but no luck, I get an error and warnings - one warning of great concern since it seems to be dangerous to me. I've posted a seperate thread for the compile problem, might be useful but even if I get it compiled it might not resolve the problem.


All times are GMT -5. The time now is 10:49 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.