nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   QuadroFX 1500 (Compaq nw9440) Can't change resolution (http://www.nvnews.net/vbulletin/showthread.php?t=95136)

drink 07-18-07 08:17 PM

QuadroFX 1500 (Compaq nw9440) Can't change resolution
 
1 Attachment(s)
I have a compaq nw9440, just updated BIOS and still have a problem that I've ALWAYS had with this system. I can use only one resolution, the native panel res of 1680x1050.

The free 'nv' driver allows me to use other resolutions. But when I try to use xvidtune -show to save that res as a modeline and use it in my xorg.conf with the 'nvidia' driver I have no luck. No modes validate. I'm not even sure it's really trying to use my modes, but I must have the syntax right because X will start.

Ubuntu shows 1680x1050@50Hz, nvidia-settings shows 1680x1050@59Hz.

Here's the modelines that I gathered while using the 'nv' driver:
"1680x1050" 147.14 1680 1784 1968 2256 1050 1051 1054 1087
"1024x768" 65.00 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
"800x600" 40.00 800 840 968 1056 600 601 605 628 +hsync +vsync
"640x480" 25.18 640 656 752 800 480 490 492 525 -hsync -vsync
"1400x1050" 122.00 1400 1488 1640 1880 1050 1052 1064 1082 +hsync +vsync
"1280x1024" 108.00 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
"1440x900" 108.84 1440 1472 1880 1912 900 918 927 946 +hsync +vsync
"1280x960" 108.00 1280 1376 1488 1800 960 961 964 1000 +hsync +vsync
"1280x800" 83.46 1280 1344 1480 1680 800 801 804 828
"1280x768" 80.14 1280 1344 1480 1680 768 769 772 795
"1152x768" 65.00 1152 1178 1314 1472 768 771 777 806 +hsync +vsync

bug report log attached.

netllama 07-18-07 08:20 PM

Re: QuadroFX 1500 (Compaq nw9440) Can't change resolution
 
The only mode that you've requested in your bug report is 1680x1050.

drink 07-19-07 12:20 AM

Re: QuadroFX 1500 (Compaq nw9440) Can't change resolution
 
1 Attachment(s)
My apologies, here's a more elaborate config file which exhibits the same problem. I had already done this, I guess I'd switched configs a few times since.

netllama 07-19-07 09:56 AM

Re: QuadroFX 1500 (Compaq nw9440) Can't change resolution
 
I wouldn't expect modelines to work for a DFP under most circumstances unless you obtained them from the EDID in the DFP.

Have you attempted to just request the modes you want (without modelines)? If so, please start X with the following command:
startx -- -logverbose 6

and then generate a new bug report while the problem is present.

drink 07-19-07 10:26 AM

Re: QuadroFX 1500 (Compaq nw9440) Can't change resolution
 
2 Attachment(s)
Interestingly, at least to me, if I 'startx -- -logverbose 6' I cannot actually log in. No client ever manages to connect to the server. Startx works fine. I did the startx with options, killed the server, ran the report, and will attach the file here.

Also, on my first reboot this morning I was told that I had a driver mismatch (worked fine, with current version verified, last night) and I had to reinstall the driver this morning. Now I am getting display corruption on scrolling (sometimes.)

The modelines below were generated while running the free 'nv' driver on this card, and using xvidtune -save. I selected each resolution (they work there) and placed them here. Perhaps nv is properly reading the EDID, and nvidia is not? Or perhaps the nv driver is automatically correcting some values somehow (?) and nvidia is not? I'll enclose the edid dump that nvidia-settings made, perhaps it can shed some light.

netllama 07-19-07 10:34 AM

Re: QuadroFX 1500 (Compaq nw9440) Can't change resolution
 
Per your bug report, the only mode defined in the EDID for your display is 1680x1050. This is why all other modes are failing to validate.

If you really want to run with a non-native mode, you'll need to set UseEDID to false, and attempt to create modelines which will work.

drink 07-19-07 11:22 AM

Re: QuadroFX 1500 (Compaq nw9440) Can't change resolution
 
One thing I noticed while reading the log was that a lot of modes were rejected because their pixel clock was "too high". We look at the file and see

(--) NVIDIA(0): Seiko (DFP-0): 330.0 MHz maximum pixel clock

Then we see some modelines validations like this:

(II) NVIDIA(0): Validating Mode "1280x960":
(II) NVIDIA(0): 1280 x 960 @ 85 Hz
(II) NVIDIA(0): Mode Source: X Server
(II) NVIDIA(0): Pixel Clock : 148.50 MHz
(II) NVIDIA(0): HRes, HSyncStart : 1280, 1344
(II) NVIDIA(0): HSyncEnd, HTotal : 1504, 1728
(II) NVIDIA(0): VRes, VSyncStart : 960, 961
(II) NVIDIA(0): VSyncEnd, VTotal : 964, 1011
(II) NVIDIA(0): H/V Polarity : +/+
(WW) NVIDIA(0): Mode is rejected: PixelClock (148.5 MHz) too high for EDID
(WW) NVIDIA(0): (EDID Max: 119.0 MHz).

Now, I HAVE tried disabling the pixel clock check without results, but maybe I wasn't requesting modes. Is this a worthwhile effort?

Regardless, that is why I tried using the modelines here. I HAVE tried them with Option "UseEDID" "false" but all I ever get is a black screen. However, these resolutions WORKED on THIS SYSTEM with the 'nv' driver. Why should they work with nv and not nvidia?

This adapter worked just fine with no special definitions files (the panel "driver" file uses the DDC) on Windows. And the 'nv' driver can see all the valid resolutions and use them properly. So why can't the nvidia driver do the same? And how am I supposed to find out what those valid resolutions are if the driver can't pull them from the display? This panel is never supplied with a monitor information file which gives that information.

I'll try using the read-edid package and see if I can get the edid while using the nv driver (or while using no driver) and work with that. But I still don't understand why the nv driver can get modes, and the nvidia driver can't.

drink 07-19-07 11:52 AM

Re: QuadroFX 1500 (Compaq nw9440) Can't change resolution
 
1 Attachment(s)
read-edid didn't do any better. It did parse the edid returned from the display by nvidia-settings with its one mode (1680x1050).

Attached is some output from Xorg with the driver set to nv: the modelines it detects, straight from the log (at level 6.)

But I can't use these modes with the nvidia driver...

I also once again tried disabling the EDID pixel clock through modevalidation options, I didn't get any new modes, now the modes just failed for other reasons. I could include that log too if you want.

drink 07-19-07 12:01 PM

Re: QuadroFX 1500 (Compaq nw9440) Can't change resolution
 
1 Attachment(s)
For further information, this is what I have in my 'nv' driver xorg.conf for mode-related information:

Section "Device"
Identifier "nVidia Corporation G71 [Quadro FX 1500M]"
Driver "nv"
BusID "PCI:1:0:0"
Option "UseEDID" "false"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-84
VertRefresh 43-60
EndSection

...
Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation G71 [Quadro FX 1500M]"
Monitor "Generic Monitor"
DefaultDepth 24
...
SubSection "Display"
Depth 24
Modes "1680x1050" "1024x768" "800x600" "640x480"
EndSubSection

(just an example, all bit depths are like that)

Options in this file may or may not make sense, I did a lot of troubleshooting by flipping back and forth between nv and nvidia drivers with an otherwise identical xorg.conf. This file was originally created by dexconf although I find that I can flip back and forth with a file from there or from nvidia-settings (tweaked more than changing the driver, or not.)

I'm just trying to figure out why 'nv' can find valid modes and use them, but 'nvidia' can't, and further why I can't use the modes nv validates with nvidia...

Attached is the full 'nv' driver xorg.conf.

drink 07-19-07 09:32 PM

Re: QuadroFX 1500 (Compaq nw9440) Can't change resolution
 
1 Attachment(s)
I used nvidia-xconfig to build a new config file, which worked. I did some tweaking, but this is what I started with:

sudo nvidia-xconfig --add-argb-glx-visuals --allow-ddcci --allow-glx-with-composite --cool-bits=1 --composite --damage-events --dynamic-twinview --include-implicit-metamodes --load-kernel-module --no-logo --randr-rotation --render-accel --use-edid-freqs --mode=640x480 --mode=800x600 --mode=1024x768

I went in and changed ModeValidation options to avoid checking the max pixel clock, which though it is correctly detected from the EDID, is CHECKED incorrectly by the nvidia driver - or so it appears. I now have a full range of available resolutions. Aspect-correct stretching is working. And so on.

(BTW, JIC anyone is wondering, I have coolbits so that I can underclock the GPU if I like, because I've had overheating problems with this laptop in the past. It's plenty fast at the stock speed, at least for my purposes.)

My xorg.conf is attached (gzipped)


All times are GMT -5. The time now is 08:48 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.