nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Installation reaches 100% when building kernel module and then fails (Ubuntu) (http://www.nvnews.net/vbulletin/showthread.php?t=95228)

flashback 07-20-07 09:37 AM

Installation reaches 100% when building kernel module and then fails (Ubuntu)
3 Attachment(s)

I'm trying to install the NVIDIA-Linux-x86-100.14.11-pkg1 driver on Ubuntu 6.06 LTS (Dapper Drake) in order to successfully use a nVidia GeForce FX 5600 video card.

I've been using GNU/Linux for a few months and trying to install the nvidia drivers (NVIDIA-Linux-x86-1.0-9746-pkg1, NVIDIA-Linux-x86-1.0-9755-pkg1, and the ones from the repositories nvidia-glx and nvidia-kernel-common) led me to some misconfigurations in the xorg.conf file. I had to recover it manually, and it worked (using the X.org nv driver), but I lost the avaiability of resolutions higher than 1024*768 (at 60Hz). Luckily enough, this misconfiguration made me realize that I could run Ubuntu without the X server by manually adding a little error to the xorg.conf file again. Sure it's not the best way but it's the only one I know that worked so far.

The NVIDIA-Linux-x86-100.14.11-pkg1 driver is the driver with whom I've gone further within the installation process. Automatically it doesn't find the kernel source, but if I force the path to where the linux-headers are the installation reaches the "building kernel module" point. The bar reaches 100% and then I get the error: "Unable to build the NVIDIA kernel module".

My linux-headers match with my kernel version (I use linux-headers-2.6.15-28), make and gcc are installed and working, the pkg-config and xserver-xorg-dev packages are installed, the nvidia-glx package has been completely uninstalled, the nvidia-kernel-common and the linux-restricted-modules are uninstalled too, and the and the files /etc/init.d/nvidia-glx and /etc/init.d/nvidia-kernel do not exist.

I've attached the nvidia-installer.log file, a sysinfo log of my system and also my xorg.conf file (configured in order to work with the X.org nv driver, but a bit messed from before), all compressed in three different zip files. What I use now is the X.org nv driver. I'd like to know if there's any possibility of installing the NVIDIA-Linux-x86-100.14.11-pkg1 driver in my system or at least use it with X.org's at a higher resolution and refresh rate (I did before).

Thanks in advance.

PS: What I change in xorg.conf in order to start Ubuntu without running the X server is
BusID "PCI:1:0:0"
BusID "PCI:0:5:0"
The file first messed up when I tried to install nvidia-glx I think.

netllama 07-20-07 10:00 AM

Re: Installation reaches 100% when building kernel module and then fails (Ubuntu)
The failure is here:
/bin/sh: scripts/genksyms/genksyms: No existe el fichero ó directorio

scripts/genksyms/genksyms should ship with your kernel source. You'll need to report this to whomever provided you with your kernel.

All times are GMT -5. The time now is 09:44 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.