nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   ALSA 0.9.2 vs. MDK 9.1 + A7N8X (http://www.nvnews.net/vbulletin/showthread.php?t=9552)

danboid 04-03-03 05:22 AM

ALSA 0.9.2 vs. MDK 9.1 + A7N8X
 
I am running Mandrake 9.1 on a A7N8X Deluxe board. I can get sound playback and recording working under the latest Audacity but not full duplex. I have checked that the full duplex option is enabled under audacity but when I try enabling it under aRTs sound stops completely.

SO I downloaded the latest ALSA (which I'm told DOES support full duplex with the Intel i810 chipset) and successfully compiled it but I can't get the driver to load. I did a make install and then a ran the snddevices script. Mandrake still insists on loading the old sound driver.

I have this line in my /etc/modules.conf

alias sound-slot-0 i810_audio

Is that right?

When I run 'modprobe snd-intel8x0' (is that the right command?) this is what I get:


/lib/modules/2.4.21-0.13mdk/kernel/sound/pci/snd-intel8x0.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
modprobe: insmod /lib/modules/2.4.21-0.13mdk/kernel/sound/pci/snd-intel8x0.o failed
modprobe: insmod snd-intel8x0 failed

This is an extract from my syslog:

Mar 30 20:44:01 localhost kernel: i810: NVIDIA nForce Audio found at IO 0xd800 and 0xd400, MEM 0x0000 and 0x0000, IRQ 5
Mar 30 20:44:02 localhost kernel: i810_audio: Audio Controller supports 6 channels.
Mar 30 20:44:02 localhost kernel: i810_audio: Defaulting to base 2 channel mode.
Mar 30 20:44:02 localhost kernel: i810_audio: Resetting connection 0
Mar 30 20:44:02 localhost kernel: ac97_codec: AC97 Audio codec, id: ALG32 (ALC650)
Mar 30 20:44:02 localhost kernel: i810_audio: AC'97 codec 0, new EID value = 0x05c7
Mar 30 20:44:02 localhost kernel: i810_audio: AC'97 codec 0, DAC map configured, total channels = 6
Mar 30 20:44:02 localhost sound: Loading sound module (i810_audio) succeeded


I've also tried running 'alsaconf' and using the --with-debug=detect configure option but none of them find my card.

Thanks for your help

dan

http://www.transelement.co.uk/

DiscipleDOC 04-04-03 11:23 AM

Dan,
Silly question, but do you have it enabled in the bios?

danboid 04-05-03 01:47 AM

Solved!
 
There were a load of extra lines that I had to add to my /etc/modules.conf file that I didn't know about. I now have ALSA working properly, with full duplex and 6 channel mixer!

All the info is over at:

http://www.alsa-project.org/alsa-doc...odule=intel8x0


All times are GMT -5. The time now is 08:20 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.