nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   7300LE + TwinView = no accelerated OpenGL (http://www.nvnews.net/vbulletin/showthread.php?t=95973)

dripton 08-02-07 09:50 PM

7300LE + TwinView = no accelerated OpenGL
 
I have a GeForce 7300LE card, and a dual-monitor setup with TwinView. I have not been able to get hardware-accelerated OpenGL to work since I added the second monitor.

With 'Load "glx"' in my xorg.conf, and the nvidia OpenGL drivers active, X will not start.

With that line commented out, or with the Mesa software-only OpenGL drivers active, X works fine, and OpenGL works too, just very slowly.

I have read the sticky threads. I have upgraded my BIOS to the latest version, which didn't help.

As directed in the sticky thread, I did "startx --logverbose6" then ran nvidia-bug-report.sh after X crashed. The output is 129 kB, so rather than pasting it here I'll provide a URL:

http://ripton.net/nvidia-bug-report.log

I've tried several nvidia driver versions. I'm currently using 100.14.11, installed via "emerge nvidia-drivers"

Any ideas?

Does anyone have TwinView and OpenGL acceleration working together on a 7300LE?

Thanks.

netllama 08-03-07 12:09 PM

Re: 7300LE + TwinView = no accelerated OpenGL
 
The bug report that you referenced was not generated after starting X with the verbose option. However, the problem is that X is hanging when attempting to load the glx extension. Does this problem persist if you (re)install the official driver package, rather than a 3rd party repackaging?

thanks,
Lonni

dripton 08-03-07 11:00 PM

Re: 7300LE + TwinView = no accelerated OpenGL
 
Problem solved. Thanks.

Running the nvidia install script directly seems to have done something good that Gentoo's ebuild installer did not. (I'm not sure exactly what.)

I ran emerge afterward to fix the package metadata, and this did not break the driver.

So, for posterity, "emerge -C nvidia-drivers; sh ./NVIDIA-Linux-x86-VERSION.run; emerge nvidia-drivers; eselect opengl set nvidia" worked for me.


All times are GMT -5. The time now is 01:09 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.