nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   RedHat 8.0, Binutils, NVIDIA Installer and me.. (http://www.nvnews.net/vbulletin/showthread.php?t=9650)

intercede007 04-04-03 04:21 PM

RedHat 8.0, Binutils, NVIDIA Installer and me..
 
OK so I'm a total Linux dunderhead.

I tried to install the new Nvidia drivers, and the installer told me I needed Binutils. So I downloaded them.

Extracted the files, went into the Binutils-2.12/Binutils directory (as par the instructions in the Readme in the Binutils-2.12 directory) and cracked open the README. To install, it told me to do this

cd binutils-XXX
./configure [options]
make
make install # copies the programs files into /usr/local/bin
# by default.

So I try doing ./configure in the Binutils-2.12 directory. I get this

Configuring for a i686-pc-linux-gnuoldld host.
Created "Makefile" in /binutils-2.12 using "mt-frag"
./configure: line 7: cc: command not found
*** The command 'cc -o conftest -g conftest.c' failed.
*** You must set the environment variable CC to a working compiler.

I have a clever idea and I tried ./configure in Binutils-2.12/Binutils and get this error at the bottom instead

configure: error: no acceptable cc found in $PATH

I'm really getting frustrated here. I'm trying the best I can to read all of the instructions and do what sounds right, but sometimes, it's cryptic to say the least and not that helpful to the novice. Any advice, ideas, or spoon-feeding anybody could deliver would be much appreciated!!!!

Kiamu 04-04-03 04:24 PM

i love to build my own distro...

and use LFS.

maybe this link helps ;)

http://www.linuxfromscratch.org/view.../binutils.html

Kiamu 04-04-03 04:27 PM

btw,

forgot to mention: if you use RH you should probably go to their download-site and fetch a new rpm containing binutils. that would install it in the correct place for you.

intercede007 04-04-03 04:39 PM

Wow...dang.

Something finally worked for me!!!!


Appreciate it man. When I looked on RedHat's website for binutils the first time, it told me that I needed to buy entitelments to get it. I just went back, looked, and voila!

Installed it, installed the drivers, and everything still works!!!


Thanks again. If you're ever in Destin, Florida I'll buy you a round :D

lurxh 04-04-03 09:50 PM

Can you link me to the rpm file? I'm having the same problem except I can't even find an rpm file with binutils in it.

Kiamu 04-05-03 03:38 AM

try rpmseek... and pick the appropriate rpm:

http://rpmseek.com/rpm-pl/binutils.html?hl=en&cx=0::

lurxh 04-05-03 07:51 AM

Ooooo man, you just stopped my 24-hours of hell. Thanx a bunch Cheers :beer:


All times are GMT -5. The time now is 07:19 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.