nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   GeForce Go 7900 GS black flash screen (http://www.nvnews.net/vbulletin/showthread.php?t=96673)

pijalu 08-16-07 10:41 AM

GeForce Go 7900 GS black flash screen
 
1 Attachment(s)
Hi,

Noticed a funny behavior on my inspiron 9400 using compiz-fusion for a pretty long time (at least 2 months): after a few hours, Xorg start to "blink": The screen becomes black for a really short time (1 or 2 frame) then every now and then part of the screen becomes black... Even if I kill compiz and start metacity, the problem persist... I usual had to kill X and everything return to normal...
I found out recently that changing setting using nvidia-settings seems to clear the issue (like changing GPU scaling...) [but it does not prevent the issue]

Here comes a tarball with 2 bug reports : 1 on a Xorg "blinking" (_flash) and the other after running the nvidia-settings that "fixed" the blinking (_nonflash)

Zapek 09-10-07 06:29 AM

Re: GeForce Go 7900 GS black flash screen
 
I have an Inspiron 9400 with a 7900GS here and the exact same problem as you. Using driver 100.14.11.

HeyMish11 09-12-07 12:42 AM

Re: GeForce Go 7900 GS black flash screen
 
Ive seen this problems on about 5 computers at my work (all with Quadro [13][45]00's) some using the 100.14.09/14 drivers and also on the 9755 ones, next time it comes up ill be putting the bug reports up here.

It used to be quite a problem but my coworker said it just went away... and now its back and i will be back to

Zapek 09-13-07 12:36 AM

Re: GeForce Go 7900 GS black flash screen
 
1 Attachment(s)
Here's the output from my system. The bug is happening right now.

netllama 09-13-07 10:02 AM

Re: GeForce Go 7900 GS black flash screen
 
Does this problem persist without the Coolbits & TripleBuffer options?
Have you verified that you're using the latest BIOS?

pijalu 09-13-07 03:46 PM

Re: GeForce Go 7900 GS black flash screen
 
Quote:

Originally Posted by netllama
Does this problem persist without the Coolbits & TripleBuffer options?

Yep - And problem 'persists' (I guess I already tried all configs... and all options in nvidia-settings...)

Quote:

Originally Posted by netlama
Have you verified that you're using the latest BIOS?

Hmm... are you speaking of the "Dell" bios ?
If yes: nope... will give a shot at it and give news...

Zapek 09-13-07 11:54 PM

Re: GeForce Go 7900 GS black flash screen
 
I flashed to the latest Dell BIOS and removed CoolBits and TrippleBuffer. No improvements so far, the bug still happens.

pijalu 09-14-07 04:09 PM

Re: GeForce Go 7900 GS black flash screen
 
Quote:

Originally Posted by pijalu
Hmm... are you speaking of the "Dell" bios ?
If yes: nope... will give a shot at it and give news...

Same as Zapek: Latest bios (A09) and still a flashing black screen..
So, what's next doctor ?

stefan42 09-15-07 06:57 AM

Re: GeForce Go 7900 GS black flash screen
 
Did you already try to set the mysterious PerfLevelSrc option?
/etc/modprobe.d/options:
options nvidia NVreg_RegistryDwords="PerfLevelSrc=0x2222"

It's never been explained by nvidia what it does, but it's evident that it helps some people (including me) to avoid flickering and XID errors.
It seems to disable adjustment of clock frequencies and helped in my case to avoid the flickering on a 7900 Go GS (Dell 9400). Of course the GPU gets hotter without clocking down so use it with care.

Zapek 09-15-07 10:03 PM

Re: GeForce Go 7900 GS black flash screen
 
I tried to set the PerfLevelSrc option but it didn't seem to change anything.

pijalu 09-16-07 02:30 PM

Re: GeForce Go 7900 GS black flash screen
 
Ok,

I didn't use the option given by Stefan since I really don't want to end up with a toasted laptop ;-)

But I tried the following option:
Code:

options nvidia NVreg_SoftEDIDs=0 NVreg_Mobile=1
(with 1 for Dell following documentation)

And it seems to give some improvements - I still get now and then a flashing screen BUT it does not continue every 30secs...

pijalu 09-22-07 10:08 AM

Re: GeForce Go 7900 GS black flash screen
 
Btw, issue continues with 100.14.19


All times are GMT -5. The time now is 10:44 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.