nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   nforce + RH 2.4.18-27.8.0 = depmod probs? (http://www.nvnews.net/vbulletin/showthread.php?t=9687)

audball 04-05-03 10:26 AM

nforce + RH 2.4.18-27.8.0 = depmod probs?
 
Has anybody tried building the nForce drivers on a RH8 system updated with the latest kernel/source/etc. (2.4.18-27.8.0 AFAIK)? When using either the tarball or a rebuilt SRPM, depmod is showing unresolved symbols for both nvaudio.o and nvnet.o.

Here's the output of 'depmod -e':

depmod: *** Unresolved symbols in /lib/modules/2.4.18-27.8.0/kernel/drivers/net/nvnet.o
depmod: eth_type_trans_R8045cc41
depmod: alloc_skb_R9e8e25db
depmod: softnet_data_R26f42c7c
depmod: netif_rx_Re317d4da
depmod: __netdev_watchdog_up_R9714b58f
depmod: skb_over_panic_Rff108adc
depmod: __kfree_skb_R0e3f5799
depmod: *** Unresolved symbols in /lib/modules/2.4.18-27.8.0/kernel/drivers/sound/nvaudio.o
depmod: register_sound_dsp_Rb862c1ee
depmod: no_llseek_R201c3a55
depmod: register_sound_mixer_R1a6137ca
depmod: add_wait_queue_R0cbf8a39
depmod: remove_wait_queue_Rb65338b9
depmod: __pollwait_Ra26a5ce8
depmod: mem_map_Re65347a5

audball 04-07-03 08:15 AM

Nevermind, I figured it out. 'ksyms' showed that all those symbols do exist and are exported; however, the symbol decoration hinted at the versions being different. A recompile fixed it. (Curious how the source RPM generated a kernel that didn't match the source...)

dnoyeB 04-22-03 09:47 PM

Hmm, I have the same problem. RH8, nforce1.

I got the kernel sources and compiled them and whatnot just to make sure everything was present. But I didn't use the recompiled kernel. I assumed it matched the current one. But the size is a little different eventhough I use the config file that was put there by the kernel install.

So after compiling the nforce dirvers I get the

[root@erasmus temp]# depmod -ae
depmod: *** Unresolved symbols in /lib/modules/2.4.18-27.8.0/kernel/drivers/net/nvnet.o
depmod: eth_type_trans_R8045cc41
depmod: alloc_skb_R9e8e25db
depmod: softnet_data_R26f42c7c
depmod: netif_rx_Re317d4da
depmod: __netdev_watchdog_up_R9714b58f
depmod: skb_over_panic_Rff108adc
depmod: __kfree_skb_R0e3f5799

So I am assuning as you do that I must actually run the compiled kernel. This is honestly, rediculous. I mean even if the compile is slightly different, it should still come from the same source.

What is up with this???

dnoyeB 04-23-03 06:05 PM

did u use xconfig? xconfig seems to have a bug that alters files that are loaded. I mean if you tell it to load file xyz, then save and exit, the new config wont necessarily match xyz.


All times are GMT -5. The time now is 12:05 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.