nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Gnome2 lockups due to bug in X driver (http://www.nvnews.net/vbulletin/showthread.php?t=97)

hobbes 07-28-02 06:35 PM

gnome2 complete lockups due to bug in X driver
 
Hi all,

I tried gnome2 on my box, only to experience complete lockups with nautilus2 (especially on image operations it seems, but I'm not sure of that). After some discussions it seems other people are experiencing those lockups, and they are related to X driver bugs.

The only fix I could find is to include Option "XaaNoScreenToScreenCopy" to the screen section in XF86Config-4. This fixes the lockups, at the price of a completely unusable desktop due to the time it takes to redraw any window that I move.

I'm using the 2960 drivers.

Has anyone experienced it and found a more usable solution to this ? Is nvidia working on a fix to those problems ?

--
Hobbes

Bern 07-28-02 07:42 PM

Do you get the same problem with any other WM?

hobbes 07-29-02 05:01 AM

No, I haven't tried another recently, and have never experienced this kind of behaviour. But it seems really related to an incompatibility between nautilus 2 and the nvidia drivers.

I tried the opensource nv driver, and it worked like a charm (but of course then I loose 3D acceleration). And disabling one specific acceleration (see original post) with nvidia cures the problem.

Discussing on a gnome list, I learned that nautilus 2 uses some rarely used drawing routines, which revealed bugs in several X display drivers. It seems the nvidia drivers are part of the bunch :-(

Thunderbird 07-29-02 05:05 AM

Perhaps your gnome 2.x packages aren't good. (or you compiled them yourself)

I'm here on debian sid/unstable and I'm using gnome 2.x using the nvidia 2960 drivers and I don't have any problems. Nautilus2 works fine. Perhaps there's an updated version of nautilus2 which doesn't have the problem. Or the problem might be a bug in your Xserver. (where the bug doesn't appear usign the opensource drivers)

hobbes 07-29-02 05:15 AM

Ha hem, I'm using the same system as yours, only I'm on sarge/testing. (the problem also occurs with woody)

Now I'm not alone to experience this on debian, see theses threads on the debian mailing lists :

http://lists.debian.org/debian-gtk-g.../msg00373.html

http://lists.debian.org/debian-gtk-g.../msg00253.html

http://lists.debian.org/debian-gtk-g.../msg00040.html

I tried the debian experimental gnome2 packages (which forced me to downgrade afterwards to gnome1, which is not a simple task, believe me), then set up a garnome system for a test user so I can test gnome2 without messing up my main user's configuration. The problem occured with both incarnations of gnome2.

For information, I'm with X 4.1.0, nvidia 2960 on a Geforce 256 DDR.

Thunderbird 07-29-02 05:46 AM

I would recommend you to switch to xfree86 4.2.0. There are some unofficial debs now made by the guys who maintain xfree86 in debian. Look here for the debs http://people.debian.org/~branden/

Recently I had some problems apt-getting some debs from there so I would recommend you to use a mirror site for branden's debs:
http://people.brainfood.com/~doogie/x4.2/

Perhaps this fixes your problems.

hobbes 07-29-02 06:39 AM

Yeah, I could do that, but these packages are quite experimental, and sid specific. I don't know how they will behave on woody/sarge.

And I made enough upgrade/downgrade/fix/incantation to satisfy the problem solver in me for some times now :-) Ok I will probably test these in some days if no other solution comes to light and I find the courrage/time to lauch this upgrade.

Thunderbird 07-29-02 06:43 AM

For the biggest part my system is still woody. It is actually woody + XFree86 4.2.0(exp) + KDE 3.0.2 and Gnome 2.x.

Just use those packages very likely they fix your problems.

hobbes 07-29-02 06:47 AM

You didn't have to recompile anything ? If you cazn confirm this, I might find the courrage to try it tonight :-)

Thunderbird 07-29-02 06:57 AM

I didn't have to compile anything. Just add the needed lines to your sources.list and then use apt-get :) (first apt-get update ofcourse)

dgently 07-29-02 02:50 PM

I think the lockup is related to the render-extension. I had the same problem with nautilus2 and xfree 4.1 (debian packages), but disabling the render-extension in the XF86Config-4 solved it:
Option "NoRenderAccel" "on"
Option "NoRenderExtension" "on"
in the Device Section. (maybe no render accel is enough, but i didn't test that)

I don't know how to disable the usage of the extension for gnome/gtk apps only (since im not a gnome user normally), but if there is a way, that might help also..

hobbes 07-29-02 04:38 PM

Ok, problem solved thanks to a post to the debian-gtk/gnome mailing-list : I just had to add Option "XaaNoOffscreenPixmaps" to my XF86Config file to make everything work without a noticeable performance hit.

This way I don't have to use the experimental X4.2 packages, I'll try them when they reach testing and try to remove that option and see what happens.

Thanks all a lot for the help.


All times are GMT -5. The time now is 12:26 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.