nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   terribly bad performance (~350fps) with Leadtek GeForce2 MX64 (http://www.nvnews.net/vbulletin/showthread.php?t=9800)

fish 04-07-03 03:04 PM

terribly bad performance (~350fps) with Leadtek GeForce2 MX64
Hi all!
I got this card (Leadtek Winfast FeForce2 MX64):

Today I started an opengl - project and had to reckognize that my graphics - performance is terribly bad:
GL_VERSION = 1.4.0 NVIDIA 43.49
GL_VENDOR = NVIDIA Corporation
GL_EXTENSIONS = GL_ARB_imaging GL_ARB_multitexture GL_ARB_point_parameters GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_window_pos GL_S3_s3tc GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_paletted_texture GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shared_texture_palette GL_EXT_stencil_wrap GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_vertex_array GL_IBM_texture_mirrored_repeat GL_KTX_buffer_region GL_NV_blend_square GL_NV_fence GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_packed_depth_stencil GL_NV_pixel_data_range GL_NV_point_sprite GL_NV_register_combiners GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_NV_texture_rectangle GL_NV_vertex_array_range GL_NV_vertex_array_range2 GL_NV_vertex_program GL_NV_vertex_program1_1 GL_NVX_ycrcb GL_SGIS_generate_mipmap GL_SGIS_multitexture GL_SGIS_texture_lod
1466 frames in 5.0 seconds = 293.200 FPS
1714 frames in 5.0 seconds = 342.800 FPS

The number is always around 350fps!

Here's the output of my proc-entries:
Host Bridge: VIA Technologies, Inc. VT8367 [KT266]
Fast Writes: Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000217:0x00000104
Fast Writes: Not Supported
SBA: Not Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000007:0x1f000104
Status: Enabled
AGP Rate: 4x
Fast Writes: Disabled
SBA: Disabled

My XF86Config is configured as suggested in the nvidia- READMEs (and X does not complain about anything - not even any uncommon warnings) - Everthing seems to be working perfect!

My CPU is a XP1800 and I got an ASUS A7V333 Mainboard.

Shall I change back to my "faster" TNT2 - Card ?!? - or has anyone got any hints?

A very sad

fish 04-07-03 03:33 PM

my logs & configs
1 Attachment(s)
Here's my config, my logs are attached:

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
Screen "Default Screen 2" LeftOf "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Logitech Mouse"
InputDevice "Tastatur Mouse"

Section "Files"
FontPath "unix/:7100"
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"

Section "Module"
Load "dbe"
# Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
# Load "speedo"
Load "type1"
# Load "vbe"
# Load "xie"

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
Option "XkbVariant" "nodeadkeys"

Section "InputDevice"
Identifier "Logitech Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
# Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"

Section "InputDevice"
Identifier "Tastatur Mouse"
Driver "mouse"
Option "Device" "/dev/psaux"
Option "Protocol" "ps/2"
Option "SendCoreEvents" "true"

Section "Monitor"
Identifier "Medion"
HorizSync 30.0 - 98.0
VertRefresh 50.0 - 160.0
Option "DPMS"

Section "Monitor"
Identifier "Belinea"
HorizSync 31.5 - 35.1
VertRefresh 50.0 - 70.0

Section "Device"
Identifier "nvidia"
Driver "nvidia"
VideoRam 32768
BusID "PCI:1:00:0"

Section "Device"
Identifier "s3virge"
Driver "s3virge"
BusID "PCI:0:12:0"

Section "Screen"
Identifier "Default Screen 2"
Device "s3virge"
Monitor "Belinea"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"

Section "Screen"
Identifier "Default Screen"
Device "nvidia"
Monitor "Medion"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x960" "1152x864" "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 4
Modes "1280x960" "1152x864" "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 8
Modes "1280x960" "1152x864" "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 15
Modes "1280x960" "1152x864" "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"

how 04-07-03 08:32 PM

well.. I am glad someone's got the same problem as I am. Now I know I am not the only one.

Igot same as you: (you got even better Motherboard)
Athlon xp 1800+
Geforce2 mx 400 64MB
I always get ~350fps with glxgears and other gl apps are really slow.

I tried everything.. upgrade kernels, nvidia drivers, and XFree86. Nothing works. so fustrating.

Nvidia please fix it.

Wolfman [TWP] 04-07-03 08:48 PM

It definately sounds like a problem there somewhere. After reading this post, I went and checked out the Glxgears output on my system:

(Work System)
MSI K7T266 Pro Mobo
AMD Athlon Thunderbird 1.4Ghz
GF2 MX400 (32MB)
RedHat 8.0 (with all the updates)
And the 43.49 Nvidia drivers

And this was my result from the Glxgears output.

3376 frames in 5.0 seconds = 675.200 FPS
3121 frames in 5.0 seconds = 624.200 FPS
3284 frames in 5.0 seconds = 656.800 FPS
3184 frames in 5.0 seconds = 636.800 FPS
3249 frames in 5.0 seconds = 649.800 FPS
3340 frames in 5.0 seconds = 668.000 FPS

Almost double what you guy's are getting and you even have faster CPU's. :confused:


how 04-08-03 02:47 AM

Thanks Wolfman for replying to this thread.
You have almost the same system as I am, therefore I think it will help more to find out what the problem is. May be you can help us out if you don't mind.

At the moment. this is my conclusion, I don't know if it is right. Fish has a better motherboard than mine K7S5A. so its not the motherboard.
its not the graphics card because I swapped for another one before.
I have the same Redhat 8.0, 4349 driver and GF2 mx with more RAM as you. Motherboard and CPU are different. Motherboard was ruled out. so I guess
the driver and athlonxp 1800+ combination not working properly.

Nvidia please look at this thread to fix this problem.

fish 04-08-03 04:14 AM

Another comparison:

An friend of mine got the same card, his CPU is an 1GH Athlon, mine is an 1.8GH Athlon XP, his software is exaclty the same as mine (Debian Woody).
He's getting about 1500 fps, which is 5 times more than me.

Maybe it really is the combination of this card with an XP cpu!

nvidia guys?!?!

how 04-08-03 04:35 AM

Thanks Fish.. evidently I think we found the problem.
The comparison you got is correct.
it is the nvidia drivers with athlon xp and Gf2 mx problem

Nvidia.. look into it please!

Wolfman [TWP] 04-08-03 06:23 AM

I forgot to mention that my system also has 512MB's of RAM. What are you guy's running?? I wonder wether that may also have something to do with it??

Although the XP did have some type of cache bug?? (Something to do with AGP/IDE constant use cause the bug to popup it's ugly head!?) Which maybe causing that problem. Even though Redhat kernel updates were supposed to fix that problem. Who knows? :confused: I might be barking up the wrong tree... :angel2:


bwkaz 04-08-03 08:35 AM

The problem is NOT the drivers in combination with an Athlon XP1800+ CPU. I have that exact setup, and I have no problems with framerates in glxgears whatsoever.

It might very well be the GF2 MX card -- those are fairly slow. I don't think they're quite that slow, but they are old.

I have 256MB RAM (PC2700), and I am using the 2.4.20 kernel, which disables the Athlon's speculative caching (which was the cause of the AGP bug that you were referring to, Wolfman -- the CPU will take control of AGP memory with regard to the cache, when the instruction stream only reads it, instead of writing, and if the video card later updates the same cache line, problems arise). 2.4.19 was actually the first kernel.org kernel that fixed that problem, though I believe it was included in RH's patches.

fish 04-08-03 10:27 AM

I know the GeForce2MX ain't the fastest card, but look at this:

My setup (256MB (2100) RAM, 1.8GH athlon XP):
1714 frames in 5.0 seconds = 342.800 FPS
Fast Writes: Not Supported
SBA: Not Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000007:0x1f000104

A friend's setup (same GPU, CPU half as fast, older mainboard, 128MB RAM):
7800 frames in 5.0 seconds = 1560.000 FPS
Fast Writes: Supported
SBA: Not Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000017:0x1f000104

It really is the same GPU!!!
Both same system (Debian Woody, self compiled 2.4.20 - kernel, both driver version 1.4.0 NVIDIA 43.49)

Kiamu 04-08-03 10:51 AM


have you tried to disable one of your cards for testing?

don't know if it is important, but i read something about sharing resources in your log file.

fish 04-08-03 11:09 AM

Of course I tried, didn't change anything (except of that the second card and monitor are disabled, of course)

All times are GMT -5. The time now is 12:21 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.