nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   cant get xorg to start at all (http://www.nvnews.net/vbulletin/showthread.php?t=98437)

edhunterbg 09-14-07 04:07 PM

cant get xorg to start at all
 
Hi guys

I have serious problem with the updated xorg.

Today I updated my /usr/src and recompiled my kerenel. I also made a big portupgrade -a, and now xorg and related ports are version 7.3. I reinstalled nvidia-driver from ports.
And rebooted. Gues what.... gdm cant start:
gdm[718]: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
...

So I decided to test without nvidia-driver and deinstalled it, then i deleted /etc/X11/xorg.conf and I made new clean xorg.conf with xorgconfig.

But this didnt help, again i got errors:
from messages:
gdm[9048]: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
gdm[9043]: Failed to start X server several times in a short time period; disabling display :0

from /var/log/xorg.0.log:
...
(II) Loading /usr/local/lib/xorg/modules/drivers//vga_drv.so
(II) Module vga: vendor="X.Org Foundation"
compiled for 7.2.0, module version = 4.1.0
Module class: X.Org Video Driver
ABI class: X.Org Video Driver, version 1.1
(EE) module ABI major version (1) doesn't match the server's version (2)(II) UnloadModule: "vga"
(II) Unloading /usr/local/lib/xorg/modules/drivers//vga_drv.so
(EE) Failed to load module "vga" (module requirement mismatch, 0)
...

and now I dont have X at all :((
need help!
10x in advance


p.s. specs: freebsd 6.2 i386, xorg 7.3, gnome 2.18.3

alexdupre 09-14-07 05:07 PM

Re: cant get xorg to start at all
 
There are two temporary workarounds for this issue:
1) start X.org with --ignoreABI
2) use the bundled "nv" driver

Said so, I hope a new driver will be released soon.

edhunterbg 09-15-07 04:48 AM

Re: cant get xorg to start at all
 
Quote:

Originally Posted by alexdupre
There are two temporary workarounds for this issue:
1) start X.org with --ignoreABI
2) use the bundled "nv" driver

Said so, I hope a new driver will be released soon.

it didnt help much :)

but after portupgrade -f xf86-* i got it running with nv driver, i'll wait for updated nvidia-driver.

rhurlin 09-15-07 05:41 AM

Re: cant get xorg to start at all
 
Quote:

Originally Posted by edhunterbg
it didnt help much :)

but after portupgrade -f xf86-* i got it running with nv driver, i'll wait for updated nvidia-driver.


I had the same problems after xorg update. Recompiling x11/nvidia-driver and starting xorg with 'startx -- -ignoreABI' (pay attention to hyphens!) helps. For using gdm or xdm you can read something in /usr/ports/UPDATING ...

Rainer


All times are GMT -5. The time now is 07:40 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.